diff mbox series

[v1,1/1] hte: Use kasprintf() instead of fixed buffer formatting

Message ID 20231010141123.3909596-1-andriy.shevchenko@linux.intel.com (mailing list archive)
State New
Headers show
Series [v1,1/1] hte: Use kasprintf() instead of fixed buffer formatting | expand

Commit Message

Andy Shevchenko Oct. 10, 2023, 2:11 p.m. UTC
Improve readability and maintainability by replacing a hardcoded string
allocation and formatting by the use of the kasprintf() helper.

Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
 drivers/hte/hte.c | 13 ++++---------
 1 file changed, 4 insertions(+), 9 deletions(-)

Comments

Dipen Patel Oct. 10, 2023, 4:12 p.m. UTC | #1
On 10/10/23 7:11 AM, Andy Shevchenko wrote:
> Improve readability and maintainability by replacing a hardcoded string
> allocation and formatting by the use of the kasprintf() helper.
> 
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> ---
>  drivers/hte/hte.c | 13 ++++---------
>  1 file changed, 4 insertions(+), 9 deletions(-)
> 
> diff --git a/drivers/hte/hte.c b/drivers/hte/hte.c
> index 1fd8d2d4528b..23a6eeb8c506 100644
> --- a/drivers/hte/hte.c
> +++ b/drivers/hte/hte.c
> @@ -17,8 +17,6 @@
>  #include <linux/debugfs.h>
>  #include <linux/device.h>
>  
> -#define HTE_TS_NAME_LEN		10
> -
>  /* Global list of the HTE devices */
>  static DEFINE_SPINLOCK(hte_lock);
>  static LIST_HEAD(hte_devices);
> @@ -389,13 +387,10 @@ static int __hte_req_ts(struct hte_ts_desc *desc, hte_ts_cb_t cb,
>  
>  	atomic_inc(&gdev->ts_req);
>  
> -	ei->line_name = NULL;
> -	if (!desc->attr.name) {
> -		ei->line_name = kzalloc(HTE_TS_NAME_LEN, GFP_KERNEL);
> -		if (ei->line_name)
> -			scnprintf(ei->line_name, HTE_TS_NAME_LEN, "ts_%u",
> -				  desc->attr.line_id);
> -	}
> +	if (desc->attr.name)
> +		ei->line_name = NULL;
> +	else
> +		ei->line_name = kasprintf(GFP_KERNEL, "ts_%u", desc->attr.line_id);
>  
>  	hte_ts_dbgfs_init(desc->attr.name == NULL ?
>  			  ei->line_name : desc->attr.name, ei);
Reviewed-by: Dipen Patel <dipenp@nvidia.com>
Andy Shevchenko Oct. 27, 2023, 12:39 p.m. UTC | #2
On Tue, Oct 10, 2023 at 09:12:09AM -0700, Dipen Patel wrote:
> On 10/10/23 7:11 AM, Andy Shevchenko wrote:
> > Improve readability and maintainability by replacing a hardcoded string
> > allocation and formatting by the use of the kasprintf() helper.

...

> >  	hte_ts_dbgfs_init(desc->attr.name == NULL ?
> >  			  ei->line_name : desc->attr.name, ei);
> Reviewed-by: Dipen Patel <dipenp@nvidia.com>

Thanks!

Who is the maintainer of this code?
If not you, shouldn't MAINTAINERS to be updated to reflect that?
Dipen Patel Oct. 27, 2023, 9:03 p.m. UTC | #3
On 10/27/23 5:39 AM, Andy Shevchenko wrote:
> On Tue, Oct 10, 2023 at 09:12:09AM -0700, Dipen Patel wrote:
>> On 10/10/23 7:11 AM, Andy Shevchenko wrote:
>>> Improve readability and maintainability by replacing a hardcoded string
>>> allocation and formatting by the use of the kasprintf() helper.
> 
> ...
> 
>>>  	hte_ts_dbgfs_init(desc->attr.name == NULL ?
>>>  			  ei->line_name : desc->attr.name, ei);
>> Reviewed-by: Dipen Patel <dipenp@nvidia.com>
> 
> Thanks!
> 
> Who is the maintainer of this code?
> If not you, shouldn't MAINTAINERS to be updated to reflect that?
> 
I am the maintainer, I am not sure how did I miss this patch for my for-next.
Let me push this right away.
diff mbox series

Patch

diff --git a/drivers/hte/hte.c b/drivers/hte/hte.c
index 1fd8d2d4528b..23a6eeb8c506 100644
--- a/drivers/hte/hte.c
+++ b/drivers/hte/hte.c
@@ -17,8 +17,6 @@ 
 #include <linux/debugfs.h>
 #include <linux/device.h>
 
-#define HTE_TS_NAME_LEN		10
-
 /* Global list of the HTE devices */
 static DEFINE_SPINLOCK(hte_lock);
 static LIST_HEAD(hte_devices);
@@ -389,13 +387,10 @@  static int __hte_req_ts(struct hte_ts_desc *desc, hte_ts_cb_t cb,
 
 	atomic_inc(&gdev->ts_req);
 
-	ei->line_name = NULL;
-	if (!desc->attr.name) {
-		ei->line_name = kzalloc(HTE_TS_NAME_LEN, GFP_KERNEL);
-		if (ei->line_name)
-			scnprintf(ei->line_name, HTE_TS_NAME_LEN, "ts_%u",
-				  desc->attr.line_id);
-	}
+	if (desc->attr.name)
+		ei->line_name = NULL;
+	else
+		ei->line_name = kasprintf(GFP_KERNEL, "ts_%u", desc->attr.line_id);
 
 	hte_ts_dbgfs_init(desc->attr.name == NULL ?
 			  ei->line_name : desc->attr.name, ei);