Message ID | 1415326063-8838-3-git-send-email-guihc.fnst@cn.fujitsu.com (mailing list archive) |
---|---|
State | Superseded |
Headers | show |
On Fri, Nov 07, 2014 at 10:07:43AM +0800, Gui Hecheng wrote: > The @fi_args->num_devices in @get_fs_info() does not include seed devices. > We could just correct it by searching the chunk tree and count how > many dev_items there are in total which includes seed devices. > > Signed-off-by: Gui Hecheng <guihc.fnst@cn.fujitsu.com> > --- > *Note* > This is just a temporary workaround to fix this problem in order to > make users happy, because a new ioctl or sysfs interface to handle this > problem needs more discussions and efforts. After the work implemented > and accepted, we could drop this. Nice, thanks. I agree that this kind of workaround is best possible for the moment, and I'm glad to see that it's not that much code to get the seeding devices right. This would also work with older kernels without the updated sysfs/ioctl interfaces, so this is likely to stay for a long time. > +u64 find_max_id(struct btrfs_ioctl_search_args *search_args, int nr_items) That's a very generic name for a function that does a very specialized thing, but I don't have a suggestion right now. > +int correct_fs_info(int fd, struct btrfs_ioctl_fs_info_args *fi_args) Same here, make fs_info correct but in what way? A comment would be good as well. -- To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
really nice fix. Thanks Gui. Anand On 08/11/2014 02:16, David Sterba wrote: > On Fri, Nov 07, 2014 at 10:07:43AM +0800, Gui Hecheng wrote: >> The @fi_args->num_devices in @get_fs_info() does not include seed devices. >> We could just correct it by searching the chunk tree and count how >> many dev_items there are in total which includes seed devices. >> >> Signed-off-by: Gui Hecheng <guihc.fnst@cn.fujitsu.com> >> --- >> *Note* >> This is just a temporary workaround to fix this problem in order to >> make users happy, because a new ioctl or sysfs interface to handle this >> problem needs more discussions and efforts. After the work implemented >> and accepted, we could drop this. > > Nice, thanks. I agree that this kind of workaround is best possible for > the moment, and I'm glad to see that it's not that much code to get the > seeding devices right. This would also work with older kernels without > the updated sysfs/ioctl interfaces, so this is likely to stay for a long > time. > >> +u64 find_max_id(struct btrfs_ioctl_search_args *search_args, int nr_items) > > That's a very generic name for a function that does a very specialized > thing, but I don't have a suggestion right now. > >> +int correct_fs_info(int fd, struct btrfs_ioctl_fs_info_args *fi_args) > > Same here, make fs_info correct but in what way? A comment would be good > as well. > -- > To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in > the body of a message to majordomo@vger.kernel.org > More majordomo info at http://vger.kernel.org/majordomo-info.html > -- To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On 7 November 2014 18:16, David Sterba <dsterba@suse.cz> wrote: > On Fri, Nov 07, 2014 at 10:07:43AM +0800, Gui Hecheng wrote: >> The @fi_args->num_devices in @get_fs_info() does not include seed devices. >> We could just correct it by searching the chunk tree and count how >> many dev_items there are in total which includes seed devices. >> >> Signed-off-by: Gui Hecheng <guihc.fnst@cn.fujitsu.com> >> --- >> *Note* >> This is just a temporary workaround to fix this problem in order to >> make users happy, because a new ioctl or sysfs interface to handle this >> problem needs more discussions and efforts. After the work implemented >> and accepted, we could drop this. > > Nice, thanks. I agree that this kind of workaround is best possible for > the moment, and I'm glad to see that it's not that much code to get the > seeding devices right. This would also work with older kernels without > the updated sysfs/ioctl interfaces, so this is likely to stay for a long > time. > >> +u64 find_max_id(struct btrfs_ioctl_search_args *search_args, int nr_items) > > That's a very generic name for a function that does a very specialized > thing, but I don't have a suggestion right now. Is find_max_device_id a suitable name? >> +int correct_fs_info(int fd, struct btrfs_ioctl_fs_info_args *fi_args) > > Same here, make fs_info correct but in what way? A comment would be good > as well. Sorry, no suggestion for this function name. Thanks, Mike -- To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On Sat, 2014-11-08 at 19:47 +0000, Mike Fleetwood wrote: > On 7 November 2014 18:16, David Sterba <dsterba@suse.cz> wrote: > > On Fri, Nov 07, 2014 at 10:07:43AM +0800, Gui Hecheng wrote: > >> The @fi_args->num_devices in @get_fs_info() does not include seed devices. > >> We could just correct it by searching the chunk tree and count how > >> many dev_items there are in total which includes seed devices. > >> > >> Signed-off-by: Gui Hecheng <guihc.fnst@cn.fujitsu.com> > >> --- > >> *Note* > >> This is just a temporary workaround to fix this problem in order to > >> make users happy, because a new ioctl or sysfs interface to handle this > >> problem needs more discussions and efforts. After the work implemented > >> and accepted, we could drop this. > > > > Nice, thanks. I agree that this kind of workaround is best possible for > > the moment, and I'm glad to see that it's not that much code to get the > > seeding devices right. This would also work with older kernels without > > the updated sysfs/ioctl interfaces, so this is likely to stay for a long > > time. > > > >> +u64 find_max_id(struct btrfs_ioctl_search_args *search_args, int nr_items) > > > > That's a very generic name for a function that does a very specialized > > thing, but I don't have a suggestion right now. > > Is find_max_device_id a suitable name? I think this one is really more clear. > >> +int correct_fs_info(int fd, struct btrfs_ioctl_fs_info_args *fi_args) > > > > Same here, make fs_info correct but in what way? A comment would be good > > as well. > > Sorry, no suggestion for this function name. may be @search_chunk_tree_for_fs_info? Thanks for the suggestions. -Gui > Thanks, > Mike -- To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/utils.c b/utils.c index 9bcc1a0..a6dcb8a 100644 --- a/utils.c +++ b/utils.c @@ -1781,6 +1781,73 @@ int get_device_info(int fd, u64 devid, return ret ? -errno : 0; } +u64 find_max_id(struct btrfs_ioctl_search_args *search_args, int nr_items) +{ + struct btrfs_dev_item *dev_item; + char *buf = search_args->buf; + + buf += (nr_items - 1) * (sizeof(struct btrfs_ioctl_search_header) + + sizeof(struct btrfs_dev_item)); + buf += sizeof(struct btrfs_ioctl_search_header); + + dev_item = (struct btrfs_dev_item *)buf; + + return btrfs_stack_device_id(dev_item); +} + +int correct_fs_info(int fd, struct btrfs_ioctl_fs_info_args *fi_args) +{ + int ret; + int max_items; + u64 start_devid = 1; + struct btrfs_ioctl_search_args search_args; + struct btrfs_ioctl_search_key *search_key = &search_args.key; + + fi_args->num_devices = 0; + + max_items = BTRFS_SEARCH_ARGS_BUFSIZE + / (sizeof(struct btrfs_ioctl_search_header) + + sizeof(struct btrfs_dev_item)); + + search_key->tree_id = BTRFS_CHUNK_TREE_OBJECTID; + search_key->min_objectid = BTRFS_DEV_ITEMS_OBJECTID; + search_key->max_objectid = BTRFS_DEV_ITEMS_OBJECTID; + search_key->min_type = BTRFS_DEV_ITEM_KEY; + search_key->max_type = BTRFS_DEV_ITEM_KEY; + search_key->min_transid = 0; + search_key->max_transid = (u64)-1; + search_key->nr_items = max_items; + search_key->max_offset = (u64)-1; + +again: + search_key->min_offset = start_devid; + + ret = ioctl(fd, BTRFS_IOC_TREE_SEARCH, &search_args); + if (ret < 0) + return -errno; + + fi_args->num_devices += (u64)search_key->nr_items; + + if (search_key->nr_items == max_items) { + start_devid = find_max_id(&search_args, + search_key->nr_items) + 1; + goto again; + } + + /* get the lastest max_id to stay consistent with the num_devices */ + if (search_key->nr_items == 0) + /* + * last tree_search returns an empty buf, use the devid of + * the last dev_item of the previous tree_search + */ + fi_args->max_id = start_devid - 1; + else + fi_args->max_id = find_max_id(&search_args, + search_key->nr_items); + + return 0; +} + /* * For a given path, fill in the ioctl fs_ and info_ args. * If the path is a btrfs mountpoint, fill info for all devices. @@ -1860,6 +1927,13 @@ int get_fs_info(char *path, struct btrfs_ioctl_fs_info_args *fi_args, ret = -errno; goto out; } + + /* + * The fs_args->num_devices does not include seed devices + */ + ret = correct_fs_info(fd, fi_args); + if (ret) + goto out; } if (!fi_args->num_devices)
The @fi_args->num_devices in @get_fs_info() does not include seed devices. We could just correct it by searching the chunk tree and count how many dev_items there are in total which includes seed devices. Signed-off-by: Gui Hecheng <guihc.fnst@cn.fujitsu.com> --- *Note* This is just a temporary workaround to fix this problem in order to make users happy, because a new ioctl or sysfs interface to handle this problem needs more discussions and efforts. After the work implemented and accepted, we could drop this. --- utils.c | 74 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 1 file changed, 74 insertions(+)