Message ID | a7e525e6-b0a2-4329-99fd-21c0af989d8e@HUB1.rwth-ad.de (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
I need the same key in my Thinkpad patch. But could you use a more descriptive name, such as KEY_ROTATE_DISPLAY? > On 4 Mar 2015, at 22:42, Stefan Brüns <stefan.bruens@rwth-aachen.de> wrote: > > Signed-off-by: Stefan Brüns <stefan.bruens@rwth-aachen.de> > --- > Requested 5 years ago: https://lkml.org/lkml/2010/2/27/36 > See also http://comments.gmane.org/gmane.linux.kernel.input/11175 > > include/uapi/linux/input.h | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/include/uapi/linux/input.h b/include/uapi/linux/input.h > index a1d7e93..0655300 100644 > --- a/include/uapi/linux/input.h > +++ b/include/uapi/linux/input.h > @@ -368,7 +368,7 @@ struct input_keymap_entry { > #define KEY_MSDOS 151 > #define KEY_COFFEE 152 /* AL Terminal Lock/Screensaver */ > #define KEY_SCREENLOCK KEY_COFFEE > -#define KEY_DIRECTION 153 > +#define KEY_DIRECTION 153 /* Display orientation for e.g. tablets */ > #define KEY_CYCLEWINDOWS 154 > #define KEY_MAIL 155 > #define KEY_BOOKMARKS 156 /* AC Bookmarks */ > -- > 2.1.4 > > -- > To unsubscribe from this list: send the line "unsubscribe linux-input" in > the body of a message to majordomo@vger.kernel.org > More majordomo info at http://vger.kernel.org/majordomo-info.html -- To unsubscribe from this list: send the line "unsubscribe linux-input" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
The description was requested 5 years ago: https://lkml.org/lkml/2010/2/27/36 See also http://comments.gmane.org/gmane.linux.kernel.input/11175 Stefan Brüns (2): Add alias KEY_ROTATE_DISPLAY for KEY_DIRECTION, add description use more descriptive KEY_ROTATE_DISPLAY instead of KEY_DIRECTION drivers/hid/hid-debug.c | 2 +- drivers/platform/x86/fujitsu-tablet.c | 6 +++--- drivers/platform/x86/hp-wmi.c | 2 +- include/uapi/linux/input.h | 3 ++- 4 files changed, 7 insertions(+), 6 deletions(-)
diff --git a/include/uapi/linux/input.h b/include/uapi/linux/input.h index a1d7e93..0655300 100644 --- a/include/uapi/linux/input.h +++ b/include/uapi/linux/input.h @@ -368,7 +368,7 @@ struct input_keymap_entry { #define KEY_MSDOS 151 #define KEY_COFFEE 152 /* AL Terminal Lock/Screensaver */ #define KEY_SCREENLOCK KEY_COFFEE -#define KEY_DIRECTION 153 +#define KEY_DIRECTION 153 /* Display orientation for e.g. tablets */ #define KEY_CYCLEWINDOWS 154 #define KEY_MAIL 155 #define KEY_BOOKMARKS 156 /* AC Bookmarks */
Signed-off-by: Stefan Brüns <stefan.bruens@rwth-aachen.de> --- Requested 5 years ago: https://lkml.org/lkml/2010/2/27/36 See also http://comments.gmane.org/gmane.linux.kernel.input/11175 include/uapi/linux/input.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)