Message ID | 1427968340-14879-1-git-send-email-human.hwang@samsung.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On 04/02/2015 11:52 AM, Hyungwon Hwang wrote: > Because the helper function which calls this callback checks whether > it is registered or not. It is not necessary if it does nothing. > So it would be better to remove the function for clarity. > > Signed-off-by: Hyungwon Hwang <human.hwang@samsung.com> Reviewed-by: Andrzej Hajda <a.hajda@samsung.com> -- Regards Andrzej > --- > drivers/gpu/drm/exynos/exynos_drm_dsi.c | 7 ------- > 1 file changed, 7 deletions(-) > > diff --git a/drivers/gpu/drm/exynos/exynos_drm_dsi.c b/drivers/gpu/drm/exynos/exynos_drm_dsi.c > index 05fe93d..0492715 100644 > --- a/drivers/gpu/drm/exynos/exynos_drm_dsi.c > +++ b/drivers/gpu/drm/exynos/exynos_drm_dsi.c > @@ -1473,12 +1473,6 @@ static int exynos_dsi_get_modes(struct drm_connector *connector) > return 0; > } > > -static int exynos_dsi_mode_valid(struct drm_connector *connector, > - struct drm_display_mode *mode) > -{ > - return MODE_OK; > -} > - > static struct drm_encoder * > exynos_dsi_best_encoder(struct drm_connector *connector) > { > @@ -1489,7 +1483,6 @@ exynos_dsi_best_encoder(struct drm_connector *connector) > > static struct drm_connector_helper_funcs exynos_dsi_connector_helper_funcs = { > .get_modes = exynos_dsi_get_modes, > - .mode_valid = exynos_dsi_mode_valid, > .best_encoder = exynos_dsi_best_encoder, > }; > >
On 2015? 04? 02? 18:52, Hyungwon Hwang wrote: > Because the helper function which calls this callback checks whether > it is registered or not. It is not necessary if it does nothing. > So it would be better to remove the function for clarity. Applied. Thanks, Inki Dae > > Signed-off-by: Hyungwon Hwang <human.hwang@samsung.com> > --- > drivers/gpu/drm/exynos/exynos_drm_dsi.c | 7 ------- > 1 file changed, 7 deletions(-) > > diff --git a/drivers/gpu/drm/exynos/exynos_drm_dsi.c b/drivers/gpu/drm/exynos/exynos_drm_dsi.c > index 05fe93d..0492715 100644 > --- a/drivers/gpu/drm/exynos/exynos_drm_dsi.c > +++ b/drivers/gpu/drm/exynos/exynos_drm_dsi.c > @@ -1473,12 +1473,6 @@ static int exynos_dsi_get_modes(struct drm_connector *connector) > return 0; > } > > -static int exynos_dsi_mode_valid(struct drm_connector *connector, > - struct drm_display_mode *mode) > -{ > - return MODE_OK; > -} > - > static struct drm_encoder * > exynos_dsi_best_encoder(struct drm_connector *connector) > { > @@ -1489,7 +1483,6 @@ exynos_dsi_best_encoder(struct drm_connector *connector) > > static struct drm_connector_helper_funcs exynos_dsi_connector_helper_funcs = { > .get_modes = exynos_dsi_get_modes, > - .mode_valid = exynos_dsi_mode_valid, > .best_encoder = exynos_dsi_best_encoder, > }; > >
diff --git a/drivers/gpu/drm/exynos/exynos_drm_dsi.c b/drivers/gpu/drm/exynos/exynos_drm_dsi.c index 05fe93d..0492715 100644 --- a/drivers/gpu/drm/exynos/exynos_drm_dsi.c +++ b/drivers/gpu/drm/exynos/exynos_drm_dsi.c @@ -1473,12 +1473,6 @@ static int exynos_dsi_get_modes(struct drm_connector *connector) return 0; } -static int exynos_dsi_mode_valid(struct drm_connector *connector, - struct drm_display_mode *mode) -{ - return MODE_OK; -} - static struct drm_encoder * exynos_dsi_best_encoder(struct drm_connector *connector) { @@ -1489,7 +1483,6 @@ exynos_dsi_best_encoder(struct drm_connector *connector) static struct drm_connector_helper_funcs exynos_dsi_connector_helper_funcs = { .get_modes = exynos_dsi_get_modes, - .mode_valid = exynos_dsi_mode_valid, .best_encoder = exynos_dsi_best_encoder, };
Because the helper function which calls this callback checks whether it is registered or not. It is not necessary if it does nothing. So it would be better to remove the function for clarity. Signed-off-by: Hyungwon Hwang <human.hwang@samsung.com> --- drivers/gpu/drm/exynos/exynos_drm_dsi.c | 7 ------- 1 file changed, 7 deletions(-)