diff mbox

[V2,01/40] staging: wilc1000: rename ssidLen of struct join_bss_param

Message ID 1444970290-17609-1-git-send-email-tony.cho@atmel.com (mailing list archive)
State Not Applicable
Delegated to: Kalle Valo
Headers show

Commit Message

Tony Cho Oct. 16, 2015, 4:37 a.m. UTC
From: Leo Kim <leo.kim@atmel.com>

This patch renames ssidLen of struct join_bss_param to ssid_len
to avoid CamelCase naming convention.

Signed-off-by: Leo Kim <leo.kim@atmel.com>
Signed-off-by: Tony Cho <tony.cho@atmel.com>
---
 drivers/staging/wilc1000/host_interface.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Greg KH Oct. 17, 2015, 4:59 a.m. UTC | #1
On Fri, Oct 16, 2015 at 01:37:31PM +0900, Tony Cho wrote:
> From: Leo Kim <leo.kim@atmel.com>
> 
> This patch renames ssidLen of struct join_bss_param to ssid_len
> to avoid CamelCase naming convention.
> 
> Signed-off-by: Leo Kim <leo.kim@atmel.com>
> Signed-off-by: Tony Cho <tony.cho@atmel.com>
> ---
>  drivers/staging/wilc1000/host_interface.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

Doesn't apply, I missed that you sent this as v2, why did you do that?
What was wrong with v1?

thanks,

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Tony Cho Oct. 19, 2015, 1:32 a.m. UTC | #2
On 2015? 10? 17? 13:59, Greg KH wrote:
> On Fri, Oct 16, 2015 at 01:37:31PM +0900, Tony Cho wrote:
>> From: Leo Kim <leo.kim@atmel.com>
>>
>> This patch renames ssidLen of struct join_bss_param to ssid_len
>> to avoid CamelCase naming convention.
>>
>> Signed-off-by: Leo Kim <leo.kim@atmel.com>
>> Signed-off-by: Tony Cho <tony.cho@atmel.com>
>> ---
>>   drivers/staging/wilc1000/host_interface.c | 4 ++--
>>   1 file changed, 2 insertions(+), 2 deletions(-)
> Doesn't apply, I missed that you sent this as v2, why did you do that?
> What was wrong with v1?

This series of V2 includes Dan's suggestion, we don't have to add one blank line between malloc and null check if-statement.

In addition, some of global variables are declared as "static" because they are used in only one file so kbuild test robot indicated they had better be declared as "static".

So, I sent the series of them as V2. I can find the V1 of this series are already accepted so I will later make separate patch for them.

Thanks,

Tony.

> thanks,
>
> greg k-h

--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Dan Carpenter Oct. 19, 2015, 3:09 p.m. UTC | #3
On Mon, Oct 19, 2015 at 10:32:10AM +0900, Tony Cho wrote:
> 
> 
> On 2015? 10? 17? 13:59, Greg KH wrote:
> >On Fri, Oct 16, 2015 at 01:37:31PM +0900, Tony Cho wrote:
> >>From: Leo Kim <leo.kim@atmel.com>
> >>
> >>This patch renames ssidLen of struct join_bss_param to ssid_len
> >>to avoid CamelCase naming convention.
> >>
> >>Signed-off-by: Leo Kim <leo.kim@atmel.com>
> >>Signed-off-by: Tony Cho <tony.cho@atmel.com>
> >>---
> >>  drivers/staging/wilc1000/host_interface.c | 4 ++--
> >>  1 file changed, 2 insertions(+), 2 deletions(-)
> >Doesn't apply, I missed that you sent this as v2, why did you do that?
> >What was wrong with v1?
> 
> This series of V2 includes Dan's suggestion, we don't have to add one blank line between malloc and null check if-statement.
> 

I said that that patch was fine.  I was intending that you change all of
them in a later patch.  I really try to not delay progress with small
review comments.

regards,
dan carpenter

--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/staging/wilc1000/host_interface.c
index 04f3bc2..e2588ef 100644
--- a/drivers/staging/wilc1000/host_interface.c
+++ b/drivers/staging/wilc1000/host_interface.c
@@ -207,7 +207,7 @@  struct join_bss_param {
 	u16 cap_info;
 	u8 au8bssid[6];
 	char ssid[MAX_SSID_LEN];
-	u8 ssidLen;
+	u8 ssid_len;
 	u8 supp_rates[MAX_RATES_SUPPORTED + 1];
 	u8 ht_capable;
 	u8 wmm_cap;
@@ -4934,7 +4934,7 @@  static void *host_int_ParseJoinBssParam(tstrNetworkInfo *ptstrNetworkInfo)
 		pNewJoinBssParam->cap_info = ptstrNetworkInfo->u16CapInfo;
 		memcpy(pNewJoinBssParam->au8bssid, ptstrNetworkInfo->au8bssid, 6);
 		memcpy((u8 *)pNewJoinBssParam->ssid, ptstrNetworkInfo->au8ssid, ptstrNetworkInfo->u8SsidLen + 1);
-		pNewJoinBssParam->ssidLen = ptstrNetworkInfo->u8SsidLen;
+		pNewJoinBssParam->ssid_len = ptstrNetworkInfo->u8SsidLen;
 		memset(pNewJoinBssParam->rsn_pcip_policy, 0xFF, 3);
 		memset(pNewJoinBssParam->rsn_auth_policy, 0xFF, 3);