Message ID | 1464129345-18985-14-git-send-email-ddaney.cavm@gmail.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Tue, May 24, 2016 at 03:35:43PM -0700, David Daney wrote: > From: David Daney <david.daney@cavium.com> > > Follow-on arm64 ACPI/NUMA patches need to map MADT entries very early > (before kmalloc is usable). > > Add acpi_map_madt_entry() which, indirectly, uses > early_memremap()/early_memunmap() to access the table and parse out > the mpidr. The existing implementation of map_madt_entry() is > modified to take a pointer to the MADT as a parameter and the callers > adjusted. > > Signed-off-by: David Daney <david.daney@cavium.com> Acked-by: Catalin Marinas <catalin.marinas@arm.com>
On 2016/5/25 6:35, David Daney wrote: > From: David Daney <david.daney@cavium.com> > > Follow-on arm64 ACPI/NUMA patches need to map MADT entries very early > (before kmalloc is usable). > > Add acpi_map_madt_entry() which, indirectly, uses > early_memremap()/early_memunmap() to access the table and parse out > the mpidr. The existing implementation of map_madt_entry() is > modified to take a pointer to the MADT as a parameter and the callers > adjusted. > > Signed-off-by: David Daney <david.daney@cavium.com> > --- > drivers/acpi/processor_core.c | 26 ++++++++++++++++++++++---- > include/acpi/processor.h | 1 + > 2 files changed, 23 insertions(+), 4 deletions(-) > > diff --git a/drivers/acpi/processor_core.c b/drivers/acpi/processor_core.c > index 33a38d6..9125d7d 100644 > --- a/drivers/acpi/processor_core.c > +++ b/drivers/acpi/processor_core.c > @@ -108,13 +108,12 @@ static int map_gicc_mpidr(struct acpi_subtable_header *entry, > return -EINVAL; > } > > -static phys_cpuid_t map_madt_entry(int type, u32 acpi_id) > +static phys_cpuid_t map_madt_entry(struct acpi_table_madt *madt, > + int type, u32 acpi_id) > { > unsigned long madt_end, entry; > phys_cpuid_t phys_id = PHYS_CPUID_INVALID; /* CPU hardware ID */ > - struct acpi_table_madt *madt; > > - madt = get_madt_table(); > if (!madt) > return phys_id; > > @@ -145,6 +144,25 @@ static phys_cpuid_t map_madt_entry(int type, u32 acpi_id) > return phys_id; > } > > +phys_cpuid_t __init acpi_map_madt_entry(u32 acpi_id) > +{ > + struct acpi_table_madt *madt = NULL; > + acpi_size tbl_size; > + phys_cpuid_t rv; > + > + acpi_get_table_with_size(ACPI_SIG_MADT, 0, > + (struct acpi_table_header **)&madt, > + &tbl_size); > + if (!madt) > + return PHYS_CPUID_INVALID; > + > + rv = map_madt_entry(madt, 1, acpi_id); Just nit-pick, pass 1 here means we need to define an acpi processor device object in DSDT (see function map_gicc_mpidr(), device_declaration), it would be fine for x2apic and gic mode, but not for lapic mode, since the function name is acpi_map_madt_entry which is general for all architecture, it will confuse people I think. How about rename acpi_map_madt_entry() to acpi_map_madt_gicc_entry()? It's only used for AMR64 to get mpidrs from GICC entries using acpi_id, other than that, it's good to me. Thanks Hanjun
diff --git a/drivers/acpi/processor_core.c b/drivers/acpi/processor_core.c index 33a38d6..9125d7d 100644 --- a/drivers/acpi/processor_core.c +++ b/drivers/acpi/processor_core.c @@ -108,13 +108,12 @@ static int map_gicc_mpidr(struct acpi_subtable_header *entry, return -EINVAL; } -static phys_cpuid_t map_madt_entry(int type, u32 acpi_id) +static phys_cpuid_t map_madt_entry(struct acpi_table_madt *madt, + int type, u32 acpi_id) { unsigned long madt_end, entry; phys_cpuid_t phys_id = PHYS_CPUID_INVALID; /* CPU hardware ID */ - struct acpi_table_madt *madt; - madt = get_madt_table(); if (!madt) return phys_id; @@ -145,6 +144,25 @@ static phys_cpuid_t map_madt_entry(int type, u32 acpi_id) return phys_id; } +phys_cpuid_t __init acpi_map_madt_entry(u32 acpi_id) +{ + struct acpi_table_madt *madt = NULL; + acpi_size tbl_size; + phys_cpuid_t rv; + + acpi_get_table_with_size(ACPI_SIG_MADT, 0, + (struct acpi_table_header **)&madt, + &tbl_size); + if (!madt) + return PHYS_CPUID_INVALID; + + rv = map_madt_entry(madt, 1, acpi_id); + + early_acpi_os_unmap_memory(madt, tbl_size); + + return rv; +} + static phys_cpuid_t map_mat_entry(acpi_handle handle, int type, u32 acpi_id) { struct acpi_buffer buffer = { ACPI_ALLOCATE_BUFFER, NULL }; @@ -185,7 +203,7 @@ phys_cpuid_t acpi_get_phys_id(acpi_handle handle, int type, u32 acpi_id) phys_id = map_mat_entry(handle, type, acpi_id); if (invalid_phys_cpuid(phys_id)) - phys_id = map_madt_entry(type, acpi_id); + phys_id = map_madt_entry(get_madt_table(), type, acpi_id); return phys_id; } diff --git a/include/acpi/processor.h b/include/acpi/processor.h index 6f1805d..f473e66 100644 --- a/include/acpi/processor.h +++ b/include/acpi/processor.h @@ -309,6 +309,7 @@ static inline int acpi_processor_get_bios_limit(int cpu, unsigned int *limit) /* in processor_core.c */ phys_cpuid_t acpi_get_phys_id(acpi_handle, int type, u32 acpi_id); +phys_cpuid_t acpi_map_madt_entry(u32 acpi_id); int acpi_map_cpuid(phys_cpuid_t phys_id, u32 acpi_id); int acpi_get_cpuid(acpi_handle, int type, u32 acpi_id);