Message ID | 1467794875-5237-3-git-send-email-eric.auger@redhat.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Hi, On 06/07/16 09:47, Eric Auger wrote: > Extend kvm_kernel_irq_routing_entry to transport the device id > field, devid. A new flags field makes possible to indicate the > devid is valid. Those additions are used for ARM GICv3 ITS MSI > injection. > > Signed-off-by: Eric Auger <eric.auger@redhat.com> > Acked-by: Christoffer Dall <christoffer.dall@linaro.org> > > --- > v4 -> v5: > - add Christoffer's R-b > > v2 -> v3: > - add flags > > v1 -> v2: > - replace msi_msg field by a struct composed of msi_msg and devid > > RFC -> PATCH: > - reword the commit message after change in first patch (uapi) > --- > include/linux/kvm_host.h | 6 +++++- > 1 file changed, 5 insertions(+), 1 deletion(-) > > diff --git a/include/linux/kvm_host.h b/include/linux/kvm_host.h > index c87fe6f..fffa299 100644 > --- a/include/linux/kvm_host.h > +++ b/include/linux/kvm_host.h > @@ -317,7 +317,11 @@ struct kvm_kernel_irq_routing_entry { > unsigned irqchip; > unsigned pin; > } irqchip; > - struct msi_msg msi; > + struct { > + struct msi_msg msi; > + u32 flags; > + u32 devid; I wonder if we should rename those two members to have an "msi_" prefix. Otherwise they turn into generic "route.flags" and "route.devid" (as seen in the next patch), which is a bit misleading. Cheers, Andre. > + }; > struct kvm_s390_adapter_int adapter; > struct kvm_hv_sint hv_sint; > }; > -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/include/linux/kvm_host.h b/include/linux/kvm_host.h index c87fe6f..fffa299 100644 --- a/include/linux/kvm_host.h +++ b/include/linux/kvm_host.h @@ -317,7 +317,11 @@ struct kvm_kernel_irq_routing_entry { unsigned irqchip; unsigned pin; } irqchip; - struct msi_msg msi; + struct { + struct msi_msg msi; + u32 flags; + u32 devid; + }; struct kvm_s390_adapter_int adapter; struct kvm_hv_sint hv_sint; };