diff mbox

SMB2: Fix share type handling

Message ID 20161121215352.3183-1-christophe.jaillet@wanadoo.fr (mailing list archive)
State New, archived
Headers show

Commit Message

Christophe JAILLET Nov. 21, 2016, 9:53 p.m. UTC
In fs/cifs/smb2pdu.h, we have:
#define SMB2_SHARE_TYPE_DISK    0x01
#define SMB2_SHARE_TYPE_PIPE    0x02
#define SMB2_SHARE_TYPE_PRINT   0x03

Knowing that, with the current code, the SMB2_SHARE_TYPE_PRINT case can
never trigger and printer share would be interpreted as disk share.

So, test the ShareType value for equality instead.

While at it, add some { } to fix a small style issue.

Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
---
Compile-tested only.

The proposed patch changes a bit the semantic as no masking is performed
anymore. If some upper bits in 'ShareType' are set, it would now be rejected
instead of silently accepted.
---
 fs/cifs/smb2pdu.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Walter Harms Nov. 22, 2016, 8:19 a.m. UTC | #1
Am 21.11.2016 22:53, schrieb Christophe JAILLET:
> In fs/cifs/smb2pdu.h, we have:
> #define SMB2_SHARE_TYPE_DISK    0x01
> #define SMB2_SHARE_TYPE_PIPE    0x02
> #define SMB2_SHARE_TYPE_PRINT   0x03
> 
> Knowing that, with the current code, the SMB2_SHARE_TYPE_PRINT case can
> never trigger and printer share would be interpreted as disk share.
> 
> So, test the ShareType value for equality instead.
> 
> While at it, add some { } to fix a small style issue.
> 
> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
> ---
> Compile-tested only.
> 
> The proposed patch changes a bit the semantic as no masking is performed
> anymore. If some upper bits in 'ShareType' are set, it would now be rejected
> instead of silently accepted.
> ---
>  fs/cifs/smb2pdu.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/fs/cifs/smb2pdu.c b/fs/cifs/smb2pdu.c
> index 5ca5ea4668a1..600f52994fd9 100644
> --- a/fs/cifs/smb2pdu.c
> +++ b/fs/cifs/smb2pdu.c
> @@ -1143,12 +1143,12 @@ SMB2_tcon(const unsigned int xid, struct cifs_ses *ses, const char *tree,
>  		goto tcon_exit;
>  	}
>  
> -	if (rsp->ShareType & SMB2_SHARE_TYPE_DISK)
> +	if (rsp->ShareType == SMB2_SHARE_TYPE_DISK) {
>  		cifs_dbg(FYI, "connection to disk share\n");
> -	else if (rsp->ShareType & SMB2_SHARE_TYPE_PIPE) {
> +	} else if (rsp->ShareType == SMB2_SHARE_TYPE_PIPE) {
>  		tcon->ipc = true;
>  		cifs_dbg(FYI, "connection to pipe share\n");
> -	} else if (rsp->ShareType & SMB2_SHARE_TYPE_PRINT) {
> +	} else if (rsp->ShareType == SMB2_SHARE_TYPE_PRINT) {
>  		tcon->print = true;
>  		cifs_dbg(FYI, "connection to printer\n");
>  	} else {


perhaps a switch/case is better suited for this ?
looks more readable.

re,
 wh


switch(sp->ShareType ) {
case SMB2_SHARE_TYPE_DISK:
	cifs_dbg(FYI, "connection to disk share\n");
	break;
case SMB2_SHARE_TYPE_PIPE:
	tcon->ipc = true;
	cifs_dbg(FYI, "connection to pipe share\n");
	break;
case SMB2_SHARE_TYPE_PRINT:
	tcon->ipc = true;
	cifs_dbg(FYI, "connection to printer\n");
	break;
default:
--
To unsubscribe from this list: send the line "unsubscribe linux-cifs" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Aurélien Aptel Nov. 22, 2016, 12:18 p.m. UTC | #2
Christophe JAILLET <christophe.jaillet@wanadoo.fr> writes:
> Knowing that, with the current code, the SMB2_SHARE_TYPE_PRINT case can
> never trigger and printer share would be interpreted as disk share.

I've checked the SMB2 specs ([MS-SMB2] 3.2.5.5), I can confirm these are
the 3 only options. No upper bits are supposed to be set.

> So, test the ShareType value for equality instead.
>
> While at it, add some { } to fix a small style issue.
>
> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
> ---
> Compile-tested only.
>
> The proposed patch changes a bit the semantic as no masking is performed
> anymore. If some upper bits in 'ShareType' are set, it would now be rejected
> instead of silently accepted.

The semantic change is correct. I also think a switch would be more
appropriate. Beside this, Looks Good To Me.
diff mbox

Patch

diff --git a/fs/cifs/smb2pdu.c b/fs/cifs/smb2pdu.c
index 5ca5ea4668a1..600f52994fd9 100644
--- a/fs/cifs/smb2pdu.c
+++ b/fs/cifs/smb2pdu.c
@@ -1143,12 +1143,12 @@  SMB2_tcon(const unsigned int xid, struct cifs_ses *ses, const char *tree,
 		goto tcon_exit;
 	}
 
-	if (rsp->ShareType & SMB2_SHARE_TYPE_DISK)
+	if (rsp->ShareType == SMB2_SHARE_TYPE_DISK) {
 		cifs_dbg(FYI, "connection to disk share\n");
-	else if (rsp->ShareType & SMB2_SHARE_TYPE_PIPE) {
+	} else if (rsp->ShareType == SMB2_SHARE_TYPE_PIPE) {
 		tcon->ipc = true;
 		cifs_dbg(FYI, "connection to pipe share\n");
-	} else if (rsp->ShareType & SMB2_SHARE_TYPE_PRINT) {
+	} else if (rsp->ShareType == SMB2_SHARE_TYPE_PRINT) {
 		tcon->print = true;
 		cifs_dbg(FYI, "connection to printer\n");
 	} else {