Message ID | 20170119140944.19051-1-abailon@baylibre.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Thursday 19 January 2017 07:39 PM, Alexandre Bailon wrote: > Add usb20 to the list of clock supported by PM runtime. > > Signed-off-by: Alexandre Bailon <abailon@baylibre.com> > --- > arch/arm/mach-davinci/pm_domain.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/arch/arm/mach-davinci/pm_domain.c b/arch/arm/mach-davinci/pm_domain.c > index 78eac2c..66471f2 100644 > --- a/arch/arm/mach-davinci/pm_domain.c > +++ b/arch/arm/mach-davinci/pm_domain.c > @@ -23,7 +23,7 @@ static struct dev_pm_domain davinci_pm_domain = { > > static struct pm_clk_notifier_block platform_bus_notifier = { > .pm_domain = &davinci_pm_domain, > - .con_ids = { "fck", "master", "slave", NULL }, > + .con_ids = { "fck", "master", "slave", "usb20", NULL }, Instead of doing this, can we drop the con_id from musb clock? Looking at the USB clocking diagram in the TRM. There is a single clock input to the USB 2.0 subsystem. There is no real need for a con_id at all. Thanks, Sekhar -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On 01/19/2017 03:48 PM, Sekhar Nori wrote: > On Thursday 19 January 2017 07:39 PM, Alexandre Bailon wrote: >> Add usb20 to the list of clock supported by PM runtime. >> >> Signed-off-by: Alexandre Bailon <abailon@baylibre.com> >> --- >> arch/arm/mach-davinci/pm_domain.c | 2 +- >> 1 file changed, 1 insertion(+), 1 deletion(-) >> >> diff --git a/arch/arm/mach-davinci/pm_domain.c b/arch/arm/mach-davinci/pm_domain.c >> index 78eac2c..66471f2 100644 >> --- a/arch/arm/mach-davinci/pm_domain.c >> +++ b/arch/arm/mach-davinci/pm_domain.c >> @@ -23,7 +23,7 @@ static struct dev_pm_domain davinci_pm_domain = { >> >> static struct pm_clk_notifier_block platform_bus_notifier = { >> .pm_domain = &davinci_pm_domain, >> - .con_ids = { "fck", "master", "slave", NULL }, >> + .con_ids = { "fck", "master", "slave", "usb20", NULL }, > > Instead of doing this, can we drop the con_id from musb clock? Looking > at the USB clocking diagram in the TRM. There is a single clock input to > the USB 2.0 subsystem. There is no real need for a con_id at all. Currently, the con_id is required to get the usb20 clock from usb-da8xx.c I will try to figure out which changes are required remove con_id. > > Thanks, > Sekhar > Thanks, Alexandre -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On 01/19/2017 09:08 AM, Alexandre Bailon wrote: > On 01/19/2017 03:48 PM, Sekhar Nori wrote: >> On Thursday 19 January 2017 07:39 PM, Alexandre Bailon wrote: >>> Add usb20 to the list of clock supported by PM runtime. >>> >>> Signed-off-by: Alexandre Bailon <abailon@baylibre.com> >>> --- >>> arch/arm/mach-davinci/pm_domain.c | 2 +- >>> 1 file changed, 1 insertion(+), 1 deletion(-) >>> >>> diff --git a/arch/arm/mach-davinci/pm_domain.c b/arch/arm/mach-davinci/pm_domain.c >>> index 78eac2c..66471f2 100644 >>> --- a/arch/arm/mach-davinci/pm_domain.c >>> +++ b/arch/arm/mach-davinci/pm_domain.c >>> @@ -23,7 +23,7 @@ static struct dev_pm_domain davinci_pm_domain = { >>> >>> static struct pm_clk_notifier_block platform_bus_notifier = { >>> .pm_domain = &davinci_pm_domain, >>> - .con_ids = { "fck", "master", "slave", NULL }, >>> + .con_ids = { "fck", "master", "slave", "usb20", NULL }, >> >> Instead of doing this, can we drop the con_id from musb clock? Looking >> at the USB clocking diagram in the TRM. There is a single clock input to >> the USB 2.0 subsystem. There is no real need for a con_id at all. > Currently, the con_id is required to get the usb20 clock from usb-da8xx.c > I will try to figure out which changes are required remove con_id. It most probably should be renamed to "fck" then it should work with your patch "[PATCH v3 5/5] usb: musb: da8xx: Add a primary support of PM runtime".
diff --git a/arch/arm/mach-davinci/pm_domain.c b/arch/arm/mach-davinci/pm_domain.c index 78eac2c..66471f2 100644 --- a/arch/arm/mach-davinci/pm_domain.c +++ b/arch/arm/mach-davinci/pm_domain.c @@ -23,7 +23,7 @@ static struct dev_pm_domain davinci_pm_domain = { static struct pm_clk_notifier_block platform_bus_notifier = { .pm_domain = &davinci_pm_domain, - .con_ids = { "fck", "master", "slave", NULL }, + .con_ids = { "fck", "master", "slave", "usb20", NULL }, }; static int __init davinci_pm_runtime_init(void)
Add usb20 to the list of clock supported by PM runtime. Signed-off-by: Alexandre Bailon <abailon@baylibre.com> --- arch/arm/mach-davinci/pm_domain.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)