Message ID | 1485523815-9629-4-git-send-email-dan@emutex.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Fri, Jan 27, 2017 at 01:30:15PM +0000, Dan O'Donovan wrote: > + if (acpi_of_modalias(adev, spi->modalias, sizeof(spi->modalias))) > + strlcpy(spi->modalias, acpi_device_hid(adev), > + sizeof(spi->modalias)); I can't help but think that this would be simpler to use if the interface were something like acpi_set_modalias() and it did the fallback to the ACPI HID internally. It'd both avoid a small amount of code duplication and make the code read a bit more naturally - I have to think to realise that this means "if there isn't an OF name use the HID" since it looks like a boolean function. Then again just putting a != 0 in the test would have the same effect probably.
diff --git a/drivers/spi/spi.c b/drivers/spi/spi.c index 656dd3e..9a8c880 100644 --- a/drivers/spi/spi.c +++ b/drivers/spi/spi.c @@ -1722,13 +1722,20 @@ static acpi_status acpi_register_spi_device(struct spi_master *master, return AE_OK; } + /* + * Populate modalias from compatible property if available, + * otherwise use native ACPI information + */ + if (acpi_of_modalias(adev, spi->modalias, sizeof(spi->modalias))) + strlcpy(spi->modalias, acpi_device_hid(adev), + sizeof(spi->modalias)); + if (spi->irq < 0) spi->irq = acpi_dev_gpio_irq_get(adev, 0); acpi_device_set_enumerated(adev); adev->power.flags.ignore_parent = true; - strlcpy(spi->modalias, acpi_device_hid(adev), sizeof(spi->modalias)); if (spi_add_device(spi)) { adev->power.flags.ignore_parent = false; dev_err(&master->dev, "failed to add SPI device %s from ACPI\n",