Message ID | 1486516546-187771-2-git-send-email-shawn.lin@rock-chips.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
[...] > diff --git a/drivers/mmc/core/quirks.c b/drivers/mmc/core/quirks.h > similarity index 95% > rename from drivers/mmc/core/quirks.c > rename to drivers/mmc/core/quirks.h > index bf25a9c..f3bbfcb7 100644 > --- a/drivers/mmc/core/quirks.c > +++ b/drivers/mmc/core/quirks.h As you are rename this to become a header file, please also clean up the included headers from the new quirks.h. For example, you don't need these: #include <linux/kernel.h> #include <linux/export.h> Instead you need: #include <linux/device.h> #include <linux/string.h> > @@ -53,7 +53,8 @@ > END_FIXUP > }; > > -void mmc_fixup_device(struct mmc_card *card, const struct mmc_fixup *table) > +static inline void __maybe_unused The "__maybe_unused" shouldn't be needed here, or is it? > +mmc_fixup_device(struct mmc_card *card, const struct mmc_fixup *table) > { > const struct mmc_fixup *f; > u64 rev = cid_rev_card(card); > @@ -82,4 +83,3 @@ void mmc_fixup_device(struct mmc_card *card, const struct mmc_fixup *table) > } > } > } > -EXPORT_SYMBOL(mmc_fixup_device); [...] Kind regards Uffe -- To unsubscribe from this list: send the line "unsubscribe linux-mmc" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On 2017/2/8 19:15, Ulf Hansson wrote: > [...] > >> diff --git a/drivers/mmc/core/quirks.c b/drivers/mmc/core/quirks.h >> similarity index 95% >> rename from drivers/mmc/core/quirks.c >> rename to drivers/mmc/core/quirks.h >> index bf25a9c..f3bbfcb7 100644 >> --- a/drivers/mmc/core/quirks.c >> +++ b/drivers/mmc/core/quirks.h > > As you are rename this to become a header file, please also clean up > the included headers from the new quirks.h. > > For example, you don't need these: > > #include <linux/kernel.h> > #include <linux/export.h> > > Instead you need: > #include <linux/device.h> > #include <linux/string.h> > Sure. > >> @@ -53,7 +53,8 @@ >> END_FIXUP >> }; >> >> -void mmc_fixup_device(struct mmc_card *card, const struct mmc_fixup *table) >> +static inline void __maybe_unused > > The "__maybe_unused" shouldn't be needed here, or is it? > I tried to keep a C file to include quirk.h to make sure it will be compiled standalone cleanly. Otherwise the gcc cast a warning with W=1 about "defined but not used".. >> +mmc_fixup_device(struct mmc_card *card, const struct mmc_fixup *table) >> { >> const struct mmc_fixup *f; >> u64 rev = cid_rev_card(card); >> @@ -82,4 +83,3 @@ void mmc_fixup_device(struct mmc_card *card, const struct mmc_fixup *table) >> } >> } >> } >> -EXPORT_SYMBOL(mmc_fixup_device); > > [...] > > Kind regards > Uffe > > >
On 10 February 2017 at 10:41, Shawn Lin <shawn.lin@rock-chips.com> wrote: > On 2017/2/8 19:15, Ulf Hansson wrote: >> >> [...] >> >>> diff --git a/drivers/mmc/core/quirks.c b/drivers/mmc/core/quirks.h >>> similarity index 95% >>> rename from drivers/mmc/core/quirks.c >>> rename to drivers/mmc/core/quirks.h >>> index bf25a9c..f3bbfcb7 100644 >>> --- a/drivers/mmc/core/quirks.c >>> +++ b/drivers/mmc/core/quirks.h >> >> >> As you are rename this to become a header file, please also clean up >> the included headers from the new quirks.h. >> >> For example, you don't need these: >> >> #include <linux/kernel.h> >> #include <linux/export.h> >> >> Instead you need: >> #include <linux/device.h> >> #include <linux/string.h> >> > > Sure. > >> >>> @@ -53,7 +53,8 @@ >>> END_FIXUP >>> }; >>> >>> -void mmc_fixup_device(struct mmc_card *card, const struct mmc_fixup >>> *table) >>> +static inline void __maybe_unused >> >> >> The "__maybe_unused" shouldn't be needed here, or is it? >> > > I tried to keep a C file to include quirk.h to make sure it will > be compiled standalone cleanly. Otherwise the gcc cast a warning > with W=1 about "defined but not used".. I see. However those kind of warnings isn't relevant when compiling the header standalone. [...] Kind regards Uffe -- To unsubscribe from this list: send the line "unsubscribe linux-mmc" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/drivers/mmc/core/Makefile b/drivers/mmc/core/Makefile index 0f81464..7e3ed1a 100644 --- a/drivers/mmc/core/Makefile +++ b/drivers/mmc/core/Makefile @@ -7,7 +7,7 @@ mmc_core-y := core.o bus.o host.o \ mmc.o mmc_ops.o sd.o sd_ops.o \ sdio.o sdio_ops.o sdio_bus.o \ sdio_cis.o sdio_io.o sdio_irq.o \ - quirks.o slot-gpio.o + slot-gpio.o mmc_core-$(CONFIG_OF) += pwrseq.o obj-$(CONFIG_PWRSEQ_SIMPLE) += pwrseq_simple.o obj-$(CONFIG_PWRSEQ_SD8787) += pwrseq_sd8787.o diff --git a/drivers/mmc/core/block.c b/drivers/mmc/core/block.c index 985477c..ce5e2a2 100644 --- a/drivers/mmc/core/block.c +++ b/drivers/mmc/core/block.c @@ -52,6 +52,7 @@ #include "host.h" #include "bus.h" #include "mmc_ops.h" +#include "quirks.h" #include "sd_ops.h" MODULE_ALIAS("mmc:block"); diff --git a/drivers/mmc/core/card.h b/drivers/mmc/core/card.h index 95e8fc5..f06cd91 100644 --- a/drivers/mmc/core/card.h +++ b/drivers/mmc/core/card.h @@ -218,6 +218,4 @@ static inline int mmc_card_broken_hpi(const struct mmc_card *c) return c->quirks & MMC_QUIRK_BROKEN_HPI; } -void mmc_fixup_device(struct mmc_card *card, const struct mmc_fixup *table); - #endif diff --git a/drivers/mmc/core/mmc.c b/drivers/mmc/core/mmc.c index f1a451e..d0e6b6f 100644 --- a/drivers/mmc/core/mmc.c +++ b/drivers/mmc/core/mmc.c @@ -25,6 +25,7 @@ #include "host.h" #include "bus.h" #include "mmc_ops.h" +#include "quirks.h" #include "sd_ops.h" #define DEFAULT_CMD6_TIMEOUT_MS 500 diff --git a/drivers/mmc/core/quirks.c b/drivers/mmc/core/quirks.h similarity index 95% rename from drivers/mmc/core/quirks.c rename to drivers/mmc/core/quirks.h index bf25a9c..f3bbfcb7 100644 --- a/drivers/mmc/core/quirks.c +++ b/drivers/mmc/core/quirks.h @@ -53,7 +53,8 @@ END_FIXUP }; -void mmc_fixup_device(struct mmc_card *card, const struct mmc_fixup *table) +static inline void __maybe_unused +mmc_fixup_device(struct mmc_card *card, const struct mmc_fixup *table) { const struct mmc_fixup *f; u64 rev = cid_rev_card(card); @@ -82,4 +83,3 @@ void mmc_fixup_device(struct mmc_card *card, const struct mmc_fixup *table) } } } -EXPORT_SYMBOL(mmc_fixup_device); diff --git a/drivers/mmc/core/sdio.c b/drivers/mmc/core/sdio.c index a64a870..f092a55 100644 --- a/drivers/mmc/core/sdio.c +++ b/drivers/mmc/core/sdio.c @@ -23,6 +23,7 @@ #include "card.h" #include "host.h" #include "bus.h" +#include "quirks.h" #include "sd.h" #include "sdio_bus.h" #include "mmc_ops.h"
Rename quirks.c to quirks.h, and include it for individual C files which need it. Signed-off-by: Shawn Lin <shawn.lin@rock-chips.com> --- Changes in v2: - add __maybe_unused to make it cleanly compiled standalone suggested by Ulf - add inline for mmc_fixup_device drivers/mmc/core/Makefile | 2 +- drivers/mmc/core/block.c | 1 + drivers/mmc/core/card.h | 2 -- drivers/mmc/core/mmc.c | 1 + drivers/mmc/core/{quirks.c => quirks.h} | 4 ++-- drivers/mmc/core/sdio.c | 1 + 6 files changed, 6 insertions(+), 5 deletions(-) rename drivers/mmc/core/{quirks.c => quirks.h} (95%)