Message ID | 1489662495-5375-20-git-send-email-yi.y.sun@linux.intel.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
>>> On 16.03.17 at 12:08, <yi.y.sun@linux.intel.com> wrote: > --- a/xen/include/public/sysctl.h > +++ b/xen/include/public/sysctl.h > @@ -744,6 +744,7 @@ typedef struct xen_sysctl_pcitopoinfo xen_sysctl_pcitopoinfo_t; > DEFINE_XEN_GUEST_HANDLE(xen_sysctl_pcitopoinfo_t); > > #define XEN_SYSCTL_PSR_CAT_get_l3_info 0 > +#define XEN_SYSCTL_PSR_CAT_get_l2_info 1 So is the lack of CDP here the reason why the earlier patch didn't do anything for the _DATA part of it? Jan
On 17-03-27 08:38:39, Jan Beulich wrote: > >>> On 16.03.17 at 12:08, <yi.y.sun@linux.intel.com> wrote: > > --- a/xen/include/public/sysctl.h > > +++ b/xen/include/public/sysctl.h > > @@ -744,6 +744,7 @@ typedef struct xen_sysctl_pcitopoinfo xen_sysctl_pcitopoinfo_t; > > DEFINE_XEN_GUEST_HANDLE(xen_sysctl_pcitopoinfo_t); > > > > #define XEN_SYSCTL_PSR_CAT_get_l3_info 0 > > +#define XEN_SYSCTL_PSR_CAT_get_l2_info 1 > > So is the lack of CDP here the reason why the earlier patch didn't > do anything for the _DATA part of it? > As explanation in previous patch, either _DATA or _CODE can be used to get CDP HW info. > Jan > > > _______________________________________________ > Xen-devel mailing list > Xen-devel@lists.xen.org > https://lists.xen.org/xen-devel
diff --git a/xen/arch/x86/psr.c b/xen/arch/x86/psr.c index 576914d..39f249e 100644 --- a/xen/arch/x86/psr.c +++ b/xen/arch/x86/psr.c @@ -280,6 +280,9 @@ static enum psr_feat_type psr_cbm_type_to_feat_type(enum cbm_type type) case PSR_CBM_TYPE_L3_CODE: feat_type = PSR_SOCKET_L3_CDP; break; + case PSR_CBM_TYPE_L2: + feat_type = PSR_SOCKET_L2_CAT; + break; default: feat_type = PSR_SOCKET_UNKNOWN; break; @@ -635,6 +638,7 @@ struct feat_ops l3_cdp_ops = { /* L2 CAT ops */ struct feat_ops l2_cat_ops = { .get_cos_max = cat_get_cos_max, + .get_feat_info = cat_get_feat_info, }; static void __init parse_psr_bool(char *s, char *value, char *feature, diff --git a/xen/arch/x86/sysctl.c b/xen/arch/x86/sysctl.c index 3bf51a4..f701910 100644 --- a/xen/arch/x86/sysctl.c +++ b/xen/arch/x86/sysctl.c @@ -216,6 +216,24 @@ long arch_do_sysctl( break; } + case XEN_SYSCTL_PSR_CAT_get_l2_info: + { + uint32_t data[PSR_INFO_CAT_SIZE]; + + ret = psr_get_info(sysctl->u.psr_cat_op.target, + PSR_CBM_TYPE_L2, data, ARRAY_SIZE(data)); + if ( ret ) + break; + + sysctl->u.psr_cat_op.u.l3_info.cbm_len = data[PSR_INFO_IDX_CBM_LEN]; + sysctl->u.psr_cat_op.u.l3_info.cos_max = data[PSR_INFO_IDX_COS_MAX]; + sysctl->u.psr_cat_op.u.l3_info.flags = data[PSR_INFO_IDX_FLAG]; + + if ( !ret && __copy_field_to_guest(u_sysctl, sysctl, u.psr_cat_op) ) + ret = -EFAULT; + break; + } + default: ret = -EOPNOTSUPP; break; diff --git a/xen/include/asm-x86/psr.h b/xen/include/asm-x86/psr.h index 4e392c8..a08bb94 100644 --- a/xen/include/asm-x86/psr.h +++ b/xen/include/asm-x86/psr.h @@ -58,6 +58,7 @@ enum cbm_type { PSR_CBM_TYPE_L3, PSR_CBM_TYPE_L3_CODE, PSR_CBM_TYPE_L3_DATA, + PSR_CBM_TYPE_L2, }; extern struct psr_cmt *psr_cmt; diff --git a/xen/include/public/sysctl.h b/xen/include/public/sysctl.h index 00f5e77..1fe8fe4 100644 --- a/xen/include/public/sysctl.h +++ b/xen/include/public/sysctl.h @@ -744,6 +744,7 @@ typedef struct xen_sysctl_pcitopoinfo xen_sysctl_pcitopoinfo_t; DEFINE_XEN_GUEST_HANDLE(xen_sysctl_pcitopoinfo_t); #define XEN_SYSCTL_PSR_CAT_get_l3_info 0 +#define XEN_SYSCTL_PSR_CAT_get_l2_info 1 struct xen_sysctl_psr_cat_op { uint32_t cmd; /* IN: XEN_SYSCTL_PSR_CAT_* */ uint32_t target; /* IN */
This patch implements get HW info flow for L2 CAT including L2 CAT callback function. Signed-off-by: Yi Sun <yi.y.sun@linux.intel.com> --- v9: - reuse 'cat_get_feat_info' for L2 CAT to reduce redundant codes. (suggested by Roger Pau) - modify sysctl implementation of L2 CAT to input data[3] to use 'cat_get_feat_info'. (suggested by Roger Pau) - modify macros names to newly defined ones. (suggested by Jan Beulich) - remove 'l2_info' to reuse 'l3_info'. (suggested by Jan Beulich) - modify macro name according to previous patch change. (suggested by Jan Beulich) v5: - rename 'dat[]' to 'data[]' (suggested by Jan Beulich) - remove type check in callback function. (suggested by Jan Beulich) v4: - create this patch because of codes architecture change. (suggested by Jan Beulich) --- xen/arch/x86/psr.c | 4 ++++ xen/arch/x86/sysctl.c | 18 ++++++++++++++++++ xen/include/asm-x86/psr.h | 1 + xen/include/public/sysctl.h | 1 + 4 files changed, 24 insertions(+)