@@ -1454,6 +1454,12 @@ long arch_do_domctl(
PSR_CBM_TYPE_L3_DATA);
break;
+ case XEN_DOMCTL_PSR_CAT_OP_SET_L2_CBM:
+ ret = psr_set_val(d, domctl->u.psr_cat_op.target,
+ (uint32_t)domctl->u.psr_cat_op.data,
+ PSR_CBM_TYPE_L2);
+ break;
+
case XEN_DOMCTL_PSR_CAT_OP_GET_L3_CBM:
domctl->u.psr_cat_op.data = 0;
ret = psr_get_val(d, domctl->u.psr_cat_op.target,
@@ -636,10 +636,27 @@ struct feat_ops l3_cdp_ops = {
};
/* L2 CAT ops */
+static void l2_cat_write_msr(unsigned int cos, uint32_t val,
+ enum cbm_type type, struct feat_node *feat)
+{
+ if ( feat->cos_reg_val[cos] != val )
+ {
+ feat->cos_reg_val[cos] = val;
+ wrmsrl(MSR_IA32_PSR_L2_MASK(cos), (uint64_t)val);
+ }
+
+ return;
+}
+
struct feat_ops l2_cat_ops = {
.get_cos_max = cat_get_cos_max,
.get_feat_info = cat_get_feat_info,
.get_val = cat_get_val,
+ .get_old_val = cat_get_old_val,
+ .set_new_val = cat_set_new_val,
+ .compare_val = cat_compare_val,
+ .fits_cos_max = cat_fits_cos_max,
+ .write_msr = l2_cat_write_msr,
};
static void __init parse_psr_bool(char *s, char *value, char *feature,
@@ -1138,6 +1138,7 @@ struct xen_domctl_psr_cat_op {
#define XEN_DOMCTL_PSR_CAT_OP_SET_L3_DATA 3
#define XEN_DOMCTL_PSR_CAT_OP_GET_L3_CODE 4
#define XEN_DOMCTL_PSR_CAT_OP_GET_L3_DATA 5
+#define XEN_DOMCTL_PSR_CAT_OP_SET_L2_CBM 6
#define XEN_DOMCTL_PSR_CAT_OP_GET_L2_CBM 7
uint32_t cmd; /* IN: XEN_DOMCTL_PSR_CAT_OP_* */
uint32_t target; /* IN */
This patch implements L2 CAT set value related callback functions and domctl interface. Signed-off-by: Yi Sun <yi.y.sun@linux.intel.com> --- v9: - reuse some CAT common functions for L2 CAT to reduce redundant codes. (suggested by Roger Pau) - remove parameter 'found' from 'cat_compare_val' and modify the return values to let caller know if the id is found or not. These things are done in patch "x86: refactor psr: set value: implement cos finding flow." (suggested by Roger Pau and Dario Faggioli) - remove 'get_cos_num' related codes. (suggested by Jan Beulich) - modify 'l2_cat_write_msr' according to previous patch change. - changes about 'uint64_t' to 'uint32_t'. (suggested by Jan Beulich) v8: - modify 'l2_cat_write_msr' to 'void'. v5: - remove type check in callback function. (suggested by Jan Beulich) - modify return value of callback functions because we do not need them to return number of entries the feature uses. In caller, we call 'get_cos_num' to get the number of entries the feature uses. (suggested by Jan Beulich) - remove 'l2_cat_get_cos_max_from_type'. (suggested by Jan Beulich) - rename 'l2_cat_exceeds_cos_max' to 'l2_cat_fits_cos_max'. (suggested by Jan Beulich) v4: - create this patch because of codes architecture change. (suggested by Jan Beulich) --- xen/arch/x86/domctl.c | 6 ++++++ xen/arch/x86/psr.c | 17 +++++++++++++++++ xen/include/public/domctl.h | 1 + 3 files changed, 24 insertions(+)