Message ID | 20170417060706.28674-3-matt@nmatt.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Mon, Apr 17, 2017 at 02:07:04AM -0400, Matt Brown wrote: > adding extern variable tiocsti_restrict to allow it to be included > in sysctl > > Signed-off-by: Matt Brown <matt@nmatt.com> > --- > include/linux/tty.h | 2 ++ > 1 file changed, 2 insertions(+) I'm all for breaking up changes to be tiny logical pieces, but this is really not needed. Please make it "one logical feature" per patch. thanks, greg k-h -- To unsubscribe from this list: send the line "unsubscribe linux-security-module" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/include/linux/tty.h b/include/linux/tty.h index 1017e904..7011102 100644 --- a/include/linux/tty.h +++ b/include/linux/tty.h @@ -342,6 +342,8 @@ struct tty_file_private { struct list_head list; }; +extern int tiocsti_restrict; + /* tty magic number */ #define TTY_MAGIC 0x5401
adding extern variable tiocsti_restrict to allow it to be included in sysctl Signed-off-by: Matt Brown <matt@nmatt.com> --- include/linux/tty.h | 2 ++ 1 file changed, 2 insertions(+)