diff mbox

[06/13] ARM: dts: armada-385-linksys: usb3 label cleanup

Message ID 20170521124903.11050-7-ralph.sennhauser@gmail.com (mailing list archive)
State New, archived
Headers show

Commit Message

Ralph Sennhauser May 21, 2017, 12:48 p.m. UTC
Now that we use the reference for the USB3.0 port update the node name
and labels for the phy and vbus to match the label used by
armada-38x.dtsi.

Signed-off-by: Ralph Sennhauser <ralph.sennhauser@gmail.com>

---

Notes:

  Going by documentation regulator-name is only of informative nature so
  changing it should be a non issue.
---
 arch/arm/boot/dts/armada-385-linksys.dtsi | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

Comments

Andrew Lunn May 22, 2017, 2:55 p.m. UTC | #1
On Sun, May 21, 2017 at 02:48:55PM +0200, Ralph Sennhauser wrote:
> Now that we use the reference for the USB3.0 port update the node name
> and labels for the phy and vbus to match the label used by
> armada-38x.dtsi.
> 
> Signed-off-by: Ralph Sennhauser <ralph.sennhauser@gmail.com>
> 
> ---
> 
> Notes:
> 
>   Going by documentation regulator-name is only of informative nature so
>   changing it should be a non issue.

Does the regulator name appear in /sys somewhere?

     Andrew
Ralph Sennhauser May 22, 2017, 6:13 p.m. UTC | #2
On Mon, 22 May 2017 16:55:15 +0200
Andrew Lunn <andrew@lunn.ch> wrote:

> On Sun, May 21, 2017 at 02:48:55PM +0200, Ralph Sennhauser wrote:
> > Now that we use the reference for the USB3.0 port update the node
> > name and labels for the phy and vbus to match the label used by
> > armada-38x.dtsi.
> > 
> > Signed-off-by: Ralph Sennhauser <ralph.sennhauser@gmail.com>
> > 
> > ---
> > 
> > Notes:
> > 
> >   Going by documentation regulator-name is only of informative
> > nature so changing it should be a non issue.  
> 
> Does the regulator name appear in /sys somewhere?

To differentiate between node-name and regulator-name property I changed
the regulator name to usb3_1-vbus-regulator-name

# find /sys -name *usb3_1-vbus*
/sys/kernel/debug/regulator/usb3_1-vbus-regulator-name
/sys/devices/platform/usb3_1-vbus
/sys/firmware/devicetree/base/soc/internal-regs/pinctrl@18000/usb3_1-vbus-pins
/sys/firmware/devicetree/base/usb3_1-vbus
/sys/bus/platform/devices/usb3_1-vbus
/sys/bus/platform/drivers/reg-fixed-voltage/usb3_1-vbus

So yes, however, only under /sys/kernel/debug and more importantly not
under /sys/class which would be covered by
Documentation/ABI/testing/sysfs-class-regulator.

How the description is worded in regulator.txt [1] under optional
properties, "regulator-name: A string used as a descriptive name for
regulator outputs" doesn't give the impression its considered part of
the ABI implicitly either, well, as you know this might just be my lack
of English skill. As I was uncertain and still am not under the
impression this to be an issue I decided to change it and leave a note
so it doesn't make it in unnoticed and can be discussed / clarified.

Changing the node name has a similar impact but the same can be said
for gpio_keys vs gpio-keys which got your Reviewed-by already.

The new name would better match some recent dts additions beside being
the more obvious choice with the related changes.

[1] Documentation/devicetree/bindings/regulator/regulator.txt 

Ralph
diff mbox

Patch

diff --git a/arch/arm/boot/dts/armada-385-linksys.dtsi b/arch/arm/boot/dts/armada-385-linksys.dtsi
index 932fca4..6cc1ec7 100644
--- a/arch/arm/boot/dts/armada-385-linksys.dtsi
+++ b/arch/arm/boot/dts/armada-385-linksys.dtsi
@@ -63,16 +63,16 @@ 
 			  MBUS_ID(0x0c, 0x04) 0 0xf1200000 0x100000>;
 	};
 
-	usb3_phy: usb3_phy {
+	usb3_1_phy: usb3_1-phy {
 		compatible = "usb-nop-xceiv";
-		vcc-supply = <&reg_xhci0_vbus>;
+		vcc-supply = <&usb3_1_vbus>;
 	};
 
-	reg_xhci0_vbus: xhci0-vbus {
+	usb3_1_vbus: usb3_1-vbus {
 		compatible = "regulator-fixed";
 		pinctrl-names = "default";
-		pinctrl-0 = <&xhci0_vbus_pins>;
-		regulator-name = "xhci0-vbus";
+		pinctrl-0 = <&usb3_1_vbus_pins>;
+		regulator-name = "usb3_1-vbus";
 		regulator-min-microvolt = <5000000>;
 		regulator-max-microvolt = <5000000>;
 		enable-active-high;
@@ -371,7 +371,7 @@ 
 		marvell,function = "gpio";
 	};
 
-	xhci0_vbus_pins: xhci0-vbus-pins {
+	usb3_1_vbus_pins: usb3_1-vbus-pins {
 		marvell,pins = "mpp50";
 		marvell,function = "gpio";
 	};
@@ -393,5 +393,5 @@ 
 
 &usb3_1 {
 	status = "okay";
-	usb-phy = <&usb3_phy>;
+	usb-phy = <&usb3_1_phy>;
 };