@@ -373,12 +373,21 @@ static bool l3_cdp_get_feat_info(const struct feat_node *feat,
return true;
}
+static void l3_cdp_write_msr(unsigned int cos, uint32_t val, enum cbm_type type)
+{
+ wrmsrl(((type == PSR_CBM_TYPE_L3_DATA) ?
+ MSR_IA32_PSR_L3_MASK_DATA(cos) :
+ MSR_IA32_PSR_L3_MASK_CODE(cos)),
+ val);
+}
+
static const struct feat_props l3_cdp_props = {
.cos_num = 2,
.type[0] = PSR_CBM_TYPE_L3_DATA,
.type[1] = PSR_CBM_TYPE_L3_CODE,
- .alt_type = FEAT_TYPE_L3_CAT,
+ .alt_type = PSR_CBM_TYPE_L3,
.get_feat_info = l3_cdp_get_feat_info,
+ .write_msr = l3_cdp_write_msr,
};
static void __init parse_psr_bool(char *s, char *value, char *feature,
@@ -824,17 +833,27 @@ static int insert_val_into_array(uint32_t val[],
if ( !psr_check_cbm(feat->cbm_len, new_val) )
return -EINVAL;
- /* Value setting position is same as feature array. */
+ /*
+ * Value setting position is same as feature array.
+ * For CDP, user may set both DATA and CODE to same value. For such case,
+ * user input 'PSR_CBM_TYPE_L3' as type. The alternative type of CDP is same
+ * as it. So we should set new_val to both of DATA and CODE under such case.
+ */
for ( i = 0; i < props->cos_num; i++ )
{
if ( type == props->type[i] )
{
val[i] = new_val;
- return 0;
+ ret = 0;
+ break;
}
+ else if ( type == props->alt_type )
+ val[i] = new_val;
+ else
+ ret = -EINVAL;
}
- return -EINVAL;
+ return ret;
}
static int compare_val(const uint32_t val[],
This patch implements L3 CDP set value related callback function. With this patch, 'psr-cat-cbm-set' command can work for L3 CDP. Signed-off-by: Yi Sun <yi.y.sun@linux.intel.com> --- v13: - remove 'strict' from 'psr_cbm_type_to_feat_type' because we use 'alt_type' to check if we need set both DATA and CODE now. (suggested by Jan Beulich) - adjust the implementation in circle in 'insert_val_into_array' to make codes clearer to show how to decide the return value. (suggested by Jan Beulich) v12: - add comment to explain how to deal with the case that user set new val for both DATA and CODE at same time. - add parameter for 'psr_cbm_type_to_feat_type' to return the feature type according to it. - use the feature type returned by 'psr_cbm_type_to_feat_type' to check if we need insert the new value into all items of the feature value array. - use conditional expression for wrmsrl. (suggested by Jan Beulich) v11: - move 'feat->cos_reg_val' assignment and value comparison in 'write_msr' callback function out as generic codes. (suggested by Jan Beulich) - changes about setting both CDP DATA and CODE at same time. - move 'type[]' declaration into previous patch which introduced 'cos_num'. (suggested by Jan Beulich) - changes about 'type[]'. (suggested by Jan Beulich) - move 'compare_val' to previous patch. (suggested by Jan Beulich) - changes about 'get_val' which has been replace by generic codes. (suggested by Jan Beulich) - remove 'restore_default_val' which is unnecessary now. (suggested by Jan Beulich) v10: - remove 'l3_cdp_get_old_val' and use 'l3_cdp_get_val' to replace it. (suggested by Jan Beulich) - remove 'l3_cdp_set_new_val'. - modify 'insert_val_to_array' flow to handle multiple COSs case. (suggested by Jan Beulich) - remove 'l3_cdp_compare_val' and implement a generic function 'comapre_val'. (suggested by Jan Beulich) - remove 'l3_cdp_fits_cos_max'. (suggested by Jan Beulich) - introduce macro 'PSR_MAX_COS_NUM'. - introduce a new member in 'feat_props', 'type[PSR_MAX_COS_NUM]' to record all 'cbm_type' the feature has. (suggested by Jan Beulich) - modify 'gather_val_array' flow to handle multiple COSs case. (suggested by Jan Beulich) - modify 'find_cos' flow and implement 'compare_val' to handle multiple COSs case. (suggested by Jan Beulich) - modify 'fits_cos_max' flow to handle multiple COSs case. (suggested by Jan Beulich) - changes about 'props'. (suggested by Jan Beulich) - remove cast in 'l3_cdp_write_msr'. (suggested by Jan Beulich) - implement 'compare_val' function to compare if feature values are what we expect in finding flow. - implement 'restore_default_val' function to restore feature's COS values to default if the feature has multiple COSs. It is called when the COS ID is reduced to 0. v9: - add comment to explain why CDP uses 2 COSs. (suggested by Wei Liu) - use 'cat_default_val'. (suggested by Wei Liu) - remove 'l3_cdp_get_cos_num' because we can directly get cos_num from feat_node now. (suggested by Jan Beulich) - remove cos checking because it has been moved to common function. (suggested by Jan Beulich) - l3_cdp_set_new_val parameter 'm' is changed to 'new_val'. (suggested by Jan Beulich) - directly use get_cdp_data(feat, 0) and get_cdp_code(feat, 0) to get default value. (suggested by Jan Beulich) - modify 'l3_cdp_write_msr' flow to write value into register according to input type. - changes about 'uint64_t' to 'uint32_t'. (suggested by Jan Beulich) v8: - modify 'l3_cdp_write_msr' type to 'void'. v5: - remove type check in callback function. (suggested by Jan Beulich) - modify return value of callback functions because we do not need them to return number of entries the feature uses. In caller, we call 'get_cos_num' to get the number of entries the feature uses. (suggested by Jan Beulich) - remove 'l3_cdp_get_cos_max_from_type'. - rename 'l3_cdp_exceeds_cos_max' to 'l3_cdp_fits_cos_max'. (suggested by Jan Beulich) v4: - create this patch to make codes easier to understand. (suggested by Jan Beulich) --- xen/arch/x86/psr.c | 27 +++++++++++++++++++++++---- 1 file changed, 23 insertions(+), 4 deletions(-)