diff mbox

[v4,05/15] x86: implement get hw info flow for MBA

Message ID 1506160104-5890-6-git-send-email-yi.y.sun@linux.intel.com (mailing list archive)
State New, archived
Headers show

Commit Message

Yi Sun Sept. 23, 2017, 9:48 a.m. UTC
This patch implements get HW info flow for MBA including its callback
function and sysctl interface.

Signed-off-by: Yi Sun <yi.y.sun@linux.intel.com>
---
CC: Jan Beulich <jbeulich@suse.com>
CC: Andrew Cooper <andrew.cooper3@citrix.com>
CC: Wei Liu <wei.liu2@citrix.com>
CC: Roger Pau Monné <roger.pau@citrix.com>
CC: Chao Peng <chao.p.peng@linux.intel.com>

v4:
    - remove 'ALLOC_' from macro names.
      (suggested by Roger Pau Monné)
    - initialize 'data[PSR_INFO_ARRAY_SIZE]' to 0 to prevent to leak stack data.
      (suggested by Roger Pau Monné)
v3:
    - replace 'PSR_VAL_TYPE_MBA' to 'PSR_TYPE_MBA_THRTL'.
      (suggested by Roger Pau Monné)
v2:
    - use 'XEN_SYSCTL_PSR_MBA_LINEAR' to set MBA feature HW info.
      (suggested by Chao Peng)
v1:
    - sort 'PSR_INFO_IDX_' macros as feature.
      (suggested by Chao Peng)
    - rename 'PSR_INFO_IDX_MBA_LINEAR' to 'PSR_INFO_IDX_MBA_FLAG'.
    - rename 'linear' in 'struct mba_info' to 'flags' for future extension.
      (suggested by Chao Peng)
---
 xen/arch/x86/psr.c          | 15 ++++++++++++++-
 xen/arch/x86/sysctl.c       | 21 ++++++++++++++++++++-
 xen/include/asm-x86/psr.h   |  2 ++
 xen/include/public/sysctl.h |  8 ++++++++
 4 files changed, 44 insertions(+), 2 deletions(-)

Comments

Roger Pau Monné Sept. 26, 2017, 8:46 a.m. UTC | #1
On Sat, Sep 23, 2017 at 09:48:14AM +0000, Yi Sun wrote:
> This patch implements get HW info flow for MBA including its callback
> function and sysctl interface.
> 
> Signed-off-by: Yi Sun <yi.y.sun@linux.intel.com>
> ---
> CC: Jan Beulich <jbeulich@suse.com>
> CC: Andrew Cooper <andrew.cooper3@citrix.com>
> CC: Wei Liu <wei.liu2@citrix.com>
> CC: Roger Pau Monné <roger.pau@citrix.com>
> CC: Chao Peng <chao.p.peng@linux.intel.com>
> 
> v4:
>     - remove 'ALLOC_' from macro names.
>       (suggested by Roger Pau Monné)
>     - initialize 'data[PSR_INFO_ARRAY_SIZE]' to 0 to prevent to leak stack data.
>       (suggested by Roger Pau Monné)
> v3:
>     - replace 'PSR_VAL_TYPE_MBA' to 'PSR_TYPE_MBA_THRTL'.
>       (suggested by Roger Pau Monné)
> v2:
>     - use 'XEN_SYSCTL_PSR_MBA_LINEAR' to set MBA feature HW info.
>       (suggested by Chao Peng)
> v1:
>     - sort 'PSR_INFO_IDX_' macros as feature.
>       (suggested by Chao Peng)
>     - rename 'PSR_INFO_IDX_MBA_LINEAR' to 'PSR_INFO_IDX_MBA_FLAG'.
>     - rename 'linear' in 'struct mba_info' to 'flags' for future extension.
>       (suggested by Chao Peng)
> ---
>  xen/arch/x86/psr.c          | 15 ++++++++++++++-
>  xen/arch/x86/sysctl.c       | 21 ++++++++++++++++++++-
>  xen/include/asm-x86/psr.h   |  2 ++
>  xen/include/public/sysctl.h |  8 ++++++++
>  4 files changed, 44 insertions(+), 2 deletions(-)
> 
> diff --git a/xen/arch/x86/psr.c b/xen/arch/x86/psr.c
> index e2f8fd0..1d0a215 100644
> --- a/xen/arch/x86/psr.c
> +++ b/xen/arch/x86/psr.c
> @@ -263,6 +263,10 @@ static enum psr_feat_type psr_type_to_feat_type(enum psr_type type)
>          feat_type = FEAT_TYPE_L2_CAT;
>          break;
>  
> +    case PSR_TYPE_MBA_THRTL:
> +        feat_type = FEAT_TYPE_MBA;
> +        break;
> +
>      default:
>          ASSERT_UNREACHABLE();
>      }
> @@ -486,7 +490,16 @@ static const struct feat_props l2_cat_props = {
>  static bool mba_get_feat_info(const struct feat_node *feat,
>                                uint32_t data[], unsigned int array_len)
>  {
> -    return false;
> +    if ( array_len != PSR_INFO_ARRAY_SIZE )

Should this be an ASSERT maybe? I don't see how array_len can be !=
PSR_INFO_ARRAY_SIZE.

> +        return false;
> +
> +    data[PSR_INFO_IDX_COS_MAX] = feat->cos_max;
> +    data[PSR_INFO_IDX_MBA_THRTL_MAX] = feat->mba.thrtl_max;
> +
> +    if ( feat->mba.linear )
> +        data[PSR_INFO_IDX_MBA_FLAG] |= XEN_SYSCTL_PSR_MBA_LINEAR;
> +
> +    return true;
>  }
>  
>  static void mba_write_msr(unsigned int cos, uint32_t val,
> diff --git a/xen/arch/x86/sysctl.c b/xen/arch/x86/sysctl.c
> index 9dee163..b2f8efa 100644
> --- a/xen/arch/x86/sysctl.c
> +++ b/xen/arch/x86/sysctl.c
> @@ -174,7 +174,7 @@ long arch_do_sysctl(
>      case XEN_SYSCTL_psr_alloc:
>          switch ( sysctl->u.psr_alloc.cmd )
>          {
> -            uint32_t data[PSR_INFO_ARRAY_SIZE];
> +            uint32_t data[PSR_INFO_ARRAY_SIZE] = {0};

I would rather do "{ 0 };" or "{ };" (note the spaces around the 0).

Thanks, Roger.
Jan Beulich Sept. 26, 2017, 11:49 a.m. UTC | #2
>>> On 26.09.17 at 10:46, <roger.pau@citrix.com> wrote:
> On Sat, Sep 23, 2017 at 09:48:14AM +0000, Yi Sun wrote:
>> --- a/xen/arch/x86/sysctl.c
>> +++ b/xen/arch/x86/sysctl.c
>> @@ -174,7 +174,7 @@ long arch_do_sysctl(
>>      case XEN_SYSCTL_psr_alloc:
>>          switch ( sysctl->u.psr_alloc.cmd )
>>          {
>> -            uint32_t data[PSR_INFO_ARRAY_SIZE];
>> +            uint32_t data[PSR_INFO_ARRAY_SIZE] = {0};
> 
> I would rather do "{ 0 };" or "{ };" (note the spaces around the 0).

The latter of the two suggested variants please.

Jan
diff mbox

Patch

diff --git a/xen/arch/x86/psr.c b/xen/arch/x86/psr.c
index e2f8fd0..1d0a215 100644
--- a/xen/arch/x86/psr.c
+++ b/xen/arch/x86/psr.c
@@ -263,6 +263,10 @@  static enum psr_feat_type psr_type_to_feat_type(enum psr_type type)
         feat_type = FEAT_TYPE_L2_CAT;
         break;
 
+    case PSR_TYPE_MBA_THRTL:
+        feat_type = FEAT_TYPE_MBA;
+        break;
+
     default:
         ASSERT_UNREACHABLE();
     }
@@ -486,7 +490,16 @@  static const struct feat_props l2_cat_props = {
 static bool mba_get_feat_info(const struct feat_node *feat,
                               uint32_t data[], unsigned int array_len)
 {
-    return false;
+    if ( array_len != PSR_INFO_ARRAY_SIZE )
+        return false;
+
+    data[PSR_INFO_IDX_COS_MAX] = feat->cos_max;
+    data[PSR_INFO_IDX_MBA_THRTL_MAX] = feat->mba.thrtl_max;
+
+    if ( feat->mba.linear )
+        data[PSR_INFO_IDX_MBA_FLAG] |= XEN_SYSCTL_PSR_MBA_LINEAR;
+
+    return true;
 }
 
 static void mba_write_msr(unsigned int cos, uint32_t val,
diff --git a/xen/arch/x86/sysctl.c b/xen/arch/x86/sysctl.c
index 9dee163..b2f8efa 100644
--- a/xen/arch/x86/sysctl.c
+++ b/xen/arch/x86/sysctl.c
@@ -174,7 +174,7 @@  long arch_do_sysctl(
     case XEN_SYSCTL_psr_alloc:
         switch ( sysctl->u.psr_alloc.cmd )
         {
-            uint32_t data[PSR_INFO_ARRAY_SIZE];
+            uint32_t data[PSR_INFO_ARRAY_SIZE] = {0};
 
         case XEN_SYSCTL_PSR_get_l3_info:
         {
@@ -214,6 +214,25 @@  long arch_do_sysctl(
             break;
         }
 
+        case XEN_SYSCTL_PSR_get_mba_info:
+        {
+            ret = psr_get_info(sysctl->u.psr_alloc.target,
+                               PSR_TYPE_MBA_THRTL, data, ARRAY_SIZE(data));
+            if ( ret )
+                break;
+
+            sysctl->u.psr_alloc.u.mba_info.cos_max =
+                                      data[PSR_INFO_IDX_COS_MAX];
+            sysctl->u.psr_alloc.u.mba_info.thrtl_max =
+                                      data[PSR_INFO_IDX_MBA_THRTL_MAX];
+            sysctl->u.psr_alloc.u.mba_info.flags =
+                                      data[PSR_INFO_IDX_MBA_FLAG];
+
+            if ( __copy_field_to_guest(u_sysctl, sysctl, u.psr_alloc) )
+                ret = -EFAULT;
+            break;
+        }
+
         default:
             ret = -EOPNOTSUPP;
             break;
diff --git a/xen/include/asm-x86/psr.h b/xen/include/asm-x86/psr.h
index 9d14264..084ae97 100644
--- a/xen/include/asm-x86/psr.h
+++ b/xen/include/asm-x86/psr.h
@@ -39,6 +39,8 @@ 
 #define PSR_INFO_IDX_COS_MAX            0
 #define PSR_INFO_IDX_CAT_CBM_LEN        1
 #define PSR_INFO_IDX_CAT_FLAG           2
+#define PSR_INFO_IDX_MBA_THRTL_MAX      1
+#define PSR_INFO_IDX_MBA_FLAG           2
 #define PSR_INFO_ARRAY_SIZE             3
 
 struct psr_cmt_l3 {
diff --git a/xen/include/public/sysctl.h b/xen/include/public/sysctl.h
index 9cb7e19..559de59 100644
--- a/xen/include/public/sysctl.h
+++ b/xen/include/public/sysctl.h
@@ -745,6 +745,7 @@  DEFINE_XEN_GUEST_HANDLE(xen_sysctl_pcitopoinfo_t);
 
 #define XEN_SYSCTL_PSR_get_l3_info               0
 #define XEN_SYSCTL_PSR_get_l2_info               1
+#define XEN_SYSCTL_PSR_get_mba_info              2
 struct xen_sysctl_psr_alloc {
     uint32_t cmd;       /* IN: XEN_SYSCTL_PSR_* */
     uint32_t target;    /* IN */
@@ -755,6 +756,13 @@  struct xen_sysctl_psr_alloc {
 #define XEN_SYSCTL_PSR_L3_CDP       (1u << 0)
             uint32_t flags;     /* OUT: CAT flags */
         } cat_info;
+
+        struct {
+            uint32_t thrtl_max; /* OUT: Maximum throttle */
+            uint32_t cos_max;   /* OUT: Maximum COS */
+#define XEN_SYSCTL_PSR_MBA_LINEAR      (1u << 0)
+            uint32_t flags;     /* OUT: MBA flags */
+        } mba_info;
     } u;
 };
 typedef struct xen_sysctl_psr_alloc xen_sysctl_psr_alloc_t;