Message ID | 20180226120142.25786-2-jack@suse.cz (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Mon, Feb 26, 2018 at 01:01:37PM +0100, Jan Kara wrote: > Commit 8ddcd653257c "block: introduce GENHD_FL_HIDDEN" added handling of > hidden devices to get_gendisk() but forgot to drop module reference > which is also acquired by get_disk(). Drop the reference as necessary. > > Arguably the function naming here is misleading as put_disk() is *not* > the counterpart of get_disk() but let's fix that in the follow up > commit since that will be more intrusive. Looks good, Reviewed-by: Christoph Hellwig <hch@lst.de>
diff --git a/block/genhd.c b/block/genhd.c index 88a53c188cb7..5098bffe6ba6 100644 --- a/block/genhd.c +++ b/block/genhd.c @@ -817,7 +817,10 @@ struct gendisk *get_gendisk(dev_t devt, int *partno) } if (disk && unlikely(disk->flags & GENHD_FL_HIDDEN)) { + struct module *owner = disk->fops->owner; + put_disk(disk); + module_put(owner); disk = NULL; } return disk;
Commit 8ddcd653257c "block: introduce GENHD_FL_HIDDEN" added handling of hidden devices to get_gendisk() but forgot to drop module reference which is also acquired by get_disk(). Drop the reference as necessary. Arguably the function naming here is misleading as put_disk() is *not* the counterpart of get_disk() but let's fix that in the follow up commit since that will be more intrusive. Fixes: 8ddcd653257c18a669fcb75ee42c37054908e0d6 CC: Christoph Hellwig <hch@lst.de> Signed-off-by: Jan Kara <jack@suse.cz> --- block/genhd.c | 3 +++ 1 file changed, 3 insertions(+)