Message ID | 20180319071537.28649-6-tiwei.bie@intel.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Mon, Mar 19, 2018 at 03:15:36PM +0800, Tiwei Bie wrote: > This macro isn't used by any VFIO code. And its name is > too generic. The vfio-common.h (in include/hw/vfio) can > be included by other modules in QEMU. It can introduce > conflicts. > > Signed-off-by: Tiwei Bie <tiwei.bie@intel.com> This one can go ahead immediately. Try posting as a separate patch. > --- > include/hw/vfio/vfio-common.h | 9 --------- > 1 file changed, 9 deletions(-) > > diff --git a/include/hw/vfio/vfio-common.h b/include/hw/vfio/vfio-common.h > index b820f7984c..f6aa4ae959 100644 > --- a/include/hw/vfio/vfio-common.h > +++ b/include/hw/vfio/vfio-common.h > @@ -34,15 +34,6 @@ > #define ERR_PREFIX "vfio error: %s: " > #define WARN_PREFIX "vfio warning: %s: " > > -/*#define DEBUG_VFIO*/ > -#ifdef DEBUG_VFIO > -#define DPRINTF(fmt, ...) \ > - do { fprintf(stderr, "vfio: " fmt, ## __VA_ARGS__); } while (0) > -#else > -#define DPRINTF(fmt, ...) \ > - do { } while (0) > -#endif > - > enum { > VFIO_DEVICE_TYPE_PCI = 0, > VFIO_DEVICE_TYPE_PLATFORM = 1, > -- > 2.11.0
On Thu, Mar 22, 2018 at 05:15:30PM +0200, Michael S. Tsirkin wrote: > On Mon, Mar 19, 2018 at 03:15:36PM +0800, Tiwei Bie wrote: > > This macro isn't used by any VFIO code. And its name is > > too generic. The vfio-common.h (in include/hw/vfio) can > > be included by other modules in QEMU. It can introduce > > conflicts. > > > > Signed-off-by: Tiwei Bie <tiwei.bie@intel.com> > > This one can go ahead immediately. > Try posting as a separate patch. Got it. Thanks! Best regards, Tiwei Bie > > > --- > > include/hw/vfio/vfio-common.h | 9 --------- > > 1 file changed, 9 deletions(-) > > > > diff --git a/include/hw/vfio/vfio-common.h b/include/hw/vfio/vfio-common.h > > index b820f7984c..f6aa4ae959 100644 > > --- a/include/hw/vfio/vfio-common.h > > +++ b/include/hw/vfio/vfio-common.h > > @@ -34,15 +34,6 @@ > > #define ERR_PREFIX "vfio error: %s: " > > #define WARN_PREFIX "vfio warning: %s: " > > > > -/*#define DEBUG_VFIO*/ > > -#ifdef DEBUG_VFIO > > -#define DPRINTF(fmt, ...) \ > > - do { fprintf(stderr, "vfio: " fmt, ## __VA_ARGS__); } while (0) > > -#else > > -#define DPRINTF(fmt, ...) \ > > - do { } while (0) > > -#endif > > - > > enum { > > VFIO_DEVICE_TYPE_PCI = 0, > > VFIO_DEVICE_TYPE_PLATFORM = 1, > > -- > > 2.11.0 > > --------------------------------------------------------------------- > To unsubscribe, e-mail: virtio-dev-unsubscribe@lists.oasis-open.org > For additional commands, e-mail: virtio-dev-help@lists.oasis-open.org >
diff --git a/include/hw/vfio/vfio-common.h b/include/hw/vfio/vfio-common.h index b820f7984c..f6aa4ae959 100644 --- a/include/hw/vfio/vfio-common.h +++ b/include/hw/vfio/vfio-common.h @@ -34,15 +34,6 @@ #define ERR_PREFIX "vfio error: %s: " #define WARN_PREFIX "vfio warning: %s: " -/*#define DEBUG_VFIO*/ -#ifdef DEBUG_VFIO -#define DPRINTF(fmt, ...) \ - do { fprintf(stderr, "vfio: " fmt, ## __VA_ARGS__); } while (0) -#else -#define DPRINTF(fmt, ...) \ - do { } while (0) -#endif - enum { VFIO_DEVICE_TYPE_PCI = 0, VFIO_DEVICE_TYPE_PLATFORM = 1,
This macro isn't used by any VFIO code. And its name is too generic. The vfio-common.h (in include/hw/vfio) can be included by other modules in QEMU. It can introduce conflicts. Signed-off-by: Tiwei Bie <tiwei.bie@intel.com> --- include/hw/vfio/vfio-common.h | 9 --------- 1 file changed, 9 deletions(-)