Message ID | 20180328011953.19496-1-tiwei.bie@intel.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Wed, Mar 28, 2018 at 09:19:53AM +0800, Tiwei Bie wrote: > This macro isn't used by any VFIO code. And its name is > too generic. The vfio-common.h (in include/hw/vfio) can > be included by other modules in QEMU. It can introduce > conflicts. > > Signed-off-by: Tiwei Bie <tiwei.bie@intel.com> Reviewed-by: Michael S. Tsirkin <mst@redhat.com> > --- > include/hw/vfio/vfio-common.h | 9 --------- > 1 file changed, 9 deletions(-) > > diff --git a/include/hw/vfio/vfio-common.h b/include/hw/vfio/vfio-common.h > index d9360148e6..cecbd4e386 100644 > --- a/include/hw/vfio/vfio-common.h > +++ b/include/hw/vfio/vfio-common.h > @@ -34,15 +34,6 @@ > #define ERR_PREFIX "vfio error: %s: " > #define WARN_PREFIX "vfio warning: %s: " > > -/*#define DEBUG_VFIO*/ > -#ifdef DEBUG_VFIO > -#define DPRINTF(fmt, ...) \ > - do { fprintf(stderr, "vfio: " fmt, ## __VA_ARGS__); } while (0) > -#else > -#define DPRINTF(fmt, ...) \ > - do { } while (0) > -#endif > - > enum { > VFIO_DEVICE_TYPE_PCI = 0, > VFIO_DEVICE_TYPE_PLATFORM = 1, > -- > 2.11.0
Hi, On 28/03/18 03:19, Tiwei Bie wrote: > This macro isn't used by any VFIO code. And its name is > too generic. The vfio-common.h (in include/hw/vfio) can > be included by other modules in QEMU. It can introduce > conflicts. > > Signed-off-by: Tiwei Bie <tiwei.bie@intel.com> Reviewed-by: Eric Auger <eric.auger@redhat.com> Thanks Eric > --- > include/hw/vfio/vfio-common.h | 9 --------- > 1 file changed, 9 deletions(-) > > diff --git a/include/hw/vfio/vfio-common.h b/include/hw/vfio/vfio-common.h > index d9360148e6..cecbd4e386 100644 > --- a/include/hw/vfio/vfio-common.h > +++ b/include/hw/vfio/vfio-common.h > @@ -34,15 +34,6 @@ > #define ERR_PREFIX "vfio error: %s: " > #define WARN_PREFIX "vfio warning: %s: " > > -/*#define DEBUG_VFIO*/ > -#ifdef DEBUG_VFIO > -#define DPRINTF(fmt, ...) \ > - do { fprintf(stderr, "vfio: " fmt, ## __VA_ARGS__); } while (0) > -#else > -#define DPRINTF(fmt, ...) \ > - do { } while (0) > -#endif > - > enum { > VFIO_DEVICE_TYPE_PCI = 0, > VFIO_DEVICE_TYPE_PLATFORM = 1, >
diff --git a/include/hw/vfio/vfio-common.h b/include/hw/vfio/vfio-common.h index d9360148e6..cecbd4e386 100644 --- a/include/hw/vfio/vfio-common.h +++ b/include/hw/vfio/vfio-common.h @@ -34,15 +34,6 @@ #define ERR_PREFIX "vfio error: %s: " #define WARN_PREFIX "vfio warning: %s: " -/*#define DEBUG_VFIO*/ -#ifdef DEBUG_VFIO -#define DPRINTF(fmt, ...) \ - do { fprintf(stderr, "vfio: " fmt, ## __VA_ARGS__); } while (0) -#else -#define DPRINTF(fmt, ...) \ - do { } while (0) -#endif - enum { VFIO_DEVICE_TYPE_PCI = 0, VFIO_DEVICE_TYPE_PLATFORM = 1,
This macro isn't used by any VFIO code. And its name is too generic. The vfio-common.h (in include/hw/vfio) can be included by other modules in QEMU. It can introduce conflicts. Signed-off-by: Tiwei Bie <tiwei.bie@intel.com> --- include/hw/vfio/vfio-common.h | 9 --------- 1 file changed, 9 deletions(-)