Message ID | 20180607083009.41793-1-hare@suse.de (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Good idea to display the flags, but the characters aren't really very self-describing. Should we prefix each with an f maybe?
On Thu, 7 Jun 2018 13:24:23 +0200 Christoph Hellwig <hch@lst.de> wrote: > Good idea to display the flags, but the characters aren't really > very self-describing. Should we prefix each with an f maybe? Honestly, I don't care. Just wanted to stick with the one-letter acronym like all the others did. But in the end having the failfast ones prefixed with an 'f' sounds reasonable. Cheers, Hannes
diff --git a/kernel/trace/blktrace.c b/kernel/trace/blktrace.c index 987d9a9ae283..238e16211a5c 100644 --- a/kernel/trace/blktrace.c +++ b/kernel/trace/blktrace.c @@ -1922,6 +1922,14 @@ void blk_fill_rwbs(char *rwbs, unsigned int op, int bytes) rwbs[i++] = 'S'; if (op & REQ_META) rwbs[i++] = 'M'; + if (op & REQ_FAILFAST_DEV) + rwbs[i++] = 'd'; + if (op & REQ_FAILFAST_TRANSPORT) + rwbs[i++] = 't'; + if (op & REQ_FAILFAST_DRIVER) + rwbs[i++] = 'v'; + if (op & REQ_DRV) + rwbs[i++] = 'V'; rwbs[i] = '\0'; }
Signed-off-by: Hannes Reinecke <hare@suse.com> --- kernel/trace/blktrace.c | 8 ++++++++ 1 file changed, 8 insertions(+)