Message ID | 20181003143824.13059-6-ulf.hansson@linaro.org (mailing list archive) |
---|---|
State | Not Applicable, archived |
Headers | show |
Series | PM / Domains: Support hierarchical CPU arrangement (PSCI/ARM) (a subset) | expand |
On Wed, Oct 03, 2018 at 04:38:18PM +0200, Ulf Hansson wrote: > The CPU's idle state nodes are currently parsed at the common cpuidle DT > library, but also when initializing back-end data for the arch specific CPU > operations, as in the PSCI driver case. > > To avoid open-coding, let's introduce of_get_cpu_state_node(), which takes > the device node for the CPU and the index to the requested idle state node, > as in-parameters. In case a corresponding idle state node is found, it > returns the node with the refcount incremented for it, else it returns > NULL. > > Moreover, for ARM, there are two generic methods, to describe the CPU's > idle states, either via the flattened description through the > "cpu-idle-states" binding [1] or via the hierarchical layout, using the > "power-domains" and the "domain-idle-states" bindings [2]. Hence, let's > take both options into account. > > [1] > Documentation/devicetree/bindings/arm/idle-states.txt > [2] > Documentation/devicetree/bindings/arm/psci.txt > > Cc: Rob Herring <robh+dt@kernel.org> > Cc: devicetree@vger.kernel.org > Cc: Lina Iyer <ilina@codeaurora.org> > Suggested-by: Sudeep Holla <sudeep.holla@arm.com> > Co-developed-by: Lina Iyer <lina.iyer@linaro.org> > Signed-off-by: Ulf Hansson <ulf.hansson@linaro.org> > Reviewed-by: Rob Herring <robh@kernel.org> > --- > drivers/of/base.c | 35 +++++++++++++++++++++++++++++++++++ > include/linux/of.h | 8 ++++++++ > 2 files changed, 43 insertions(+) > > diff --git a/drivers/of/base.c b/drivers/of/base.c > index 74eaedd5b860..bf1d5fa34899 100644 > --- a/drivers/of/base.c > +++ b/drivers/of/base.c > @@ -424,6 +424,41 @@ int of_cpu_node_to_id(struct device_node *cpu_node) > } > EXPORT_SYMBOL(of_cpu_node_to_id); > > +/** > + * of_get_cpu_state_node - Get CPU's idle state node at the given index > + * > + * @cpu_node: The device node for the CPU > + * @index: The index in the list of the idle states > + * > + * Two generic methods can be used to describe a CPU's idle states, either via > + * a flattened description through the "cpu-idle-states" binding or via the > + * hierarchical layout, using the "power-domains" and the "domain-idle-states" > + * bindings. This function check for both and returns the idle state node for > + * the requested index. > + * > + * In case and idle state node is found at index, the refcount incremented for > + * it, so call of_node_put() on it when done. Returns NULL if not found. > + */ > +struct device_node *of_get_cpu_state_node(struct device_node *cpu_node, No strong opinion but I am wondering if it makes sense to get cpu logical index and fetch the cpu of_node here to contain the refcount on it within this function while we are trying to consolidate. I do see that may not be so useful in psci.c but keeping refcount for cpu of_node here keeps the user free from that. I am fine as it is if there are reasons not to do that. -- Regards, Sudeep
On 10 October 2018 at 17:03, Sudeep Holla <sudeep.holla@arm.com> wrote: > On Wed, Oct 03, 2018 at 04:38:18PM +0200, Ulf Hansson wrote: >> The CPU's idle state nodes are currently parsed at the common cpuidle DT >> library, but also when initializing back-end data for the arch specific CPU >> operations, as in the PSCI driver case. >> >> To avoid open-coding, let's introduce of_get_cpu_state_node(), which takes >> the device node for the CPU and the index to the requested idle state node, >> as in-parameters. In case a corresponding idle state node is found, it >> returns the node with the refcount incremented for it, else it returns >> NULL. >> >> Moreover, for ARM, there are two generic methods, to describe the CPU's >> idle states, either via the flattened description through the >> "cpu-idle-states" binding [1] or via the hierarchical layout, using the >> "power-domains" and the "domain-idle-states" bindings [2]. Hence, let's >> take both options into account. >> >> [1] >> Documentation/devicetree/bindings/arm/idle-states.txt >> [2] >> Documentation/devicetree/bindings/arm/psci.txt >> >> Cc: Rob Herring <robh+dt@kernel.org> >> Cc: devicetree@vger.kernel.org >> Cc: Lina Iyer <ilina@codeaurora.org> >> Suggested-by: Sudeep Holla <sudeep.holla@arm.com> >> Co-developed-by: Lina Iyer <lina.iyer@linaro.org> >> Signed-off-by: Ulf Hansson <ulf.hansson@linaro.org> >> Reviewed-by: Rob Herring <robh@kernel.org> >> --- >> drivers/of/base.c | 35 +++++++++++++++++++++++++++++++++++ >> include/linux/of.h | 8 ++++++++ >> 2 files changed, 43 insertions(+) >> >> diff --git a/drivers/of/base.c b/drivers/of/base.c >> index 74eaedd5b860..bf1d5fa34899 100644 >> --- a/drivers/of/base.c >> +++ b/drivers/of/base.c >> @@ -424,6 +424,41 @@ int of_cpu_node_to_id(struct device_node *cpu_node) >> } >> EXPORT_SYMBOL(of_cpu_node_to_id); >> >> +/** >> + * of_get_cpu_state_node - Get CPU's idle state node at the given index >> + * >> + * @cpu_node: The device node for the CPU >> + * @index: The index in the list of the idle states >> + * >> + * Two generic methods can be used to describe a CPU's idle states, either via >> + * a flattened description through the "cpu-idle-states" binding or via the >> + * hierarchical layout, using the "power-domains" and the "domain-idle-states" >> + * bindings. This function check for both and returns the idle state node for >> + * the requested index. >> + * >> + * In case and idle state node is found at index, the refcount incremented for >> + * it, so call of_node_put() on it when done. Returns NULL if not found. >> + */ >> +struct device_node *of_get_cpu_state_node(struct device_node *cpu_node, > > No strong opinion but I am wondering if it makes sense to get cpu > logical index and fetch the cpu of_node here to contain the refcount on > it within this function while we are trying to consolidate. I do see > that may not be so useful in psci.c but keeping refcount for cpu of_node > here keeps the user free from that. I see your point. However, I am hesitating doing that change, as it would be a waste for the psci case, but I also think that it may becomes a bit less straight forward to use this helper function. Although, no strong opinions from my side either, but since Rob is happy with this, there is no need to change it, I think. > > I am fine as it is if there are reasons not to do that. > Right. Kind regards Uffe
On Thu, Oct 11, 2018 at 05:05:07PM +0200, Ulf Hansson wrote: > On 10 October 2018 at 17:03, Sudeep Holla <sudeep.holla@arm.com> wrote: [...] > > > > No strong opinion but I am wondering if it makes sense to get cpu > > logical index and fetch the cpu of_node here to contain the refcount on > > it within this function while we are trying to consolidate. I do see > > that may not be so useful in psci.c but keeping refcount for cpu of_node > > here keeps the user free from that. > > I see your point. > > However, I am hesitating doing that change, as it would be a waste for > the psci case, but I also think that it may becomes a bit less > straight forward to use this helper function. > > Although, no strong opinions from my side either, but since Rob is > happy with this, there is no need to change it, I think. > Sure, no problem. -- Regards, Sudeep
diff --git a/drivers/of/base.c b/drivers/of/base.c index 74eaedd5b860..bf1d5fa34899 100644 --- a/drivers/of/base.c +++ b/drivers/of/base.c @@ -424,6 +424,41 @@ int of_cpu_node_to_id(struct device_node *cpu_node) } EXPORT_SYMBOL(of_cpu_node_to_id); +/** + * of_get_cpu_state_node - Get CPU's idle state node at the given index + * + * @cpu_node: The device node for the CPU + * @index: The index in the list of the idle states + * + * Two generic methods can be used to describe a CPU's idle states, either via + * a flattened description through the "cpu-idle-states" binding or via the + * hierarchical layout, using the "power-domains" and the "domain-idle-states" + * bindings. This function check for both and returns the idle state node for + * the requested index. + * + * In case and idle state node is found at index, the refcount incremented for + * it, so call of_node_put() on it when done. Returns NULL if not found. + */ +struct device_node *of_get_cpu_state_node(struct device_node *cpu_node, + int index) +{ + struct of_phandle_args args; + int err; + + err = of_parse_phandle_with_args(cpu_node, "power-domains", + "#power-domain-cells", 0, &args); + if (!err) { + struct device_node *state_node = + of_parse_phandle(args.np, "domain-idle-states", index); + + of_node_put(args.np); + return state_node; + } + + return of_parse_phandle(cpu_node, "cpu-idle-states", index); +} +EXPORT_SYMBOL(of_get_cpu_state_node); + /** * __of_device_is_compatible() - Check if the node matches given constraints * @device: pointer to node diff --git a/include/linux/of.h b/include/linux/of.h index 99b0ebf49632..42dae048674c 100644 --- a/include/linux/of.h +++ b/include/linux/of.h @@ -353,6 +353,8 @@ extern const void *of_get_property(const struct device_node *node, const char *name, int *lenp); extern struct device_node *of_get_cpu_node(int cpu, unsigned int *thread); +extern struct device_node *of_get_cpu_state_node(struct device_node *cpu_node, + int index); #define for_each_property_of_node(dn, pp) \ for (pp = dn->properties; pp != NULL; pp = pp->next) @@ -754,6 +756,12 @@ static inline struct device_node *of_get_cpu_node(int cpu, return NULL; } +static inline struct device_node *of_get_cpu_state_node(struct device_node *cpu_node, + int index) +{ + return NULL; +} + static inline int of_n_addr_cells(struct device_node *np) { return 0;