Message ID | 20190221180423.GA5689@embeddedor (mailing list archive) |
---|---|
State | Accepted |
Delegated to: | Herbert Xu |
Headers | show |
Series | crypto: af_alg - use struct_size() in sock_kfree_s() | expand |
On Thu, Feb 21, 2019 at 12:04:23PM -0600, Gustavo A. R. Silva wrote: > Make use of the struct_size() helper instead of an open-coded version > in order to avoid any potential type mistakes, in particular in the > context in which this code is being used. > > So, change the following form: > > sizeof(*sgl) + sizeof(sgl->sg[0]) * (MAX_SGL_ENTS + 1) > > to : > > struct_size(sgl, sg, MAX_SGL_ENTS + 1) > > This code was detected with the help of Coccinelle. > > Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com> > --- > crypto/af_alg.c | 3 +-- > 1 file changed, 1 insertion(+), 2 deletions(-) Patch applied. Thanks.
diff --git a/crypto/af_alg.c b/crypto/af_alg.c index 65f4326d08f0..edca0998b2a4 100644 --- a/crypto/af_alg.c +++ b/crypto/af_alg.c @@ -637,8 +637,7 @@ void af_alg_pull_tsgl(struct sock *sk, size_t used, struct scatterlist *dst, } list_del(&sgl->list); - sock_kfree_s(sk, sgl, sizeof(*sgl) + sizeof(sgl->sg[0]) * - (MAX_SGL_ENTS + 1)); + sock_kfree_s(sk, sgl, struct_size(sgl, sg, MAX_SGL_ENTS + 1)); } if (!ctx->used)
Make use of the struct_size() helper instead of an open-coded version in order to avoid any potential type mistakes, in particular in the context in which this code is being used. So, change the following form: sizeof(*sgl) + sizeof(sgl->sg[0]) * (MAX_SGL_ENTS + 1) to : struct_size(sgl, sg, MAX_SGL_ENTS + 1) This code was detected with the help of Coccinelle. Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com> --- crypto/af_alg.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-)