Message ID | 20190301132809.24653-5-will.deacon@arm.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | Rework debug exception handling code | expand |
On Fri, Mar 01, 2019 at 01:28:03PM +0000, Will Deacon wrote: > Since the 'addr' parameter contains an UNKNOWN value for non-watchpoint > debug exceptions, rename it to 'unused' for those hooks so we don't get > tempted to use it in the future. > > Signed-off-by: Will Deacon <will.deacon@arm.com> Reviewed-by: Mark Rutland <mark.rutland@arm.com> Mark. > --- > arch/arm64/kernel/debug-monitors.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/arch/arm64/kernel/debug-monitors.c b/arch/arm64/kernel/debug-monitors.c > index d7bb6aefae0a..c4c263d0cf0f 100644 > --- a/arch/arm64/kernel/debug-monitors.c > +++ b/arch/arm64/kernel/debug-monitors.c > @@ -222,7 +222,7 @@ static void send_user_sigtrap(int si_code) > "User debug trap"); > } > > -static int single_step_handler(unsigned long addr, unsigned int esr, > +static int single_step_handler(unsigned long unused, unsigned int esr, > struct pt_regs *regs) > { > bool handler_found = false; > @@ -302,7 +302,7 @@ static int call_break_hook(struct pt_regs *regs, unsigned int esr) > } > NOKPROBE_SYMBOL(call_break_hook); > > -static int brk_handler(unsigned long addr, unsigned int esr, > +static int brk_handler(unsigned long unused, unsigned int esr, > struct pt_regs *regs) > { > bool handler_found = false; > -- > 2.11.0 >
diff --git a/arch/arm64/kernel/debug-monitors.c b/arch/arm64/kernel/debug-monitors.c index d7bb6aefae0a..c4c263d0cf0f 100644 --- a/arch/arm64/kernel/debug-monitors.c +++ b/arch/arm64/kernel/debug-monitors.c @@ -222,7 +222,7 @@ static void send_user_sigtrap(int si_code) "User debug trap"); } -static int single_step_handler(unsigned long addr, unsigned int esr, +static int single_step_handler(unsigned long unused, unsigned int esr, struct pt_regs *regs) { bool handler_found = false; @@ -302,7 +302,7 @@ static int call_break_hook(struct pt_regs *regs, unsigned int esr) } NOKPROBE_SYMBOL(call_break_hook); -static int brk_handler(unsigned long addr, unsigned int esr, +static int brk_handler(unsigned long unused, unsigned int esr, struct pt_regs *regs) { bool handler_found = false;
Since the 'addr' parameter contains an UNKNOWN value for non-watchpoint debug exceptions, rename it to 'unused' for those hooks so we don't get tempted to use it in the future. Signed-off-by: Will Deacon <will.deacon@arm.com> --- arch/arm64/kernel/debug-monitors.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)