Message ID | 1563393026-17118-1-git-send-email-wahrenst@gmx.net (mailing list archive) |
---|---|
Headers | show |
Series | ARM: Add minimal Raspberry Pi 4 support | expand |
Stefan Wahren <wahrenst@gmx.net> writes: > This series adds minimal support for the new Raspberry Pi 4, so we are able > to login via debug UART. > > Patch 1-5: Prepare platform and DTS for the new SoC BMC2838 > Patch 6-9: Enable support for emmc2 on BCM2838 > Patch 10-14: Enable pinctrl for BCM2838 > Patch 15: Enable SPI support for BCM2838 > Patch 16-18: Add Raspberry Pi 4 DTS support > > Unfortunately the Raspberry Pi Foundation didn't released a > peripheral documentation for the new SoC yet. So we only have a preliminary > datasheet [1] and reduced schematics [2]. > > This series is marked as RFC because some parts (e.g. pinctrl) are still > work in progress. > > [1] - https://www.raspberrypi.org/documentation/hardware/raspberrypi/bcm2711/rpi_DATA_2711_1p0_preliminary.pdf > [2] - https://www.raspberrypi.org/documentation/hardware/raspberrypi/schematics/rpi_SCH_4b_4p0_reduced.pdf > > Discussible things: > - SoC compatible BCM2711 (as on the SoC label) vs BCM2838 (existing naming scheme) > - ARCH membership ARCH_BCM2835 vs ARCH_BCMSTB Thanks for taking this on! I would love to see us drop this silly upstream/downstream compatible string naming scheme and just use 2711 (or 7211 for modules shared with 7211 that were enabled there first). However, I don't feel that strongly about it when I'm not the one doing the work. Other than the SPI shared interrupt change that looks dodgy, and a preference for the clock change being data-driven instead, I would be willing to ack the whole thing.
On 7/18/19 11:45 AM, Eric Anholt wrote: > Stefan Wahren <wahrenst@gmx.net> writes: > >> This series adds minimal support for the new Raspberry Pi 4, so we are able >> to login via debug UART. >> >> Patch 1-5: Prepare platform and DTS for the new SoC BMC2838 >> Patch 6-9: Enable support for emmc2 on BCM2838 >> Patch 10-14: Enable pinctrl for BCM2838 >> Patch 15: Enable SPI support for BCM2838 >> Patch 16-18: Add Raspberry Pi 4 DTS support >> >> Unfortunately the Raspberry Pi Foundation didn't released a >> peripheral documentation for the new SoC yet. So we only have a preliminary >> datasheet [1] and reduced schematics [2]. >> >> This series is marked as RFC because some parts (e.g. pinctrl) are still >> work in progress. >> >> [1] - https://www.raspberrypi.org/documentation/hardware/raspberrypi/bcm2711/rpi_DATA_2711_1p0_preliminary.pdf >> [2] - https://www.raspberrypi.org/documentation/hardware/raspberrypi/schematics/rpi_SCH_4b_4p0_reduced.pdf >> >> Discussible things: >> - SoC compatible BCM2711 (as on the SoC label) vs BCM2838 (existing naming scheme) >> - ARCH membership ARCH_BCM2835 vs ARCH_BCMSTB > > Thanks for taking this on! > > I would love to see us drop this silly upstream/downstream compatible > string naming scheme and just use 2711 (or 7211 for modules shared with > 7211 that were enabled there first). However, I don't feel that > strongly about it when I'm not the one doing the work. 2711 and 7211 are really different chips so we would need to keep differentiating the two form a hardware description perspective, even if the driver behavior is strictly the same (that's a software implementation detail). > > Other than the SPI shared interrupt change that looks dodgy, and a > preference for the clock change being data-driven instead, I would be > willing to ack the whole thing. > It does look good to me as well, will do a more thorough pass again.
On Thu, 2019-07-18 at 11:45 -0700, Eric Anholt wrote: > Stefan Wahren <wahrenst@gmx.net> writes: > > > This series adds minimal support for the new Raspberry Pi 4, so we are able > > to login via debug UART. > > > > Patch 1-5: Prepare platform and DTS for the new SoC BMC2838 > > Patch 6-9: Enable support for emmc2 on BCM2838 > > Patch 10-14: Enable pinctrl for BCM2838 > > Patch 15: Enable SPI support for BCM2838 > > Patch 16-18: Add Raspberry Pi 4 DTS support > > > > Unfortunately the Raspberry Pi Foundation didn't released a > > peripheral documentation for the new SoC yet. So we only have a preliminary > > datasheet [1] and reduced schematics [2]. > > > > This series is marked as RFC because some parts (e.g. pinctrl) are still > > work in progress. > > > > [1] - > > https://www.raspberrypi.org/documentation/hardware/raspberrypi/bcm2711/rpi_DATA_2711_1p0_preliminary.pdf > > [2] - > > https://www.raspberrypi.org/documentation/hardware/raspberrypi/schematics/rpi_SCH_4b_4p0_reduced.pdf > > > > Discussible things: > > - SoC compatible BCM2711 (as on the SoC label) vs BCM2838 (existing naming > > scheme) > > - ARCH membership ARCH_BCM2835 vs ARCH_BCMSTB > > Thanks for taking this on! > > I would love to see us drop this silly upstream/downstream compatible > string naming scheme and just use 2711 (or 7211 for modules shared with > 7211 that were enabled there first). However, I don't feel that > strongly about it when I'm not the one doing the work. In the long run it would have the added benefit of being able to use all the overlays the RPi Foundation supports. That said I agree with Eric's sentiment.