Message ID | 20190806160137.29275-1-efremov@linux.com (mailing list archive) |
---|---|
State | Mainlined, archived |
Commit | c4c3772384bc93e3d1eccd88bd7f5d74de74e0d7 |
Headers | show |
Series | s390/pci: PCI_IOV_RESOURCES loop refactoring in zpci_map_resources | expand |
On Tue, 6 Aug 2019, Denis Efremov wrote: > This patch alters the for loop iteration scheme in zpci_map_resources > to make it more usual. Thus, the patch generalizes the style for > PCI_IOV_RESOURCES iteration and improves readability. > > Signed-off-by: Denis Efremov <efremov@linux.com> Applied for inclusion via s390/linux.git . Thanks! Sebastian
Thanks for the patch! Sebastian may have silently fixed this, but for future reference, $ git log --oneline arch/s390/pci/pci.c c7ff0e918a7c s390/pci: deal with devices that have no support for MIO instructions dcd33b23c9f3 s390/pci: fix assignment of bus resources 56271303808f s390/pci: add parameter to disable usage of MIO instructions 71ba41c9b1d9 s390/pci: provide support for MIO instructions 81deca12c202 s390/pci: move io address mapping code to pci_insn.c fbfe07d440f2 s390/pci: add parameter to force floating irqs c840927cf5f2 s390/pci: move everything irq related to pci_irq.c 066ee72aecdc s390/pci: remove unused define ... shows that the typical style there is to start the subject with a verb so it's an imperative sentence. On Tue, Aug 06, 2019 at 07:01:37PM +0300, Denis Efremov wrote: > This patch alters the for loop iteration scheme in zpci_map_resources > to make it more usual. Thus, the patch generalizes the style for > PCI_IOV_RESOURCES iteration and improves readability. > > Signed-off-by: Denis Efremov <efremov@linux.com> > --- > arch/s390/pci/pci.c | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) > > diff --git a/arch/s390/pci/pci.c b/arch/s390/pci/pci.c > index b0e3b9a0e488..c7fea9bea8cb 100644 > --- a/arch/s390/pci/pci.c > +++ b/arch/s390/pci/pci.c > @@ -431,13 +431,13 @@ static void zpci_map_resources(struct pci_dev *pdev) > } > > #ifdef CONFIG_PCI_IOV > - i = PCI_IOV_RESOURCES; > + for (i = 0; i < PCI_SRIOV_NUM_BARS; i++) { > + int bar = i + PCI_IOV_RESOURCES; > > - for (; i < PCI_SRIOV_NUM_BARS + PCI_IOV_RESOURCES; i++) { > - len = pci_resource_len(pdev, i); > + len = pci_resource_len(pdev, bar); > if (!len) > continue; > - pdev->resource[i].parent = &iov_res; > + pdev->resource[bar].parent = &iov_res; > } > #endif > } > -- > 2.21.0 >
diff --git a/arch/s390/pci/pci.c b/arch/s390/pci/pci.c index b0e3b9a0e488..c7fea9bea8cb 100644 --- a/arch/s390/pci/pci.c +++ b/arch/s390/pci/pci.c @@ -431,13 +431,13 @@ static void zpci_map_resources(struct pci_dev *pdev) } #ifdef CONFIG_PCI_IOV - i = PCI_IOV_RESOURCES; + for (i = 0; i < PCI_SRIOV_NUM_BARS; i++) { + int bar = i + PCI_IOV_RESOURCES; - for (; i < PCI_SRIOV_NUM_BARS + PCI_IOV_RESOURCES; i++) { - len = pci_resource_len(pdev, i); + len = pci_resource_len(pdev, bar); if (!len) continue; - pdev->resource[i].parent = &iov_res; + pdev->resource[bar].parent = &iov_res; } #endif }
This patch alters the for loop iteration scheme in zpci_map_resources to make it more usual. Thus, the patch generalizes the style for PCI_IOV_RESOURCES iteration and improves readability. Signed-off-by: Denis Efremov <efremov@linux.com> --- arch/s390/pci/pci.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)