Message ID | 20190916204158.6889-19-efremov@linux.com (mailing list archive) |
---|---|
State | New, archived |
Delegated to: | Bjorn Helgaas |
Headers | show |
Series | [RESEND,v3,01/26] PCI: Add define for the number of standard PCI BARs | expand |
On Mon, Sep 16, 2019 at 10:47 PM Denis Efremov <efremov@linux.com> wrote: > > Replace the magic constant (6) with define PCI_STD_NUM_BARS representing > the number of PCI BARs. > > Cc: Jack Wang <jinpu.wang@cloud.ionos.com> > Cc: "James E.J. Bottomley" <jejb@linux.ibm.com> > Signed-off-by: Denis Efremov <efremov@linux.com> Looks fine, thanks! Acked-by: Jack Wang <jinpu.wang@cloud.ionos.com> > --- > drivers/scsi/pm8001/pm8001_hwi.c | 2 +- > drivers/scsi/pm8001/pm8001_init.c | 2 +- > 2 files changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/scsi/pm8001/pm8001_hwi.c b/drivers/scsi/pm8001/pm8001_hwi.c > index 68a8217032d0..1a3661d6be06 100644 > --- a/drivers/scsi/pm8001/pm8001_hwi.c > +++ b/drivers/scsi/pm8001/pm8001_hwi.c > @@ -1186,7 +1186,7 @@ static void pm8001_hw_chip_rst(struct pm8001_hba_info *pm8001_ha) > void pm8001_chip_iounmap(struct pm8001_hba_info *pm8001_ha) > { > s8 bar, logical = 0; > - for (bar = 0; bar < 6; bar++) { > + for (bar = 0; bar < PCI_STD_NUM_BARS; bar++) { > /* > ** logical BARs for SPC: > ** bar 0 and 1 - logical BAR0 > diff --git a/drivers/scsi/pm8001/pm8001_init.c b/drivers/scsi/pm8001/pm8001_init.c > index 3374f553c617..aca913490eb5 100644 > --- a/drivers/scsi/pm8001/pm8001_init.c > +++ b/drivers/scsi/pm8001/pm8001_init.c > @@ -401,7 +401,7 @@ static int pm8001_ioremap(struct pm8001_hba_info *pm8001_ha) > > pdev = pm8001_ha->pdev; > /* map pci mem (PMC pci base 0-3)*/ > - for (bar = 0; bar < 6; bar++) { > + for (bar = 0; bar < PCI_STD_NUM_BARS; bar++) { > /* > ** logical BARs for SPC: > ** bar 0 and 1 - logical BAR0 > -- > 2.21.0 >
Denis, > Replace the magic constant (6) with define PCI_STD_NUM_BARS > representing the number of PCI BARs. Applied to 5.4/scsi-fixes. Thanks!
Hi, On 24.09.2019 05:22, Martin K. Petersen wrote: > > Denis, > >> Replace the magic constant (6) with define PCI_STD_NUM_BARS >> representing the number of PCI BARs. > > Applied to 5.4/scsi-fixes. Thanks! > This constant PCI_STD_NUM_BARS is introduced in the first patch [01/26]. I'm afraid that this patch without the first one will break the compilation. This patchset is dedicated to Bjorn's tree. Sorry for confusing you. Thanks, Denis
On Mon, Sep 23, 2019 at 10:22:42PM -0400, Martin K. Petersen wrote: > > Denis, > > > Replace the magic constant (6) with define PCI_STD_NUM_BARS > > representing the number of PCI BARs. > > Applied to 5.4/scsi-fixes. Thanks! I think this depends on a previous patch that actually adds the PCI_STD_NUM_BARS definition. It will probably be easier if I apply the whole series via the PCI tree. Bjorn
Bjorn, > I think this depends on a previous patch that actually adds the > PCI_STD_NUM_BARS definition. It will probably be easier if I apply > the whole series via the PCI tree. Looks like my mail about this getting dropped due to the missing definition got lost in transit. In any case, feel free to take this through the PCI tree. Acked-by: Martin K. Petersen <martin.petersen@oracle.com>
diff --git a/drivers/scsi/pm8001/pm8001_hwi.c b/drivers/scsi/pm8001/pm8001_hwi.c index 68a8217032d0..1a3661d6be06 100644 --- a/drivers/scsi/pm8001/pm8001_hwi.c +++ b/drivers/scsi/pm8001/pm8001_hwi.c @@ -1186,7 +1186,7 @@ static void pm8001_hw_chip_rst(struct pm8001_hba_info *pm8001_ha) void pm8001_chip_iounmap(struct pm8001_hba_info *pm8001_ha) { s8 bar, logical = 0; - for (bar = 0; bar < 6; bar++) { + for (bar = 0; bar < PCI_STD_NUM_BARS; bar++) { /* ** logical BARs for SPC: ** bar 0 and 1 - logical BAR0 diff --git a/drivers/scsi/pm8001/pm8001_init.c b/drivers/scsi/pm8001/pm8001_init.c index 3374f553c617..aca913490eb5 100644 --- a/drivers/scsi/pm8001/pm8001_init.c +++ b/drivers/scsi/pm8001/pm8001_init.c @@ -401,7 +401,7 @@ static int pm8001_ioremap(struct pm8001_hba_info *pm8001_ha) pdev = pm8001_ha->pdev; /* map pci mem (PMC pci base 0-3)*/ - for (bar = 0; bar < 6; bar++) { + for (bar = 0; bar < PCI_STD_NUM_BARS; bar++) { /* ** logical BARs for SPC: ** bar 0 and 1 - logical BAR0
Replace the magic constant (6) with define PCI_STD_NUM_BARS representing the number of PCI BARs. Cc: Jack Wang <jinpu.wang@cloud.ionos.com> Cc: "James E.J. Bottomley" <jejb@linux.ibm.com> Signed-off-by: Denis Efremov <efremov@linux.com> --- drivers/scsi/pm8001/pm8001_hwi.c | 2 +- drivers/scsi/pm8001/pm8001_init.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-)