Message ID | 7bc9d610-728c-37b0-d175-dba21dc0dfff@huawei.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | mm/memory-failure.c: replace with page_shift() in add_to_kill() | expand |
On 05.11.19 09:21, Yunfeng Ye wrote: > The function page_shift() is supported after the commit 94ad9338109f > ("mm: introduce page_shift()"). > > So replace with page_shift() in add_to_kill() for readability. > > Signed-off-by: Yunfeng Ye <yeyunfeng@huawei.com> > --- > mm/memory-failure.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/mm/memory-failure.c b/mm/memory-failure.c > index 3151c87dff73..e48c50cac889 100644 > --- a/mm/memory-failure.c > +++ b/mm/memory-failure.c > @@ -326,7 +326,7 @@ static void add_to_kill(struct task_struct *tsk, struct page *p, > if (is_zone_device_page(p)) > tk->size_shift = dev_pagemap_mapping_shift(p, vma); > else > - tk->size_shift = compound_order(compound_head(p)) + PAGE_SHIFT; > + tk->size_shift = page_shift(compound_head(p)); > > /* > * Send SIGKILL if "tk->addr == -EFAULT". Also, as > Reviewed-by: David Hildenbrand <david@redhat.com>
On Tue, Nov 05, 2019 at 04:21:44PM +0800, Yunfeng Ye wrote: > The function page_shift() is supported after the commit 94ad9338109f > ("mm: introduce page_shift()"). > > So replace with page_shift() in add_to_kill() for readability. > > Signed-off-by: Yunfeng Ye <yeyunfeng@huawei.com> Acked-by: Naoya Horiguchi <n-horiguchi@ah.jp.nec.com>
diff --git a/mm/memory-failure.c b/mm/memory-failure.c index 3151c87dff73..e48c50cac889 100644 --- a/mm/memory-failure.c +++ b/mm/memory-failure.c @@ -326,7 +326,7 @@ static void add_to_kill(struct task_struct *tsk, struct page *p, if (is_zone_device_page(p)) tk->size_shift = dev_pagemap_mapping_shift(p, vma); else - tk->size_shift = compound_order(compound_head(p)) + PAGE_SHIFT; + tk->size_shift = page_shift(compound_head(p)); /* * Send SIGKILL if "tk->addr == -EFAULT". Also, as
The function page_shift() is supported after the commit 94ad9338109f ("mm: introduce page_shift()"). So replace with page_shift() in add_to_kill() for readability. Signed-off-by: Yunfeng Ye <yeyunfeng@huawei.com> --- mm/memory-failure.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)