Message ID | 20191122164807.27938-1-mlevitsk@redhat.com (mailing list archive) |
---|---|
Headers | show |
Series | RFC: [for 5.0]: HMP monitor handlers cleanups | expand |
* Maxim Levitsky (mlevitsk@redhat.com) wrote: > This patch series is bunch of cleanups > to the hmp monitor code. > > This series only touched blockdev related hmp handlers. > > No functional changes expected other that > light error message changes by the last patch. > > This was inspired by this bugzilla: > https://bugzilla.redhat.com/show_bug.cgi?id=1719169 > > Basically some users still parse hmp error messages, > and they would like to have them prefixed with 'Error:' > > In commit 66363e9a43f649360a3f74d2805c9f864da027eb we added > the hmp_handle_error which does exactl that but some hmp handlers > don't use it. > > In this patch series, I moved all the block related hmp handlers > into blockdev-hmp-cmds.c, and then made them use this function > to report the errors. > > I hope I didn't change too much code, I just felt that if > I touch this code, I can also make it easier to find these > handlers, that were scattered over 3 different files. > > Changes from V1: > * move the handlers to block/monitor/block-hmp-cmds.c > * tiny cleanup for the commit messages OK, so again, from the HMP side: Reviewed-by: Dr. David Alan Gilbert <dgilbert@redhat.com> > Best regards, > Maxim Levitsky > > Maxim Levitsky (9): > monitor/hmp: uninline add_init_drive > monitor/hmp: rename device-hotplug.c to block/monitor/block-hmp-cmds.c > monitor/hmp: move hmp_drive_del and hmp_commit to block-hmp-cmds.c > monitor/hmp: move hmp_drive_mirror and hmp_drive_backup to > block-hmp-cmds.c > monitor/hmp: move hmp_block_job* to block-hmp-cmds.c > monitor/hmp: move hmp_snapshot_* to block-hmp-cmds.c > monitor/hmp: move remaining hmp_block* functions to block-hmp-cmds.c > monitor/hmp: move hmp_info_block* to block-hmp-cmds.c > monitor/hmp: Prefer to use hmp_handle_error for error reporting in > block hmp commands > > MAINTAINERS | 1 + > Makefile.objs | 2 +- > block/Makefile.objs | 1 + > block/monitor/Makefile.objs | 1 + > block/monitor/block-hmp-cmds.c | 656 +++++++++++++++++++++++++++++++++ > blockdev.c | 95 ----- > device-hotplug.c | 91 ----- > monitor/hmp-cmds.c | 465 ----------------------- > 8 files changed, 660 insertions(+), 652 deletions(-) > create mode 100644 block/monitor/Makefile.objs > create mode 100644 block/monitor/block-hmp-cmds.c > delete mode 100644 device-hotplug.c > > -- > 2.17.2 > -- Dr. David Alan Gilbert / dgilbert@redhat.com / Manchester, UK