Message ID | 20200301122330.4296-1-afzal.mohd.ma@gmail.com (mailing list archive) |
---|---|
State | Mainlined |
Commit | 37b146e3f2b4bab1009245f45e1cd9a321efcbbe |
Headers | show |
Series | [v3] ARM: orion: replace setup_irq() by request_irq() | expand |
On Sun, Mar 01, 2020 at 05:53:30PM +0530, afzal mohammed wrote: > request_irq() is preferred over setup_irq(). Invocations of setup_irq() > occur after memory allocators are ready. > > Per tglx[1], setup_irq() existed in olden days when allocators were not > ready by the time early interrupts were initialized. > > Hence replace setup_irq() by request_irq(). > > [1] https://lkml.kernel.org/r/alpine.DEB.2.20.1710191609480.1971@nanos > > Signed-off-by: afzal mohammed <afzal.mohd.ma@gmail.com> Reviewed-by: Andrew Lunn <andrew@lunn.ch> Andrew
Hi Andrew, Jason, Sebastian, Gregory,
Please let me know the way upstream for this patch
On Sun, Mar 01, 2020 at 04:44:35PM +0100, Andrew Lunn wrote:
> Reviewed-by: Andrew Lunn <andrew@lunn.ch>
Thanks Andrew
Regards
afzal
Hello afzal mohammed, > Hi Andrew, Jason, Sebastian, Gregory, > > Please let me know the way upstream for this patch I am taking care of it. Gregory > > On Sun, Mar 01, 2020 at 04:44:35PM +0100, Andrew Lunn wrote: > >> Reviewed-by: Andrew Lunn <andrew@lunn.ch> > > Thanks Andrew > > Regards > afzal
Hi afzal, > request_irq() is preferred over setup_irq(). Invocations of setup_irq() > occur after memory allocators are ready. > > Per tglx[1], setup_irq() existed in olden days when allocators were not > ready by the time early interrupts were initialized. > > Hence replace setup_irq() by request_irq(). > > [1] https://lkml.kernel.org/r/alpine.DEB.2.20.1710191609480.1971@nanos > > Signed-off-by: afzal mohammed <afzal.mohd.ma@gmail.com> Applied on mvebu/arm Thanks, Gregory > --- > Hi sub-arch maintainers, > > If the patch is okay, please take it thr' your tree. > > Regards > afzal > > v3: > * Split out from series, also split out from ARM patch to subarch level > as Thomas suggested to take it thr' respective maintainers > * Modify string displayed in case of error as suggested by Thomas > * Re-arrange code as required to improve readability > * Remove irrelevant parts from commit message & improve > > v2: > * Replace pr_err("request_irq() on %s failed" by > pr_err("%s: request_irq() failed" > * Commit message massage > > arch/arm/plat-orion/time.c | 10 +++------- > 1 file changed, 3 insertions(+), 7 deletions(-) > > diff --git a/arch/arm/plat-orion/time.c b/arch/arm/plat-orion/time.c > index ffb93db68e9c..509d4824dc1c 100644 > --- a/arch/arm/plat-orion/time.c > +++ b/arch/arm/plat-orion/time.c > @@ -177,12 +177,6 @@ static irqreturn_t orion_timer_interrupt(int irq, void *dev_id) > return IRQ_HANDLED; > } > > -static struct irqaction orion_timer_irq = { > - .name = "orion_tick", > - .flags = IRQF_TIMER, > - .handler = orion_timer_interrupt > -}; > - > void __init > orion_time_set_base(void __iomem *_timer_base) > { > @@ -236,7 +230,9 @@ orion_time_init(void __iomem *_bridge_base, u32 _bridge_timer1_clr_mask, > /* > * Setup clockevent timer (interrupt-driven). > */ > - setup_irq(irq, &orion_timer_irq); > + if (request_irq(irq, orion_timer_interrupt, IRQF_TIMER, "orion_tick", > + NULL)) > + pr_err("Failed to request irq %u (orion_tick)\n", irq); > orion_clkevt.cpumask = cpumask_of(0); > clockevents_config_and_register(&orion_clkevt, tclk, 1, 0xfffffffe); > } > -- > 2.25.1 >
diff --git a/arch/arm/plat-orion/time.c b/arch/arm/plat-orion/time.c index ffb93db68e9c..509d4824dc1c 100644 --- a/arch/arm/plat-orion/time.c +++ b/arch/arm/plat-orion/time.c @@ -177,12 +177,6 @@ static irqreturn_t orion_timer_interrupt(int irq, void *dev_id) return IRQ_HANDLED; } -static struct irqaction orion_timer_irq = { - .name = "orion_tick", - .flags = IRQF_TIMER, - .handler = orion_timer_interrupt -}; - void __init orion_time_set_base(void __iomem *_timer_base) { @@ -236,7 +230,9 @@ orion_time_init(void __iomem *_bridge_base, u32 _bridge_timer1_clr_mask, /* * Setup clockevent timer (interrupt-driven). */ - setup_irq(irq, &orion_timer_irq); + if (request_irq(irq, orion_timer_interrupt, IRQF_TIMER, "orion_tick", + NULL)) + pr_err("Failed to request irq %u (orion_tick)\n", irq); orion_clkevt.cpumask = cpumask_of(0); clockevents_config_and_register(&orion_clkevt, tclk, 1, 0xfffffffe); }
request_irq() is preferred over setup_irq(). Invocations of setup_irq() occur after memory allocators are ready. Per tglx[1], setup_irq() existed in olden days when allocators were not ready by the time early interrupts were initialized. Hence replace setup_irq() by request_irq(). [1] https://lkml.kernel.org/r/alpine.DEB.2.20.1710191609480.1971@nanos Signed-off-by: afzal mohammed <afzal.mohd.ma@gmail.com> --- Hi sub-arch maintainers, If the patch is okay, please take it thr' your tree. Regards afzal v3: * Split out from series, also split out from ARM patch to subarch level as Thomas suggested to take it thr' respective maintainers * Modify string displayed in case of error as suggested by Thomas * Re-arrange code as required to improve readability * Remove irrelevant parts from commit message & improve v2: * Replace pr_err("request_irq() on %s failed" by pr_err("%s: request_irq() failed" * Commit message massage arch/arm/plat-orion/time.c | 10 +++------- 1 file changed, 3 insertions(+), 7 deletions(-)