Message ID | 20200313180333.75011-1-rajatja@google.com (mailing list archive) |
---|---|
State | Accepted |
Headers | show |
Series | [v3] Input: Allocate keycode for "Selective Screenshot" key | expand |
On Fri, 13 Mar 2020 at 11:03, Rajat Jain <rajatja@google.com> wrote: > > New chromeos keyboards have a "snip" key that is basically a selective > screenshot (allows a user to select an area of screen to be copied). > Allocate a keycode for it. > > Signed-off-by: Rajat Jain <rajatja@google.com> Reviewed-by: Harry Cutts <hcutts@chromium.org> Harry Cutts Chrome OS Touch/Input team > --- > v3: Rename KEY_SNIP to KEY_SELECTIVE_SNAPSHOT > V2: Drop patch [1/2] and instead rebase this on top of Linus' tree. > > include/uapi/linux/input-event-codes.h | 2 ++ > 1 file changed, 2 insertions(+) > > diff --git a/include/uapi/linux/input-event-codes.h b/include/uapi/linux/input-event-codes.h > index 0f1db1cccc3fd..c4dbe2ee9c098 100644 > --- a/include/uapi/linux/input-event-codes.h > +++ b/include/uapi/linux/input-event-codes.h > @@ -652,6 +652,8 @@ > /* Electronic privacy screen control */ > #define KEY_PRIVACY_SCREEN_TOGGLE 0x279 > > +#define KEY_SELECTIVE_SCREENSHOT 0x280 > + > /* > * Some keyboards have keys which do not have a defined meaning, these keys > * are intended to be programmed / bound to macros by the user. For most > -- > 2.25.1.481.gfbce0eb801-goog >
On Fri, Mar 13, 2020 at 11:03:33AM -0700, Rajat Jain wrote: > New chromeos keyboards have a "snip" key that is basically a selective > screenshot (allows a user to select an area of screen to be copied). > Allocate a keycode for it. > > Signed-off-by: Rajat Jain <rajatja@google.com> Applied, thank you. > --- > v3: Rename KEY_SNIP to KEY_SELECTIVE_SNAPSHOT > V2: Drop patch [1/2] and instead rebase this on top of Linus' tree. > > include/uapi/linux/input-event-codes.h | 2 ++ > 1 file changed, 2 insertions(+) > > diff --git a/include/uapi/linux/input-event-codes.h b/include/uapi/linux/input-event-codes.h > index 0f1db1cccc3fd..c4dbe2ee9c098 100644 > --- a/include/uapi/linux/input-event-codes.h > +++ b/include/uapi/linux/input-event-codes.h > @@ -652,6 +652,8 @@ > /* Electronic privacy screen control */ > #define KEY_PRIVACY_SCREEN_TOGGLE 0x279 > > +#define KEY_SELECTIVE_SCREENSHOT 0x280 > + > /* > * Some keyboards have keys which do not have a defined meaning, these keys > * are intended to be programmed / bound to macros by the user. For most > -- > 2.25.1.481.gfbce0eb801-goog >
On Tue, Mar 17, 2020 at 8:56 PM Dmitry Torokhov <dmitry.torokhov@gmail.com> wrote: > > On Fri, Mar 13, 2020 at 11:03:33AM -0700, Rajat Jain wrote: > > New chromeos keyboards have a "snip" key that is basically a selective > > screenshot (allows a user to select an area of screen to be copied). > > Allocate a keycode for it. > > > > Signed-off-by: Rajat Jain <rajatja@google.com> > > Applied, thank you. I just noticed that I had by mistake used KEY_SELECTIVE_SNAPSHOT instead of intended KEY_SELECTIVE_SCREENSHOT in the commit message. My apologies. Can you please fix the commit message if not already pushed. Otherwise I can send a follow up patch if you'd like. Thanks & Best Regards, Rajat > > > --- > > v3: Rename KEY_SNIP to KEY_SELECTIVE_SNAPSHOT > > V2: Drop patch [1/2] and instead rebase this on top of Linus' tree. > > > > include/uapi/linux/input-event-codes.h | 2 ++ > > 1 file changed, 2 insertions(+) > > > > diff --git a/include/uapi/linux/input-event-codes.h b/include/uapi/linux/input-event-codes.h > > index 0f1db1cccc3fd..c4dbe2ee9c098 100644 > > --- a/include/uapi/linux/input-event-codes.h > > +++ b/include/uapi/linux/input-event-codes.h > > @@ -652,6 +652,8 @@ > > /* Electronic privacy screen control */ > > #define KEY_PRIVACY_SCREEN_TOGGLE 0x279 > > > > +#define KEY_SELECTIVE_SCREENSHOT 0x280 > > + > > /* > > * Some keyboards have keys which do not have a defined meaning, these keys > > * are intended to be programmed / bound to macros by the user. For most > > -- > > 2.25.1.481.gfbce0eb801-goog > > > > -- > Dmitry
On Tue, Mar 17, 2020 at 9:12 PM Rajat Jain <rajatja@google.com> wrote: > > On Tue, Mar 17, 2020 at 8:56 PM Dmitry Torokhov > <dmitry.torokhov@gmail.com> wrote: > > > > On Fri, Mar 13, 2020 at 11:03:33AM -0700, Rajat Jain wrote: > > > New chromeos keyboards have a "snip" key that is basically a selective > > > screenshot (allows a user to select an area of screen to be copied). > > > Allocate a keycode for it. > > > > > > Signed-off-by: Rajat Jain <rajatja@google.com> > > > > Applied, thank you. > > I just noticed that I had by mistake used KEY_SELECTIVE_SNAPSHOT > instead of intended KEY_SELECTIVE_SCREENSHOT in the commit message. My > apologies. Can you please fix the commit message if not already > pushed. Otherwise I can send a follow up patch if you'd like. Arghhh..... please disregard. I was looking at the wrong place. The patch was correct. No need to do anything. Thanks! :-) Best Regards, Rajat > > Thanks & Best Regards, > > Rajat > > > > > > --- > > > v3: Rename KEY_SNIP to KEY_SELECTIVE_SNAPSHOT > > > V2: Drop patch [1/2] and instead rebase this on top of Linus' tree. > > > > > > include/uapi/linux/input-event-codes.h | 2 ++ > > > 1 file changed, 2 insertions(+) > > > > > > diff --git a/include/uapi/linux/input-event-codes.h b/include/uapi/linux/input-event-codes.h > > > index 0f1db1cccc3fd..c4dbe2ee9c098 100644 > > > --- a/include/uapi/linux/input-event-codes.h > > > +++ b/include/uapi/linux/input-event-codes.h > > > @@ -652,6 +652,8 @@ > > > /* Electronic privacy screen control */ > > > #define KEY_PRIVACY_SCREEN_TOGGLE 0x279 > > > > > > +#define KEY_SELECTIVE_SCREENSHOT 0x280 > > > + > > > /* > > > * Some keyboards have keys which do not have a defined meaning, these keys > > > * are intended to be programmed / bound to macros by the user. For most > > > -- > > > 2.25.1.481.gfbce0eb801-goog > > > > > > > -- > > Dmitry
diff --git a/include/uapi/linux/input-event-codes.h b/include/uapi/linux/input-event-codes.h index 0f1db1cccc3fd..c4dbe2ee9c098 100644 --- a/include/uapi/linux/input-event-codes.h +++ b/include/uapi/linux/input-event-codes.h @@ -652,6 +652,8 @@ /* Electronic privacy screen control */ #define KEY_PRIVACY_SCREEN_TOGGLE 0x279 +#define KEY_SELECTIVE_SCREENSHOT 0x280 + /* * Some keyboards have keys which do not have a defined meaning, these keys * are intended to be programmed / bound to macros by the user. For most
New chromeos keyboards have a "snip" key that is basically a selective screenshot (allows a user to select an area of screen to be copied). Allocate a keycode for it. Signed-off-by: Rajat Jain <rajatja@google.com> --- v3: Rename KEY_SNIP to KEY_SELECTIVE_SNAPSHOT V2: Drop patch [1/2] and instead rebase this on top of Linus' tree. include/uapi/linux/input-event-codes.h | 2 ++ 1 file changed, 2 insertions(+)