Message ID | 20200331210905.GA31680@avx2 (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | proc: rename "catch" function argument | expand |
On Wed, 1 Apr 2020 00:09:05 +0300 Alexey Dobriyan <adobriyan@gmail.com> wrote: > "catch" is reserved keyword in C++, rename it to something > both gcc and g++ accept. Why? Is someone compiling the kernel with g++? > Rename "ign" for symmetry. > > Signed-off-by: _Z6Alexeyv <adobriyan@gmail.com> Was this intentional?
On Wed, Apr 15, 2020 at 09:07:27PM -0700, Andrew Morton wrote: > On Wed, 1 Apr 2020 00:09:05 +0300 Alexey Dobriyan <adobriyan@gmail.com> wrote: > > > "catch" is reserved keyword in C++, rename it to something > > both gcc and g++ accept. > > Why? Is someone compiling the kernel with g++? I do! https://marc.info/?l=linux-acpi&m=158343373912366&w=4 > > Rename "ign" for symmetry. > > > > Signed-off-by: _Z6Alexeyv <adobriyan@gmail.com> > > Was this intentional? In Russia, C++ mangles you! :^)
On Thu, 16 Apr 2020 20:21:55 +0300 Alexey Dobriyan <adobriyan@gmail.com> wrote: > On Wed, Apr 15, 2020 at 09:07:27PM -0700, Andrew Morton wrote: > > On Wed, 1 Apr 2020 00:09:05 +0300 Alexey Dobriyan <adobriyan@gmail.com> wrote: > > > > > "catch" is reserved keyword in C++, rename it to something > > > both gcc and g++ accept. > > > > Why? Is someone compiling the kernel with g++? > > I do! > https://marc.info/?l=linux-acpi&m=158343373912366&w=4 > Lol. But why?
--- a/fs/proc/array.c +++ b/fs/proc/array.c @@ -248,8 +248,8 @@ void render_sigset_t(struct seq_file *m, const char *header, seq_putc(m, '\n'); } -static void collect_sigign_sigcatch(struct task_struct *p, sigset_t *ign, - sigset_t *catch) +static void collect_sigign_sigcatch(struct task_struct *p, sigset_t *sigign, + sigset_t *sigcatch) { struct k_sigaction *k; int i; @@ -257,9 +257,9 @@ static void collect_sigign_sigcatch(struct task_struct *p, sigset_t *ign, k = p->sighand->action; for (i = 1; i <= _NSIG; ++i, ++k) { if (k->sa.sa_handler == SIG_IGN) - sigaddset(ign, i); + sigaddset(sigign, i); else if (k->sa.sa_handler != SIG_DFL) - sigaddset(catch, i); + sigaddset(sigcatch, i); } }
"catch" is reserved keyword in C++, rename it to something both gcc and g++ accept. Rename "ign" for symmetry. Signed-off-by: _Z6Alexeyv <adobriyan@gmail.com> --- fs/proc/array.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)