Message ID | 20200505115543.1660-1-thunder.leizhen@huawei.com (mailing list archive) |
---|---|
Headers | show |
Series | eliminate SECTOR related magic numbers and duplicated conversions | expand |
On 05/05/2020 12:55, Zhen Lei wrote: > When I studied the code of mm/swap, I found "1 << (PAGE_SHIFT - 9)" appears > many times. So I try to clean up it. > > 1. Replace "1 << (PAGE_SHIFT - 9)" or similar with SECTORS_PER_PAGE > 2. Replace "PAGE_SHIFT - 9" with SECTORS_PER_PAGE_SHIFT > 3. Replace "9" with SECTOR_SHIFT > 4. Replace "512" with SECTOR_SIZE Naive question - what is happening about 4096-byte sectors? Do we need to forward-plan? Cheers, Wol
On Tue, May 05, 2020 at 06:32:36PM +0100, antlists wrote: > On 05/05/2020 12:55, Zhen Lei wrote: > > When I studied the code of mm/swap, I found "1 << (PAGE_SHIFT - 9)" appears > > many times. So I try to clean up it. > > > > 1. Replace "1 << (PAGE_SHIFT - 9)" or similar with SECTORS_PER_PAGE > > 2. Replace "PAGE_SHIFT - 9" with SECTORS_PER_PAGE_SHIFT > > 3. Replace "9" with SECTOR_SHIFT > > 4. Replace "512" with SECTOR_SIZE > > Naive question - what is happening about 4096-byte sectors? Do we need to > forward-plan? They're fully supported already, but Linux defines a sector to be 512 bytes. So we multiply by 8 and divide by 8 a few times unnecessarily, but it's not worth making sector size be a per-device property. Good thought, though.