mbox series

[0/3] selftests: vdso: Add a selftest for vDSO getcpu()

Message ID 20200505174728.46594-1-broonie@kernel.org (mailing list archive)
Headers show
Series selftests: vdso: Add a selftest for vDSO getcpu() | expand

Message

Mark Brown May 5, 2020, 5:47 p.m. UTC
This series does a bit of a cleanup of the existing tests for the vDSO
in kselftest and then adds a new test for getcpu().

Mark Brown (3):
  selftests: vdso: Rename vdso_test to vdso_test_gettimeofday
  selftests: vdso: Use a header file to prototype parse_vdso API
  selftests: vdso: Add a selftest for vDSO getcpu()

 tools/testing/selftests/vDSO/.gitignore       |  2 +
 tools/testing/selftests/vDSO/Makefile         |  5 +-
 tools/testing/selftests/vDSO/parse_vdso.c     | 24 +--------
 tools/testing/selftests/vDSO/parse_vdso.h     | 31 ++++++++++++
 .../selftests/vDSO/vdso_standalone_test_x86.c |  4 +-
 .../testing/selftests/vDSO/vdso_test_getcpu.c | 50 +++++++++++++++++++
 .../{vdso_test.c => vdso_test_gettimeofday.c} | 10 ++--
 7 files changed, 92 insertions(+), 34 deletions(-)
 create mode 100644 tools/testing/selftests/vDSO/parse_vdso.h
 create mode 100644 tools/testing/selftests/vDSO/vdso_test_getcpu.c
 rename tools/testing/selftests/vDSO/{vdso_test.c => vdso_test_gettimeofday.c} (84%)

Comments

Shuah May 5, 2020, 6:17 p.m. UTC | #1
On 5/5/20 11:47 AM, Mark Brown wrote:
> This series does a bit of a cleanup of the existing tests for the vDSO
> in kselftest and then adds a new test for getcpu().
> 
> Mark Brown (3):
>    selftests: vdso: Rename vdso_test to vdso_test_gettimeofday
>    selftests: vdso: Use a header file to prototype parse_vdso API
>    selftests: vdso: Add a selftest for vDSO getcpu()
> 
>   tools/testing/selftests/vDSO/.gitignore       |  2 +
>   tools/testing/selftests/vDSO/Makefile         |  5 +-
>   tools/testing/selftests/vDSO/parse_vdso.c     | 24 +--------
>   tools/testing/selftests/vDSO/parse_vdso.h     | 31 ++++++++++++
>   .../selftests/vDSO/vdso_standalone_test_x86.c |  4 +-
>   .../testing/selftests/vDSO/vdso_test_getcpu.c | 50 +++++++++++++++++++
>   .../{vdso_test.c => vdso_test_gettimeofday.c} | 10 ++--
>   7 files changed, 92 insertions(+), 34 deletions(-)
>   create mode 100644 tools/testing/selftests/vDSO/parse_vdso.h
>   create mode 100644 tools/testing/selftests/vDSO/vdso_test_getcpu.c
>   rename tools/testing/selftests/vDSO/{vdso_test.c => vdso_test_gettimeofday.c} (84%)
> 

Thanks Mark. These look good to me. I will apply them for
Linux 5.8-rc1.

thanks,
-- Shuah