Message ID | 20200607131023.3136390-1-martin.blumenstingl@googlemail.com (mailing list archive) |
---|---|
State | Mainlined |
Commit | 03e62fd67d3ab33f39573fc8787d89dc9b4d7255 |
Headers | show |
Series | MIPS: lantiq: xway: sysctrl: fix the GPHY clock alias names | expand |
On 6/7/20 3:10 PM, Martin Blumenstingl wrote: > The dt-bindings for the GSWIP describe that the node should be named > "switch". Use the same name in sysctrl.c so the GSWIP driver can > actually find the "gphy0" and "gphy1" clocks. > > Fixes: 14fceff4771e51 ("net: dsa: Add Lantiq / Intel DSA driver for vrx200") > Cc: stable@vger.kernel.org > Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> Acked-by: Hauke Mehrtens <hauke@hauke-m.de> > --- > arch/mips/lantiq/xway/sysctrl.c | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) > > diff --git a/arch/mips/lantiq/xway/sysctrl.c b/arch/mips/lantiq/xway/sysctrl.c > index aa37545ebe8f..b10342018d19 100644 > --- a/arch/mips/lantiq/xway/sysctrl.c > +++ b/arch/mips/lantiq/xway/sysctrl.c > @@ -514,8 +514,8 @@ void __init ltq_soc_init(void) > clkdev_add_pmu("1e10b308.eth", NULL, 0, 0, PMU_SWITCH | > PMU_PPE_DP | PMU_PPE_TC); > clkdev_add_pmu("1da00000.usif", "NULL", 1, 0, PMU_USIF); > - clkdev_add_pmu("1e108000.gswip", "gphy0", 0, 0, PMU_GPHY); > - clkdev_add_pmu("1e108000.gswip", "gphy1", 0, 0, PMU_GPHY); > + clkdev_add_pmu("1e108000.switch", "gphy0", 0, 0, PMU_GPHY); > + clkdev_add_pmu("1e108000.switch", "gphy1", 0, 0, PMU_GPHY); > clkdev_add_pmu("1e103100.deu", NULL, 1, 0, PMU_DEU); > clkdev_add_pmu("1e116000.mei", "afe", 1, 2, PMU_ANALOG_DSL_AFE); > clkdev_add_pmu("1e116000.mei", "dfe", 1, 0, PMU_DFE); > @@ -538,8 +538,8 @@ void __init ltq_soc_init(void) > PMU_SWITCH | PMU_PPE_DPLUS | PMU_PPE_DPLUM | > PMU_PPE_EMA | PMU_PPE_TC | PMU_PPE_SLL01 | > PMU_PPE_QSB | PMU_PPE_TOP); > - clkdev_add_pmu("1e108000.gswip", "gphy0", 0, 0, PMU_GPHY); > - clkdev_add_pmu("1e108000.gswip", "gphy1", 0, 0, PMU_GPHY); > + clkdev_add_pmu("1e108000.switch", "gphy0", 0, 0, PMU_GPHY); > + clkdev_add_pmu("1e108000.switch", "gphy1", 0, 0, PMU_GPHY); > clkdev_add_pmu("1e103000.sdio", NULL, 1, 0, PMU_SDIO); > clkdev_add_pmu("1e103100.deu", NULL, 1, 0, PMU_DEU); > clkdev_add_pmu("1e116000.mei", "dfe", 1, 0, PMU_DFE); >
On Sun, Jun 07, 2020 at 03:10:23PM +0200, Martin Blumenstingl wrote: > The dt-bindings for the GSWIP describe that the node should be named > "switch". Use the same name in sysctrl.c so the GSWIP driver can > actually find the "gphy0" and "gphy1" clocks. > > Fixes: 14fceff4771e51 ("net: dsa: Add Lantiq / Intel DSA driver for vrx200") > Cc: stable@vger.kernel.org > Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> > --- > arch/mips/lantiq/xway/sysctrl.c | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) applied to mips-fixes. Thomas.
diff --git a/arch/mips/lantiq/xway/sysctrl.c b/arch/mips/lantiq/xway/sysctrl.c index aa37545ebe8f..b10342018d19 100644 --- a/arch/mips/lantiq/xway/sysctrl.c +++ b/arch/mips/lantiq/xway/sysctrl.c @@ -514,8 +514,8 @@ void __init ltq_soc_init(void) clkdev_add_pmu("1e10b308.eth", NULL, 0, 0, PMU_SWITCH | PMU_PPE_DP | PMU_PPE_TC); clkdev_add_pmu("1da00000.usif", "NULL", 1, 0, PMU_USIF); - clkdev_add_pmu("1e108000.gswip", "gphy0", 0, 0, PMU_GPHY); - clkdev_add_pmu("1e108000.gswip", "gphy1", 0, 0, PMU_GPHY); + clkdev_add_pmu("1e108000.switch", "gphy0", 0, 0, PMU_GPHY); + clkdev_add_pmu("1e108000.switch", "gphy1", 0, 0, PMU_GPHY); clkdev_add_pmu("1e103100.deu", NULL, 1, 0, PMU_DEU); clkdev_add_pmu("1e116000.mei", "afe", 1, 2, PMU_ANALOG_DSL_AFE); clkdev_add_pmu("1e116000.mei", "dfe", 1, 0, PMU_DFE); @@ -538,8 +538,8 @@ void __init ltq_soc_init(void) PMU_SWITCH | PMU_PPE_DPLUS | PMU_PPE_DPLUM | PMU_PPE_EMA | PMU_PPE_TC | PMU_PPE_SLL01 | PMU_PPE_QSB | PMU_PPE_TOP); - clkdev_add_pmu("1e108000.gswip", "gphy0", 0, 0, PMU_GPHY); - clkdev_add_pmu("1e108000.gswip", "gphy1", 0, 0, PMU_GPHY); + clkdev_add_pmu("1e108000.switch", "gphy0", 0, 0, PMU_GPHY); + clkdev_add_pmu("1e108000.switch", "gphy1", 0, 0, PMU_GPHY); clkdev_add_pmu("1e103000.sdio", NULL, 1, 0, PMU_SDIO); clkdev_add_pmu("1e103100.deu", NULL, 1, 0, PMU_DEU); clkdev_add_pmu("1e116000.mei", "dfe", 1, 0, PMU_DFE);
The dt-bindings for the GSWIP describe that the node should be named "switch". Use the same name in sysctrl.c so the GSWIP driver can actually find the "gphy0" and "gphy1" clocks. Fixes: 14fceff4771e51 ("net: dsa: Add Lantiq / Intel DSA driver for vrx200") Cc: stable@vger.kernel.org Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> --- arch/mips/lantiq/xway/sysctrl.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)