Message ID | 20200722065257.17943-3-jon.lin@rock-chips.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | [v1,1/3] spi: rockchip: Config spi rx dma burst size depend on xfer length | expand |
Hi Jon, Am Mittwoch, 22. Juli 2020, 08:52:57 CEST schrieb Jon Lin: > The RXFLR is possible larger than rx_left in Rockchip SPI, fix it. > > Signed-off-by: Jon Lin <jon.lin@rock-chips.com> > --- > drivers/spi/spi-rockchip.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/spi/spi-rockchip.c b/drivers/spi/spi-rockchip.c > index a451dacab5cf..1f5e613b67d9 100644 > --- a/drivers/spi/spi-rockchip.c > +++ b/drivers/spi/spi-rockchip.c > @@ -291,7 +291,7 @@ static void rockchip_spi_pio_writer(struct rockchip_spi *rs) > static void rockchip_spi_pio_reader(struct rockchip_spi *rs) > { > u32 words = readl_relaxed(rs->regs + ROCKCHIP_SPI_RXFLR); > - u32 rx_left = rs->rx_left - words; > + u32 rx_left = rs->rx_left > words ? rs->rx_left - words : 0; I guess for future readability of the code braces might be nice, like u32 rx_left = (rs->rx_left > words) ? rs->rx_left - words : 0; But I stumbled onto (and fixed similarly) that issue yesterday as well, so Reviewed-by: Heiko Stuebner <heiko@sntech.de> Heiko
diff --git a/drivers/spi/spi-rockchip.c b/drivers/spi/spi-rockchip.c index a451dacab5cf..1f5e613b67d9 100644 --- a/drivers/spi/spi-rockchip.c +++ b/drivers/spi/spi-rockchip.c @@ -291,7 +291,7 @@ static void rockchip_spi_pio_writer(struct rockchip_spi *rs) static void rockchip_spi_pio_reader(struct rockchip_spi *rs) { u32 words = readl_relaxed(rs->regs + ROCKCHIP_SPI_RXFLR); - u32 rx_left = rs->rx_left - words; + u32 rx_left = rs->rx_left > words ? rs->rx_left - words : 0; /* the hardware doesn't allow us to change fifo threshold * level while spi is enabled, so instead make sure to leave
The RXFLR is possible larger than rx_left in Rockchip SPI, fix it. Signed-off-by: Jon Lin <jon.lin@rock-chips.com> --- drivers/spi/spi-rockchip.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)