Message ID | 20200723073744.13400-20-krzk@kernel.org (mailing list archive) |
---|---|
State | Changes Requested |
Headers | show |
Series | memory: Cleanup, improve and compile test memory drivers | expand |
On Thu, Jul 23, 2020 at 9:39 AM Krzysztof Kozlowski <krzk@kernel.org> wrote: > > do-while is a preferred way for complex macros because of safety > reasons. This fixes checkpatch error: > > ERROR: Macros starting with if should be enclosed by a do - while > loop to avoid possible if/else logic defects > > Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org> This is an improvement, but the macro still has other issues that are just as bad as the one you address: - Using the # operator to avoid the "" in the invocation seems confusing - it implicitly uses the 'cs' and 't' variables of the calling function instead of passing them as arguments. - it calls 'return -1' in a function that otherwise uses errno-style return codes, so this gets interpreted as EPERM "Operation not permitted". I would probably just open-code the entire thing and remove the macro like: ret = 0; ret |= set_gpmc_timing_reg(cs, GPMC_CS_CONFIG2, 0, 3, 0, t->cs_on, GPMC_CD_FCLK, "cs_on"); ret |= set_gpmc_timing_reg(cs, GPMC_CS_CONFIG2, 8, 12, 0, t->cs_rd_off, GPMC_CD_FCLK, "cs_rd_off"); ret |= set_gpmc_timing_reg(cs, GPMC_CS_CONFIG2, 16, 20, 0, t->cs_wr_off, GPMC_CD_FCLK, "cs_wr_off); ... if (ret) return -ENXIO; Of maybe leave the macro, but remove the if/return part and use the "ret |= GPMC_SET_ONE(...)" trick to avoid some of the problems. Arnd
On Thu, Jul 23, 2020 at 11:09:40AM +0200, Arnd Bergmann wrote: > On Thu, Jul 23, 2020 at 9:39 AM Krzysztof Kozlowski <krzk@kernel.org> wrote: > > > > do-while is a preferred way for complex macros because of safety > > reasons. This fixes checkpatch error: > > > > ERROR: Macros starting with if should be enclosed by a do - while > > loop to avoid possible if/else logic defects > > > > Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org> > > This is an improvement, but the macro still has other issues that > are just as bad as the one you address: > > - Using the # operator to avoid the "" in the invocation seems confusing I guess it was useful for debugging. > - it implicitly uses the 'cs' and 't' variables of the calling function instead > of passing them as arguments. Actually another reason to convert it to just a function. > - it calls 'return -1' in a function that otherwise uses errno-style > return codes, so this gets interpreted as EPERM "Operation not > permitted". The users of this macro also do it (gpmc_cs_set_timings()) so this wrong practice is consistent with the driver. :) > > I would probably just open-code the entire thing and remove the > macro like: > > ret = 0; > ret |= set_gpmc_timing_reg(cs, GPMC_CS_CONFIG2, 0, 3, 0, t->cs_on, > GPMC_CD_FCLK, "cs_on"); > ret |= set_gpmc_timing_reg(cs, GPMC_CS_CONFIG2, 8, 12, 0, > t->cs_rd_off, GPMC_CD_FCLK, "cs_rd_off"); > ret |= set_gpmc_timing_reg(cs, GPMC_CS_CONFIG2, 16, 20, 0, > t->cs_wr_off, GPMC_CD_FCLK, "cs_wr_off); > ... > if (ret) > return -ENXIO;a I like this approach because it also removes the 'return' from macro which is not desired. > > Of maybe leave the macro, but remove the if/return part and use > the "ret |= GPMC_SET_ONE(...)" trick to avoid some of the problems. I could probably then keep it as a function. This would be the safest and remove most of the problems here. Best regards, Krzysztof
diff --git a/drivers/memory/omap-gpmc.c b/drivers/memory/omap-gpmc.c index c158b6cae9a9..bb85aa56d247 100644 --- a/drivers/memory/omap-gpmc.c +++ b/drivers/memory/omap-gpmc.c @@ -635,10 +635,12 @@ static int set_gpmc_timing_reg(int cs, int reg, int st_bit, int end_bit, int max return 0; } -#define GPMC_SET_ONE_CD_MAX(reg, st, end, max, field, cd) \ - if (set_gpmc_timing_reg(cs, (reg), (st), (end), (max), \ - t->field, (cd), #field) < 0) \ - return -1 +#define GPMC_SET_ONE_CD_MAX(reg, st, end, max, field, cd) \ + do { \ + if (set_gpmc_timing_reg(cs, (reg), (st), (end), (max), \ + t->field, (cd), #field) < 0) \ + return -1; \ + } while (0) #define GPMC_SET_ONE(reg, st, end, field) \ GPMC_SET_ONE_CD_MAX(reg, st, end, 0, field, GPMC_CD_FCLK)
do-while is a preferred way for complex macros because of safety reasons. This fixes checkpatch error: ERROR: Macros starting with if should be enclosed by a do - while loop to avoid possible if/else logic defects Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org> --- drivers/memory/omap-gpmc.c | 10 ++++++---- 1 file changed, 6 insertions(+), 4 deletions(-)