Message ID | 20200901223059.14801-6-nm@ti.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | arm64: dts: ti: k3-*: Squash up node_name_chars_strict warnings | expand |
On 9/1/20 5:30 PM, Nishanth Menon wrote: > Use temperature-sensor@ naming for nodes following standard conventions of device > tree (section 2.2.2 Generic Names recommendation in [1]). > > [1] https://github.com/devicetree-org/devicetree-specification/tree/v0.3 > > Suggested-by: Suman Anna <s-anna@ti.com> > Suggested-by: Vignesh Raghavendra <vigneshr@ti.com> > Signed-off-by: Nishanth Menon <nm@ti.com> > --- > arch/arm64/boot/dts/ti/k3-am65-wakeup.dtsi | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/arch/arm64/boot/dts/ti/k3-am65-wakeup.dtsi b/arch/arm64/boot/dts/ti/k3-am65-wakeup.dtsi > index bb498be2f0a4..ed42f13e7663 100644 > --- a/arch/arm64/boot/dts/ti/k3-am65-wakeup.dtsi > +++ b/arch/arm64/boot/dts/ti/k3-am65-wakeup.dtsi > @@ -95,7 +95,7 @@ > clock-names = "gpio"; > }; > > - wkup_vtm0: thermal@42050000 { > + wkup_vtm0: temperature-sensor@42050000 { There has been a suggestion to use something like thermal-sensor during the bindings review, but it is better to use this standard node name. Reviewed-by: Suman Anna <s-anna@ti.com> regards Suman > compatible = "ti,am654-vtm"; > reg = <0x42050000 0x25c>; > power-domains = <&k3_pds 80 TI_SCI_PD_EXCLUSIVE>; >
On 11:55-20200902, Suman Anna wrote: > On 9/1/20 5:30 PM, Nishanth Menon wrote: > > Use temperature-sensor@ naming for nodes following standard conventions of device > > tree (section 2.2.2 Generic Names recommendation in [1]). > > > > [1] https://github.com/devicetree-org/devicetree-specification/tree/v0.3 > > > > Suggested-by: Suman Anna <s-anna@ti.com> > > Suggested-by: Vignesh Raghavendra <vigneshr@ti.com> > > Signed-off-by: Nishanth Menon <nm@ti.com> > > --- > > arch/arm64/boot/dts/ti/k3-am65-wakeup.dtsi | 2 +- > > 1 file changed, 1 insertion(+), 1 deletion(-) > > > > diff --git a/arch/arm64/boot/dts/ti/k3-am65-wakeup.dtsi b/arch/arm64/boot/dts/ti/k3-am65-wakeup.dtsi > > index bb498be2f0a4..ed42f13e7663 100644 > > --- a/arch/arm64/boot/dts/ti/k3-am65-wakeup.dtsi > > +++ b/arch/arm64/boot/dts/ti/k3-am65-wakeup.dtsi > > @@ -95,7 +95,7 @@ > > clock-names = "gpio"; > > }; > > > > - wkup_vtm0: thermal@42050000 { > > + wkup_vtm0: temperature-sensor@42050000 { > > There has been a suggestion to use something like thermal-sensor during the > bindings review, but it is better to use this standard node name. Yes - I did notice it as well, and then picked up the recommendation straight from 0.3 spec itself. > > Reviewed-by: Suman Anna <s-anna@ti.com> > > regards > Suman > > > compatible = "ti,am654-vtm"; > > reg = <0x42050000 0x25c>; > > power-domains = <&k3_pds 80 TI_SCI_PD_EXCLUSIVE>; > > >
diff --git a/arch/arm64/boot/dts/ti/k3-am65-wakeup.dtsi b/arch/arm64/boot/dts/ti/k3-am65-wakeup.dtsi index bb498be2f0a4..ed42f13e7663 100644 --- a/arch/arm64/boot/dts/ti/k3-am65-wakeup.dtsi +++ b/arch/arm64/boot/dts/ti/k3-am65-wakeup.dtsi @@ -95,7 +95,7 @@ clock-names = "gpio"; }; - wkup_vtm0: thermal@42050000 { + wkup_vtm0: temperature-sensor@42050000 { compatible = "ti,am654-vtm"; reg = <0x42050000 0x25c>; power-domains = <&k3_pds 80 TI_SCI_PD_EXCLUSIVE>;
Use temperature-sensor@ naming for nodes following standard conventions of device tree (section 2.2.2 Generic Names recommendation in [1]). [1] https://github.com/devicetree-org/devicetree-specification/tree/v0.3 Suggested-by: Suman Anna <s-anna@ti.com> Suggested-by: Vignesh Raghavendra <vigneshr@ti.com> Signed-off-by: Nishanth Menon <nm@ti.com> --- arch/arm64/boot/dts/ti/k3-am65-wakeup.dtsi | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)