Message ID | 20200916232924.129991-1-sonnysasaka@chromium.org (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | [BlueZ] doc/coding-style: Allow spaces after tabs for indenting wrapped lines | expand |
Hi Marcel, On Wed, Sep 16, 2020 at 4:31 PM Sonny Sasaka <sonnysasaka@chromium.org> wrote: > > The "only tabs for indentation" rule was enforced long ago to align with > Linux kernel net coding style. This is no longer the case today so we > are relaxing the coding style to allow spaces after tabs if it can > increase readability. > > --- > doc/coding-style.txt | 7 +++++++ > 1 file changed, 7 insertions(+) > > diff --git a/doc/coding-style.txt b/doc/coding-style.txt > index f0bf880e3..6a7415847 100644 > --- a/doc/coding-style.txt > +++ b/doc/coding-style.txt > @@ -104,9 +104,16 @@ void btd_adapter_register_pin_cb(struct btd_adapter *adapter, > void btd_adapter_register_pin_cb(struct btd_adapter *adapter, > btd_adapter_pin_cb_t cb) > > +5) > +void btd_adapter_register_pin_cb(struct btd_adapter *adapter, > + btd_adapter_pin_cb_t cb) > + > The referred style for line wrapping is to indent as far as possible to the > right without hitting the 80 columns limit. > > +It is acceptable to add padding with spaces after tabs to increase > +readability, for example to indent function arguments at the parenthesis. > + @Marcel: Any thoughts on this change? Id like to apply this so we make the life of people contributing to both kernel and userspace easier. > M5: Space when doing type casting > ================================= > > -- > 2.26.2 >
Hi Sonny, > The "only tabs for indentation" rule was enforced long ago to align with > Linux kernel net coding style. This is no longer the case today so we > are relaxing the coding style to allow spaces after tabs if it can > increase readability. > > --- > doc/coding-style.txt | 7 +++++++ > 1 file changed, 7 insertions(+) > > diff --git a/doc/coding-style.txt b/doc/coding-style.txt > index f0bf880e3..6a7415847 100644 > --- a/doc/coding-style.txt > +++ b/doc/coding-style.txt > @@ -104,9 +104,16 @@ void btd_adapter_register_pin_cb(struct btd_adapter *adapter, > void btd_adapter_register_pin_cb(struct btd_adapter *adapter, > btd_adapter_pin_cb_t cb) > > +5) > +void btd_adapter_register_pin_cb(struct btd_adapter *adapter, > + btd_adapter_pin_cb_t cb) > + > The referred style for line wrapping is to indent as far as possible to the > right without hitting the 80 columns limit. > > +It is acceptable to add padding with spaces after tabs to increase > +readability, for example to indent function arguments at the parenthesis. > + NAK. The userspace style is a bit different than the kernel one. Regards Marcel
[Ping and resending in plain text] Hi Marcel, Could you share the reason behind the "only tab for indentation" rule for userspace code? I find that it is hard to format the code and it'd be good if we adopt the kernel space style indentation as well which increases readability and ease of code formatting. On Thu, Oct 1, 2020 at 12:16 AM Marcel Holtmann <marcel@holtmann.org> wrote: > > Hi Sonny, > > > The "only tabs for indentation" rule was enforced long ago to align with > > Linux kernel net coding style. This is no longer the case today so we > > are relaxing the coding style to allow spaces after tabs if it can > > increase readability. > > > > --- > > doc/coding-style.txt | 7 +++++++ > > 1 file changed, 7 insertions(+) > > > > diff --git a/doc/coding-style.txt b/doc/coding-style.txt > > index f0bf880e3..6a7415847 100644 > > --- a/doc/coding-style.txt > > +++ b/doc/coding-style.txt > > @@ -104,9 +104,16 @@ void btd_adapter_register_pin_cb(struct btd_adapter *adapter, > > void btd_adapter_register_pin_cb(struct btd_adapter *adapter, > > btd_adapter_pin_cb_t cb) > > > > +5) > > +void btd_adapter_register_pin_cb(struct btd_adapter *adapter, > > + btd_adapter_pin_cb_t cb) > > + > > The referred style for line wrapping is to indent as far as possible to the > > right without hitting the 80 columns limit. > > > > +It is acceptable to add padding with spaces after tabs to increase > > +readability, for example to indent function arguments at the parenthesis. > > + > > NAK. The userspace style is a bit different than the kernel one. > > Regards > > Marcel >
Hi Sonny, > Could you share the reason behind the "only tab for indentation" rule > for userspace code? I find that it is hard to format the code and it'd > be good if we adopt the kernel space style indentation as well which > increases readability and ease of code formatting. the coding style in BlueZ userspace is the original coding style that we also keep in other projects like ConnMan, oFono, iwd, ELL etc. So I have no interest in changing it. Kernel patches use different coding style than userspace and that is fine. Regards Marcel
diff --git a/doc/coding-style.txt b/doc/coding-style.txt index f0bf880e3..6a7415847 100644 --- a/doc/coding-style.txt +++ b/doc/coding-style.txt @@ -104,9 +104,16 @@ void btd_adapter_register_pin_cb(struct btd_adapter *adapter, void btd_adapter_register_pin_cb(struct btd_adapter *adapter, btd_adapter_pin_cb_t cb) +5) +void btd_adapter_register_pin_cb(struct btd_adapter *adapter, + btd_adapter_pin_cb_t cb) + The referred style for line wrapping is to indent as far as possible to the right without hitting the 80 columns limit. +It is acceptable to add padding with spaces after tabs to increase +readability, for example to indent function arguments at the parenthesis. + M5: Space when doing type casting =================================