Message ID | 20210107175017.15893-3-nirmoy.das@amd.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | A PCI quirk for resizable BAR 0 on Navi10 | expand |
On Thu, Jan 07, 2021 at 06:50:15PM +0100, Nirmoy Das wrote: > Users of pci_resize_resource() need a way to calculate bar size > from desired bytes. Add a helper function and export it so that > modular drivers can use it. s/bar/BAR/ > Signed-off-by: Darren Salt <devspam@moreofthesa.me.uk> > Signed-off-by: Christian König <christian.koenig@amd.com> > Signed-off-by: Nirmoy Das <nirmoy.das@amd.com> Acked-by: Bjorn Helgaas <bhelgaas@google.com> > --- > drivers/pci/pci.c | 2 +- > include/linux/pci.h | 6 ++++++ > 2 files changed, 7 insertions(+), 1 deletion(-) > > diff --git a/drivers/pci/pci.c b/drivers/pci/pci.c > index ef80ed451415..16216186b51c 100644 > --- a/drivers/pci/pci.c > +++ b/drivers/pci/pci.c > @@ -1648,7 +1648,7 @@ static void pci_restore_rebar_state(struct pci_dev *pdev) > pci_read_config_dword(pdev, pos + PCI_REBAR_CTRL, &ctrl); > bar_idx = ctrl & PCI_REBAR_CTRL_BAR_IDX; > res = pdev->resource + bar_idx; > - size = ilog2(resource_size(res)) - 20; > + size = pci_rebar_bytes_to_size(resource_size(res)); > ctrl &= ~PCI_REBAR_CTRL_BAR_SIZE; > ctrl |= size << PCI_REBAR_CTRL_BAR_SHIFT; > pci_write_config_dword(pdev, pos + PCI_REBAR_CTRL, ctrl); > diff --git a/include/linux/pci.h b/include/linux/pci.h > index 9999040cfad9..77fed01523e0 100644 > --- a/include/linux/pci.h > +++ b/include/linux/pci.h > @@ -1226,6 +1226,12 @@ void pci_update_resource(struct pci_dev *dev, int resno); > int __must_check pci_assign_resource(struct pci_dev *dev, int i); > int __must_check pci_reassign_resource(struct pci_dev *dev, int i, resource_size_t add_size, resource_size_t align); > void pci_release_resource(struct pci_dev *dev, int resno); > +static inline int pci_rebar_bytes_to_size(u64 bytes) > +{ > + bytes = roundup_pow_of_two(bytes); > + return max(ilog2(bytes), 20) - 20; This isn't returning a "size", is it? It looks like it's returning the log2 of the number of MB the BAR will be, i.e., the encoding used by the Resizable BAR Control register "BAR Size" field. Needs a brief comment to that effect and/or a different function name. > +} > + > u32 pci_rebar_get_possible_sizes(struct pci_dev *pdev, int bar); > int __must_check pci_resize_resource(struct pci_dev *dev, int i, int size); > int pci_select_bars(struct pci_dev *dev, unsigned long flags); > -- > 2.29.2 >
I demand that Bjorn Helgaas may or may not have written... >> +static inline int pci_rebar_bytes_to_size(u64 bytes) >> +{ >> + bytes = roundup_pow_of_two(bytes); >> + return max(ilog2(bytes), 20) - 20; > This isn't returning a "size", is it? It looks like it's returning the > log2 of the number of MB the BAR will be, i.e., the encoding used by the > Resizable BAR Control register "BAR Size" field. Needs a brief comment to > that effect and/or a different function name. Given that, it seems to me that pci_rebar_size_to_bytes should be similarly commented and/or renamed.
On Thu, Jan 07, 2021 at 11:31:36PM +0000, Darren Salt wrote: > I demand that Bjorn Helgaas may or may not have written... ? > >> +static inline int pci_rebar_bytes_to_size(u64 bytes) > >> +{ > >> + bytes = roundup_pow_of_two(bytes); > >> + return max(ilog2(bytes), 20) - 20; > > > This isn't returning a "size", is it? It looks like it's returning the > > log2 of the number of MB the BAR will be, i.e., the encoding used by the > > Resizable BAR Control register "BAR Size" field. Needs a brief comment to > > that effect and/or a different function name. > > Given that, it seems to me that pci_rebar_size_to_bytes should be similarly > commented and/or renamed. Makes sense. Something like this is sufficient: return 1ULL << (size + 20); /* Convert PCI_REBAR_CTRL "BAR Size" */
diff --git a/drivers/pci/pci.c b/drivers/pci/pci.c index ef80ed451415..16216186b51c 100644 --- a/drivers/pci/pci.c +++ b/drivers/pci/pci.c @@ -1648,7 +1648,7 @@ static void pci_restore_rebar_state(struct pci_dev *pdev) pci_read_config_dword(pdev, pos + PCI_REBAR_CTRL, &ctrl); bar_idx = ctrl & PCI_REBAR_CTRL_BAR_IDX; res = pdev->resource + bar_idx; - size = ilog2(resource_size(res)) - 20; + size = pci_rebar_bytes_to_size(resource_size(res)); ctrl &= ~PCI_REBAR_CTRL_BAR_SIZE; ctrl |= size << PCI_REBAR_CTRL_BAR_SHIFT; pci_write_config_dword(pdev, pos + PCI_REBAR_CTRL, ctrl); diff --git a/include/linux/pci.h b/include/linux/pci.h index 9999040cfad9..77fed01523e0 100644 --- a/include/linux/pci.h +++ b/include/linux/pci.h @@ -1226,6 +1226,12 @@ void pci_update_resource(struct pci_dev *dev, int resno); int __must_check pci_assign_resource(struct pci_dev *dev, int i); int __must_check pci_reassign_resource(struct pci_dev *dev, int i, resource_size_t add_size, resource_size_t align); void pci_release_resource(struct pci_dev *dev, int resno); +static inline int pci_rebar_bytes_to_size(u64 bytes) +{ + bytes = roundup_pow_of_two(bytes); + return max(ilog2(bytes), 20) - 20; +} + u32 pci_rebar_get_possible_sizes(struct pci_dev *pdev, int bar); int __must_check pci_resize_resource(struct pci_dev *dev, int i, int size); int pci_select_bars(struct pci_dev *dev, unsigned long flags);