Message ID | 20210107132838.396641-8-djrscally@gmail.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | Add functionality to ipu3-cio2 driver allowing software_node connections to sensors on platforms designed for Windows | expand |
On Thu, Jan 07, 2021 at 01:28:30PM +0000, Daniel Scally wrote: > OF, ACPI and software_nodes all implement graphs including nodes for ports > and endpoints. These are all intended to be named with a common schema, > as "port@n" and "endpoint@n" where n is an unsigned int representing the > index of the node. To ensure commonality across the subsystems, provide a > set of macros to define the format. > > Suggested-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com> > Reviewed-by: Andy Shevchenko <andy.shevchenko@gmail.com> > Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> > Signed-off-by: Daniel Scally <djrscally@gmail.com> Reviewed-by: Heikki Krogerus <heikki.krogerus@linux.intel.com> > --- > Changes in v5: > > - Changed commit subject > > include/linux/fwnode.h | 7 +++++++ > 1 file changed, 7 insertions(+) > > diff --git a/include/linux/fwnode.h b/include/linux/fwnode.h > index fde4ad97564c..77414e431e89 100644 > --- a/include/linux/fwnode.h > +++ b/include/linux/fwnode.h > @@ -50,6 +50,13 @@ struct fwnode_endpoint { > const struct fwnode_handle *local_fwnode; > }; > > +/* > + * ports and endpoints defined as software_nodes should all follow a common > + * naming scheme; use these macros to ensure commonality. > + */ > +#define SWNODE_GRAPH_PORT_NAME_FMT "port@%u" > +#define SWNODE_GRAPH_ENDPOINT_NAME_FMT "endpoint@%u" > + > #define NR_FWNODE_REFERENCE_ARGS 8 > > /** > -- > 2.25.1
Hi Rafael, Could you please let us know with an Acked-by if this patch can be merged through the linux-media tree for v5.12 ? The cover letter contains additional details (in a nutshell, this is a cross-tree series and we would like to avoid topic branches). On Thu, Jan 07, 2021 at 01:28:30PM +0000, Daniel Scally wrote: > OF, ACPI and software_nodes all implement graphs including nodes for ports > and endpoints. These are all intended to be named with a common schema, > as "port@n" and "endpoint@n" where n is an unsigned int representing the > index of the node. To ensure commonality across the subsystems, provide a > set of macros to define the format. > > Suggested-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com> > Reviewed-by: Andy Shevchenko <andy.shevchenko@gmail.com> > Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> > Signed-off-by: Daniel Scally <djrscally@gmail.com> > --- > Changes in v5: > > - Changed commit subject > > include/linux/fwnode.h | 7 +++++++ > 1 file changed, 7 insertions(+) > > diff --git a/include/linux/fwnode.h b/include/linux/fwnode.h > index fde4ad97564c..77414e431e89 100644 > --- a/include/linux/fwnode.h > +++ b/include/linux/fwnode.h > @@ -50,6 +50,13 @@ struct fwnode_endpoint { > const struct fwnode_handle *local_fwnode; > }; > > +/* > + * ports and endpoints defined as software_nodes should all follow a common > + * naming scheme; use these macros to ensure commonality. > + */ > +#define SWNODE_GRAPH_PORT_NAME_FMT "port@%u" > +#define SWNODE_GRAPH_ENDPOINT_NAME_FMT "endpoint@%u" > + > #define NR_FWNODE_REFERENCE_ARGS 8 > > /**
On Thu, Jan 7, 2021 at 2:31 PM Daniel Scally <djrscally@gmail.com> wrote: > > OF, ACPI and software_nodes all implement graphs including nodes for ports > and endpoints. These are all intended to be named with a common schema, > as "port@n" and "endpoint@n" where n is an unsigned int representing the > index of the node. To ensure commonality across the subsystems, provide a > set of macros to define the format. > > Suggested-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com> > Reviewed-by: Andy Shevchenko <andy.shevchenko@gmail.com> > Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> > Signed-off-by: Daniel Scally <djrscally@gmail.com> Acked-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com> > --- > Changes in v5: > > - Changed commit subject > > include/linux/fwnode.h | 7 +++++++ > 1 file changed, 7 insertions(+) > > diff --git a/include/linux/fwnode.h b/include/linux/fwnode.h > index fde4ad97564c..77414e431e89 100644 > --- a/include/linux/fwnode.h > +++ b/include/linux/fwnode.h > @@ -50,6 +50,13 @@ struct fwnode_endpoint { > const struct fwnode_handle *local_fwnode; > }; > > +/* > + * ports and endpoints defined as software_nodes should all follow a common > + * naming scheme; use these macros to ensure commonality. > + */ > +#define SWNODE_GRAPH_PORT_NAME_FMT "port@%u" > +#define SWNODE_GRAPH_ENDPOINT_NAME_FMT "endpoint@%u" > + > #define NR_FWNODE_REFERENCE_ARGS 8 > > /** > -- > 2.25.1 >
On Sat, Jan 9, 2021 at 3:06 AM Laurent Pinchart <laurent.pinchart@ideasonboard.com> wrote: > > Hi Rafael, > > Could you please let us know with an Acked-by Done, sorry for the delay. > if this patch can be merged through the linux-media tree for v5.12 ? Yes, it can. Thanks!
diff --git a/include/linux/fwnode.h b/include/linux/fwnode.h index fde4ad97564c..77414e431e89 100644 --- a/include/linux/fwnode.h +++ b/include/linux/fwnode.h @@ -50,6 +50,13 @@ struct fwnode_endpoint { const struct fwnode_handle *local_fwnode; }; +/* + * ports and endpoints defined as software_nodes should all follow a common + * naming scheme; use these macros to ensure commonality. + */ +#define SWNODE_GRAPH_PORT_NAME_FMT "port@%u" +#define SWNODE_GRAPH_ENDPOINT_NAME_FMT "endpoint@%u" + #define NR_FWNODE_REFERENCE_ARGS 8 /**