mbox series

[0/3] Pipe DMC Prep patches

Message ID 20210428211249.11037-1-anusha.srivatsa@intel.com (mailing list archive)
Headers show
Series Pipe DMC Prep patches | expand

Message

Srivatsa, Anusha April 28, 2021, 9:12 p.m. UTC
This series adds the prep work needed before the
actual Pipe DMC implementation.

Anusha Srivatsa (3):
  drm/i915/csr: s/DRM_ERROR/drm_err
  drm/i915/csr: Add intel_csr_has_dmc_payload() helper
  drm/i915/csr: Introduce DMC_FW_MAIN

 drivers/gpu/drm/i915/display/intel_csr.c      | 94 +++++++++----------
 drivers/gpu/drm/i915/display/intel_csr.h      | 33 +++++++
 .../drm/i915/display/intel_display_debugfs.c  |  4 +-
 .../drm/i915/display/intel_display_power.c    | 16 ++--
 drivers/gpu/drm/i915/i915_drv.h               | 18 +---
 drivers/gpu/drm/i915/i915_gpu_error.c         |  2 +-
 6 files changed, 92 insertions(+), 75 deletions(-)

Comments

Jani Nikula May 3, 2021, 6:12 p.m. UTC | #1
On Wed, 28 Apr 2021, Anusha Srivatsa <anusha.srivatsa@intel.com> wrote:
> This series adds the prep work needed before the
> actual Pipe DMC implementation.

When should we rename csr to dmc all over the place?

BR,
Jani.

>
> Anusha Srivatsa (3):
>   drm/i915/csr: s/DRM_ERROR/drm_err
>   drm/i915/csr: Add intel_csr_has_dmc_payload() helper
>   drm/i915/csr: Introduce DMC_FW_MAIN
>
>  drivers/gpu/drm/i915/display/intel_csr.c      | 94 +++++++++----------
>  drivers/gpu/drm/i915/display/intel_csr.h      | 33 +++++++
>  .../drm/i915/display/intel_display_debugfs.c  |  4 +-
>  .../drm/i915/display/intel_display_power.c    | 16 ++--
>  drivers/gpu/drm/i915/i915_drv.h               | 18 +---
>  drivers/gpu/drm/i915/i915_gpu_error.c         |  2 +-
>  6 files changed, 92 insertions(+), 75 deletions(-)
Jani Nikula May 5, 2021, 6:40 a.m. UTC | #2
On Mon, 03 May 2021, Jani Nikula <jani.nikula@linux.intel.com> wrote:
> On Wed, 28 Apr 2021, Anusha Srivatsa <anusha.srivatsa@intel.com> wrote:
>> This series adds the prep work needed before the
>> actual Pipe DMC implementation.
>
> When should we rename csr to dmc all over the place?

To elaborate, I think it's pretty confusing that we use both CSR and DMC
acronyms in code. There may be a distinction, but we don't respect that
in the usage. Sure, the spec mentions both, but I don't think we follow
the naming there either.

I think we should just rename all CSR references to DMC, including the
file name and the function and struct names.

I wonder if it would be better to do the renames first before starting
to build a lot of changes on top.

BR,
Jani.
Srivatsa, Anusha May 5, 2021, 5:36 p.m. UTC | #3
> -----Original Message-----
> From: Jani Nikula <jani.nikula@linux.intel.com>
> Sent: Tuesday, May 4, 2021 11:41 PM
> To: Srivatsa, Anusha <anusha.srivatsa@intel.com>; intel-
> gfx@lists.freedesktop.org
> Subject: Re: [Intel-gfx] [PATCH 0/3] Pipe DMC Prep patches
> 
> On Mon, 03 May 2021, Jani Nikula <jani.nikula@linux.intel.com> wrote:
> > On Wed, 28 Apr 2021, Anusha Srivatsa <anusha.srivatsa@intel.com>
> wrote:
> >> This series adds the prep work needed before the actual Pipe DMC
> >> implementation.
> >
> > When should we rename csr to dmc all over the place?
> 
> To elaborate, I think it's pretty confusing that we use both CSR and DMC
> acronyms in code. There may be a distinction, but we don't respect that in
> the usage. Sure, the spec mentions both, but I don't think we follow the
> naming there either.
> 
> I think we should just rename all CSR references to DMC, including the file
> name and the function and struct names.
>
Just eyeballing the source file, it looks like it is a good way to go. We have function names like parse_csr_fw_dmc which can be changed to just parse_dmc_fw_header or something on those lines...

> I wonder if it would be better to do the renames first before starting to build
> a lot of changes on top.

Yes. The renames will affect some things that this series touches as well.

Anusha
> BR,
> Jani.
> 
> 
> --
> Jani Nikula, Intel Open Source Graphics Center