Message ID | 20210504132350.4693-3-longman@redhat.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | mm: memcg/slab: Fix objcg pointer array handling problem | expand |
On 5/4/21 3:23 PM, Waiman Long wrote: > There are currently two problems in the way the objcg pointer array > (memcg_data) in the page structure is being allocated and freed. > > On its allocation, it is possible that the allocated objcg pointer > array comes from the same slab that requires memory accounting. If this > happens, the slab will never become empty again as there is at least > one object left (the obj_cgroup array) in the slab. > > When it is freed, the objcg pointer array object may be the last one > in its slab and hence causes kfree() to be called again. With the > right workload, the slab cache may be set up in a way that allows the > recursive kfree() calling loop to nest deep enough to cause a kernel > stack overflow and panic the system. > > One way to solve this problem is to split the kmalloc-<n> caches > (KMALLOC_NORMAL) into two separate sets - a new set of kmalloc-<n> > (KMALLOC_NORMAL) caches for non-accounted objects only and a new set of > kmalloc-cg-<n> (KMALLOC_CGROUP) caches for accounted objects only. All > the other caches can allow a mix of accounted and non-accounted objects. > > With this change, all the objcg pointer array objects will come from > KMALLOC_NORMAL caches which won't have their objcg pointer arrays. So > both the recursive kfree() problem and non-freeable slab problem > are gone. > > The new KMALLOC_CGROUP is added between KMALLOC_NORMAL and > KMALLOC_RECLAIM so that the first for loop in create_kmalloc_caches() > will include the newly added caches without change. Great, thanks I hope there would be also benefits to objcg arrays not created for all the normal caches anymore (possibly poorly used due to mix of accounted and non-accounted objects in the same cache) and perhaps it's possible for you to quantify the reduction of those? > Suggested-by: Vlastimil Babka <vbabka@suse.cz> > Signed-off-by: Waiman Long <longman@redhat.com> ... > @@ -321,6 +328,14 @@ kmalloc_caches[NR_KMALLOC_TYPES][KMALLOC_SHIFT_HIGH + 1]; > > static __always_inline enum kmalloc_cache_type kmalloc_type(gfp_t flags) > { > +#ifdef CONFIG_MEMCG_KMEM > + /* > + * KMALLOC_CGROUP for non-reclaimable and non-DMA object with > + * accounting enabled. > + */ > + if ((flags & (__GFP_DMA | __GFP_RECLAIMABLE | __GFP_ACCOUNT)) == __GFP_ACCOUNT) > + return KMALLOC_CGROUP; > +#endif This function was designed so that KMALLOC_NORMAL would be the first tested and returned possibility, as it's expected to be the most common. What about the following on top? ----8<---- diff --git a/include/linux/slab.h b/include/linux/slab.h index fca03c22ea7c..418c5df0305b 100644 --- a/include/linux/slab.h +++ b/include/linux/slab.h @@ -328,30 +328,40 @@ kmalloc_caches[NR_KMALLOC_TYPES][KMALLOC_SHIFT_HIGH + 1]; static __always_inline enum kmalloc_cache_type kmalloc_type(gfp_t flags) { -#ifdef CONFIG_MEMCG_KMEM /* - * KMALLOC_CGROUP for non-reclaimable and non-DMA object with - * accounting enabled. + * The most common case is KMALLOC_NORMAL, so test for it + * with a single branch for all flags that might affect it */ - if ((flags & (__GFP_DMA | __GFP_RECLAIMABLE | __GFP_ACCOUNT)) == __GFP_ACCOUNT) - return KMALLOC_CGROUP; + if (likely((flags & (__GFP_RECLAIMABLE +#ifdef CONFIG_MEMCG_KMEM + | __GFP_ACCOUNT #endif #ifdef CONFIG_ZONE_DMA - /* - * The most common case is KMALLOC_NORMAL, so test for it - * with a single branch for both flags. - */ - if (likely((flags & (__GFP_DMA | __GFP_RECLAIMABLE)) == 0)) + | __GFP_DMA +#endif + )) == 0)) return KMALLOC_NORMAL; +#ifdef CONFIG_MEMCG_KMEM /* - * At least one of the flags has to be set. If both are, __GFP_DMA - * is more important. + * KMALLOC_CGROUP for non-reclaimable and non-DMA object with + * accounting enabled. */ - return flags & __GFP_DMA ? KMALLOC_DMA : KMALLOC_RECLAIM; -#else - return flags & __GFP_RECLAIMABLE ? KMALLOC_RECLAIM : KMALLOC_NORMAL; + if ((flags & (__GFP_ACCOUNT | __GFP_RECLAIMABLE +#ifdef CONFIG_ZONE_DMA + | __GFP_DMA +#endif + )) == __GFP_ACCOUNT) + return KMALLOC_CGROUP; #endif + +#ifdef CONFIG_ZONE_DMA + if (flags & __GFP_DMA) + return KMALLOC_DMA; +#endif + + /* if we got here, it has to be __GFP_RECLAIMABLE */ + return KMALLOC_RECLAIM; } /*
On 5/4/21 12:01 PM, Vlastimil Babka wrote: > On 5/4/21 3:23 PM, Waiman Long wrote: >> There are currently two problems in the way the objcg pointer array >> (memcg_data) in the page structure is being allocated and freed. >> >> On its allocation, it is possible that the allocated objcg pointer >> array comes from the same slab that requires memory accounting. If this >> happens, the slab will never become empty again as there is at least >> one object left (the obj_cgroup array) in the slab. >> >> When it is freed, the objcg pointer array object may be the last one >> in its slab and hence causes kfree() to be called again. With the >> right workload, the slab cache may be set up in a way that allows the >> recursive kfree() calling loop to nest deep enough to cause a kernel >> stack overflow and panic the system. >> >> One way to solve this problem is to split the kmalloc-<n> caches >> (KMALLOC_NORMAL) into two separate sets - a new set of kmalloc-<n> >> (KMALLOC_NORMAL) caches for non-accounted objects only and a new set of >> kmalloc-cg-<n> (KMALLOC_CGROUP) caches for accounted objects only. All >> the other caches can allow a mix of accounted and non-accounted objects. >> >> With this change, all the objcg pointer array objects will come from >> KMALLOC_NORMAL caches which won't have their objcg pointer arrays. So >> both the recursive kfree() problem and non-freeable slab problem >> are gone. >> >> The new KMALLOC_CGROUP is added between KMALLOC_NORMAL and >> KMALLOC_RECLAIM so that the first for loop in create_kmalloc_caches() >> will include the newly added caches without change. > Great, thanks I hope there would be also benefits to objcg arrays not > created for all the normal caches anymore (possibly poorly used due to > mix of accounted and non-accounted objects in the same cache) and perhaps > it's possible for you to quantify the reduction of those? Right, I will update the commit log to mention that as well. Thanks! >> Suggested-by: Vlastimil Babka <vbabka@suse.cz> >> Signed-off-by: Waiman Long <longman@redhat.com> > ... > >> @@ -321,6 +328,14 @@ kmalloc_caches[NR_KMALLOC_TYPES][KMALLOC_SHIFT_HIGH + 1]; >> >> static __always_inline enum kmalloc_cache_type kmalloc_type(gfp_t flags) >> { >> +#ifdef CONFIG_MEMCG_KMEM >> + /* >> + * KMALLOC_CGROUP for non-reclaimable and non-DMA object with >> + * accounting enabled. >> + */ >> + if ((flags & (__GFP_DMA | __GFP_RECLAIMABLE | __GFP_ACCOUNT)) == __GFP_ACCOUNT) >> + return KMALLOC_CGROUP; >> +#endif > This function was designed so that KMALLOC_NORMAL would be the first tested and > returned possibility, as it's expected to be the most common. What about the > following on top? > > ----8<---- > diff --git a/include/linux/slab.h b/include/linux/slab.h > index fca03c22ea7c..418c5df0305b 100644 > --- a/include/linux/slab.h > +++ b/include/linux/slab.h > @@ -328,30 +328,40 @@ kmalloc_caches[NR_KMALLOC_TYPES][KMALLOC_SHIFT_HIGH + 1]; > > static __always_inline enum kmalloc_cache_type kmalloc_type(gfp_t flags) > { > -#ifdef CONFIG_MEMCG_KMEM > /* > - * KMALLOC_CGROUP for non-reclaimable and non-DMA object with > - * accounting enabled. > + * The most common case is KMALLOC_NORMAL, so test for it > + * with a single branch for all flags that might affect it > */ > - if ((flags & (__GFP_DMA | __GFP_RECLAIMABLE | __GFP_ACCOUNT)) == __GFP_ACCOUNT) > - return KMALLOC_CGROUP; > + if (likely((flags & (__GFP_RECLAIMABLE > +#ifdef CONFIG_MEMCG_KMEM > + | __GFP_ACCOUNT > #endif > #ifdef CONFIG_ZONE_DMA > - /* > - * The most common case is KMALLOC_NORMAL, so test for it > - * with a single branch for both flags. > - */ > - if (likely((flags & (__GFP_DMA | __GFP_RECLAIMABLE)) == 0)) > + | __GFP_DMA > +#endif > + )) == 0)) > return KMALLOC_NORMAL; > > +#ifdef CONFIG_MEMCG_KMEM > /* > - * At least one of the flags has to be set. If both are, __GFP_DMA > - * is more important. > + * KMALLOC_CGROUP for non-reclaimable and non-DMA object with > + * accounting enabled. > */ > - return flags & __GFP_DMA ? KMALLOC_DMA : KMALLOC_RECLAIM; > -#else > - return flags & __GFP_RECLAIMABLE ? KMALLOC_RECLAIM : KMALLOC_NORMAL; > + if ((flags & (__GFP_ACCOUNT | __GFP_RECLAIMABLE > +#ifdef CONFIG_ZONE_DMApropose this to the customer as proposing this will create a lot of confusion > + | __GFP_DMA > +#endif > + )) == __GFP_ACCOUNT) > + return KMALLOC_CGROUP; > #endif > + > +#ifdef CONFIG_ZONE_DMA > + if (flags & __GFP_DMA) > + return KMALLOC_DMA; > +#endif > + > + /* if we got here, it has to be __GFP_RECLAIMABLE */ > + return KMALLOC_RECLAIM; > } > > /* > OK, I will make KMALLOC_NORMAL the first in the test. However the proposed change is a bit hard to read, so I will probably change it a bit. Thanks, Longman
diff --git a/include/linux/slab.h b/include/linux/slab.h index 0c97d788762c..fca03c22ea7c 100644 --- a/include/linux/slab.h +++ b/include/linux/slab.h @@ -305,9 +305,16 @@ static inline void __check_heap_object(const void *ptr, unsigned long n, /* * Whenever changing this, take care of that kmalloc_type() and * create_kmalloc_caches() still work as intended. + * + * KMALLOC_NORMAL is for non-accounted objects only whereas KMALLOC_CGROUP + * is for accounted objects only. All the other kmem caches can have both + * accounted and non-accounted objects. */ enum kmalloc_cache_type { KMALLOC_NORMAL = 0, +#ifdef CONFIG_MEMCG_KMEM + KMALLOC_CGROUP, +#endif KMALLOC_RECLAIM, #ifdef CONFIG_ZONE_DMA KMALLOC_DMA, @@ -321,6 +328,14 @@ kmalloc_caches[NR_KMALLOC_TYPES][KMALLOC_SHIFT_HIGH + 1]; static __always_inline enum kmalloc_cache_type kmalloc_type(gfp_t flags) { +#ifdef CONFIG_MEMCG_KMEM + /* + * KMALLOC_CGROUP for non-reclaimable and non-DMA object with + * accounting enabled. + */ + if ((flags & (__GFP_DMA | __GFP_RECLAIMABLE | __GFP_ACCOUNT)) == __GFP_ACCOUNT) + return KMALLOC_CGROUP; +#endif #ifdef CONFIG_ZONE_DMA /* * The most common case is KMALLOC_NORMAL, so test for it diff --git a/mm/slab_common.c b/mm/slab_common.c index f8833d3e5d47..d750e3ba7af5 100644 --- a/mm/slab_common.c +++ b/mm/slab_common.c @@ -727,21 +727,25 @@ struct kmem_cache *kmalloc_slab(size_t size, gfp_t flags) } #ifdef CONFIG_ZONE_DMA -#define INIT_KMALLOC_INFO(__size, __short_size) \ -{ \ - .name[KMALLOC_NORMAL] = "kmalloc-" #__short_size, \ - .name[KMALLOC_RECLAIM] = "kmalloc-rcl-" #__short_size, \ - .name[KMALLOC_DMA] = "dma-kmalloc-" #__short_size, \ - .size = __size, \ -} +#define KMALLOC_DMA_NAME(sz) .name[KMALLOC_DMA] = "dma-kmalloc-" #sz, +#else +#define KMALLOC_DMA_NAME(sz) +#endif + +#ifdef CONFIG_MEMCG_KMEM +#define KMALLOC_CGROUP_NAME(sz) .name[KMALLOC_CGROUP] = "kmalloc-cg-" #sz, #else +#define KMALLOC_CGROUP_NAME(sz) +#endif + #define INIT_KMALLOC_INFO(__size, __short_size) \ { \ .name[KMALLOC_NORMAL] = "kmalloc-" #__short_size, \ .name[KMALLOC_RECLAIM] = "kmalloc-rcl-" #__short_size, \ + KMALLOC_CGROUP_NAME(__short_size) \ + KMALLOC_DMA_NAME(__short_size) \ .size = __size, \ } -#endif /* * kmalloc_info[] is to make slub_debug=,kmalloc-xx option work at boot time. @@ -847,6 +851,9 @@ void __init create_kmalloc_caches(slab_flags_t flags) int i; enum kmalloc_cache_type type; + /* + * Including KMALLOC_CGROUP if CONFIG_MEMCG_KMEM defined + */ for (type = KMALLOC_NORMAL; type <= KMALLOC_RECLAIM; type++) { for (i = KMALLOC_SHIFT_LOW; i <= KMALLOC_SHIFT_HIGH; i++) { if (!kmalloc_caches[type][i])
There are currently two problems in the way the objcg pointer array (memcg_data) in the page structure is being allocated and freed. On its allocation, it is possible that the allocated objcg pointer array comes from the same slab that requires memory accounting. If this happens, the slab will never become empty again as there is at least one object left (the obj_cgroup array) in the slab. When it is freed, the objcg pointer array object may be the last one in its slab and hence causes kfree() to be called again. With the right workload, the slab cache may be set up in a way that allows the recursive kfree() calling loop to nest deep enough to cause a kernel stack overflow and panic the system. One way to solve this problem is to split the kmalloc-<n> caches (KMALLOC_NORMAL) into two separate sets - a new set of kmalloc-<n> (KMALLOC_NORMAL) caches for non-accounted objects only and a new set of kmalloc-cg-<n> (KMALLOC_CGROUP) caches for accounted objects only. All the other caches can allow a mix of accounted and non-accounted objects. With this change, all the objcg pointer array objects will come from KMALLOC_NORMAL caches which won't have their objcg pointer arrays. So both the recursive kfree() problem and non-freeable slab problem are gone. The new KMALLOC_CGROUP is added between KMALLOC_NORMAL and KMALLOC_RECLAIM so that the first for loop in create_kmalloc_caches() will include the newly added caches without change. Suggested-by: Vlastimil Babka <vbabka@suse.cz> Signed-off-by: Waiman Long <longman@redhat.com> --- include/linux/slab.h | 15 +++++++++++++++ mm/slab_common.c | 23 +++++++++++++++-------- 2 files changed, 30 insertions(+), 8 deletions(-)