Message ID | 20210514081100.16196-1-yuehaibing@huawei.com (mailing list archive) |
---|---|
State | Accepted |
Commit | 5a3f869c5b4d230b60ba0197c10506dd4ae30851 |
Headers | show |
Series | [-next] ASoC: soc-core: use DEVICE_ATTR_RO macro | expand |
On Fri, May 14, 2021 at 04:11:00PM +0800, YueHaibing wrote: > -static ssize_t pmdown_time_set(struct device *dev, > - struct device_attribute *attr, > - const char *buf, size_t count) > +static ssize_t pmdown_time_store(struct device *dev, > + struct device_attribute *attr, > + const char *buf, size_t count) This unrelated formatting change should be in a separate patch.
On 2021/5/14 20:24, Mark Brown wrote: > On Fri, May 14, 2021 at 04:11:00PM +0800, YueHaibing wrote: > >> -static ssize_t pmdown_time_set(struct device *dev, >> - struct device_attribute *attr, >> - const char *buf, size_t count) >> +static ssize_t pmdown_time_store(struct device *dev, >> + struct device_attribute *attr, >> + const char *buf, size_t count) > > This unrelated formatting change should be in a separate patch. This change pmdown_time_set() to pmdown_time_store(), which trigger checkpatch warning. >
On Fri, 14 May 2021 16:11:00 +0800, YueHaibing wrote: > Use DEVICE_ATTR_RO helper instead of plain DEVICE_ATTR, > which makes the code a bit shorter and easier to read. Applied to https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next Thanks! [1/1] ASoC: soc-core: use DEVICE_ATTR_RO macro commit: 5a3f869c5b4d230b60ba0197c10506dd4ae30851 All being well this means that it will be integrated into the linux-next tree (usually sometime in the next 24 hours) and sent to Linus during the next merge window (or sooner if it is a bug fix), however if problems are discovered then the patch may be dropped or reverted. You may get further e-mails resulting from automated or manual testing and review of the tree, please engage with people reporting problems and send followup patches addressing any issues that are reported if needed. If any updates are required or you are submitting further changes they should be sent as incremental updates against current git, existing patches will not be replaced. Please add any relevant lists and maintainers to the CCs when replying to this mail. Thanks, Mark
diff --git a/sound/soc/soc-core.c b/sound/soc/soc-core.c index 1c0904acb935..2d969e31f37d 100644 --- a/sound/soc/soc-core.c +++ b/sound/soc/soc-core.c @@ -75,9 +75,9 @@ static ssize_t pmdown_time_show(struct device *dev, return sprintf(buf, "%ld\n", rtd->pmdown_time); } -static ssize_t pmdown_time_set(struct device *dev, - struct device_attribute *attr, - const char *buf, size_t count) +static ssize_t pmdown_time_store(struct device *dev, + struct device_attribute *attr, + const char *buf, size_t count) { struct snd_soc_pcm_runtime *rtd = dev_get_drvdata(dev); int ret; @@ -89,7 +89,7 @@ static ssize_t pmdown_time_set(struct device *dev, return count; } -static DEVICE_ATTR(pmdown_time, 0644, pmdown_time_show, pmdown_time_set); +static DEVICE_ATTR_RW(pmdown_time); static struct attribute *soc_dev_attrs[] = { &dev_attr_pmdown_time.attr,
Use DEVICE_ATTR_RO helper instead of plain DEVICE_ATTR, which makes the code a bit shorter and easier to read. Signed-off-by: YueHaibing <yuehaibing@huawei.com> --- sound/soc/soc-core.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)