Message ID | 20210602114339.11223-5-thunder.leizhen@huawei.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | mfd: use DEVICE_ATTR_* macro to simplify code | expand |
On Wed, 02 Jun 2021, Zhen Lei wrote: > Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes > the code a bit shorter and easier to read. > > Signed-off-by: Zhen Lei <thunder.leizhen@huawei.com> > --- > drivers/mfd/sm501.c | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) Applied, thanks.
diff --git a/drivers/mfd/sm501.c b/drivers/mfd/sm501.c index 6d2f4a0a901dc08..bc0a2c38653e51c 100644 --- a/drivers/mfd/sm501.c +++ b/drivers/mfd/sm501.c @@ -1190,13 +1190,13 @@ static int sm501_register_gpio_i2c(struct sm501_devdata *sm, return 0; } -/* sm501_dbg_regs +/* dbg_regs_show * * Debug attribute to attach to parent device to show core registers */ -static ssize_t sm501_dbg_regs(struct device *dev, - struct device_attribute *attr, char *buff) +static ssize_t dbg_regs_show(struct device *dev, + struct device_attribute *attr, char *buff) { struct sm501_devdata *sm = dev_get_drvdata(dev) ; unsigned int reg; @@ -1213,7 +1213,7 @@ static ssize_t sm501_dbg_regs(struct device *dev, } -static DEVICE_ATTR(dbg_regs, 0444, sm501_dbg_regs, NULL); +static DEVICE_ATTR_RO(dbg_regs); /* sm501_init_reg *
Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes the code a bit shorter and easier to read. Signed-off-by: Zhen Lei <thunder.leizhen@huawei.com> --- drivers/mfd/sm501.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)