Message ID | 1626415089-57584-1-git-send-email-zhangshaokun@hisilicon.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | [v2] arm64: cpufeature: Use defined macro instead of magic numbers | expand |
On Fri, Jul 16, 2021 at 01:58:09PM +0800, Shaokun Zhang wrote: > Use defined macro to simplify the code and make it more readable. > > Cc: Catalin Marinas <catalin.marinas@arm.com> > Cc: Will Deacon <will@kernel.org> > Cc: Marc Zyngier <maz@kernel.org> > Signed-off-by: Shaokun Zhang <zhangshaokun@hisilicon.com> > --- > ChangeLog: > v1-->v2: > 1. Address Will's comment to make code more readable. > > arch/arm64/kernel/cpufeature.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/arch/arm64/kernel/cpufeature.c b/arch/arm64/kernel/cpufeature.c > index 125d5c9471ac..93004bc8e1e8 100644 > --- a/arch/arm64/kernel/cpufeature.c > +++ b/arch/arm64/kernel/cpufeature.c > @@ -1733,7 +1733,7 @@ static void cpu_has_fwb(const struct arm64_cpu_capabilities *__unused) > u64 val = read_sysreg_s(SYS_CLIDR_EL1); > > /* Check that CLIDR_EL1.LOU{U,IS} are both 0 */ > - WARN_ON(val & (7 << 27 | 7 << 21)); > + WARN_ON(CLIDR_LOUU(val) || CLIDR_LOUIS(val)); Acked-by: Will Deacon <will@kernel.org> Will
On Fri, 16 Jul 2021 13:58:09 +0800, Shaokun Zhang wrote:
> Use defined macro to simplify the code and make it more readable.
Applied to arm64 (for-next/misc), thanks!
[1/1] arm64: cpufeature: Use defined macro instead of magic numbers
https://git.kernel.org/arm64/c/ff85f10ba8e4
diff --git a/arch/arm64/kernel/cpufeature.c b/arch/arm64/kernel/cpufeature.c index 125d5c9471ac..93004bc8e1e8 100644 --- a/arch/arm64/kernel/cpufeature.c +++ b/arch/arm64/kernel/cpufeature.c @@ -1733,7 +1733,7 @@ static void cpu_has_fwb(const struct arm64_cpu_capabilities *__unused) u64 val = read_sysreg_s(SYS_CLIDR_EL1); /* Check that CLIDR_EL1.LOU{U,IS} are both 0 */ - WARN_ON(val & (7 << 27 | 7 << 21)); + WARN_ON(CLIDR_LOUU(val) || CLIDR_LOUIS(val)); } #ifdef CONFIG_ARM64_PAN
Use defined macro to simplify the code and make it more readable. Cc: Catalin Marinas <catalin.marinas@arm.com> Cc: Will Deacon <will@kernel.org> Cc: Marc Zyngier <maz@kernel.org> Signed-off-by: Shaokun Zhang <zhangshaokun@hisilicon.com> --- ChangeLog: v1-->v2: 1. Address Will's comment to make code more readable. arch/arm64/kernel/cpufeature.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)