Message ID | 20210826121006.685257-2-michael@walle.cc (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | drm/etnaviv: IOMMU related fixes | expand |
Am Do., 26. Aug. 2021 um 14:10 Uhr schrieb Michael Walle <michael@walle.cc>: > > There is already a macro for the magic value. Use it. > > Signed-off-by: Michael Walle <michael@walle.cc> Reviewed-by: Christian Gmeiner <christian.gmeiner@gmail.com> I will wait for v2 for the rest of the changes to review. > --- > drivers/gpu/drm/etnaviv/etnaviv_drv.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/gpu/drm/etnaviv/etnaviv_drv.c b/drivers/gpu/drm/etnaviv/etnaviv_drv.c > index 7dcc6392792d..2509b3e85709 100644 > --- a/drivers/gpu/drm/etnaviv/etnaviv_drv.c > +++ b/drivers/gpu/drm/etnaviv/etnaviv_drv.c > @@ -653,7 +653,7 @@ static int __init etnaviv_init(void) > if (!of_device_is_available(np)) > continue; > > - pdev = platform_device_alloc("etnaviv", -1); > + pdev = platform_device_alloc("etnaviv", PLATFORM_DEVID_NONE); > if (!pdev) { > ret = -ENOMEM; > of_node_put(np); > -- > 2.30.2 >
diff --git a/drivers/gpu/drm/etnaviv/etnaviv_drv.c b/drivers/gpu/drm/etnaviv/etnaviv_drv.c index 7dcc6392792d..2509b3e85709 100644 --- a/drivers/gpu/drm/etnaviv/etnaviv_drv.c +++ b/drivers/gpu/drm/etnaviv/etnaviv_drv.c @@ -653,7 +653,7 @@ static int __init etnaviv_init(void) if (!of_device_is_available(np)) continue; - pdev = platform_device_alloc("etnaviv", -1); + pdev = platform_device_alloc("etnaviv", PLATFORM_DEVID_NONE); if (!pdev) { ret = -ENOMEM; of_node_put(np);
There is already a macro for the magic value. Use it. Signed-off-by: Michael Walle <michael@walle.cc> --- drivers/gpu/drm/etnaviv/etnaviv_drv.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)