Message ID | 20210906184333.1855426-10-l.stach@pengutronix.de (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | i.MX8MM GPC improvements and BLK_CTRL driver | expand |
On 06.09.21 20:43, Lucas Stach wrote: > This adds the defines for the power domains provided by the VPU > blk-ctrl. > > Signed-off-by: Lucas Stach <l.stach@pengutronix.de> > --- > include/dt-bindings/power/imx8mm-power.h | 4 ++++ > 1 file changed, 4 insertions(+) > > diff --git a/include/dt-bindings/power/imx8mm-power.h b/include/dt-bindings/power/imx8mm-power.h > index fc9c2e16aadc..38b0a56fd7d0 100644 > --- a/include/dt-bindings/power/imx8mm-power.h > +++ b/include/dt-bindings/power/imx8mm-power.h > @@ -19,4 +19,8 @@ > #define IMX8MM_POWER_DOMAIN_DISPMIX 10 > #define IMX8MM_POWER_DOMAIN_MIPI 11 > > +#define IMX8MM_VPUBLK_PD_G1 0 > +#define IMX8MM_VPUBLK_PD_G2 1 > +#define IMX8MM_VPUBLK_PD_H1 2 I wonder how these defines should be named. Here you have a IMX8MM_*BLK_PD_*, but for the DISP BLK-CTRL you only have IMX8MM_*BLK_* (without the PD). Also in Peng's last approach for this we already have defines for this [1] that have been acked by Rob and might be useful as a reference or you could even pick up Peng's patch and by that carry over the existing R-b/A-b tags. Though, in general I like the shorter versions you provided better. [1] https://patchwork.kernel.org/project/linux-arm-kernel/patch/20210629072941.7980-2-peng.fan@oss.nxp.com/ > + > #endif >
Am Dienstag, dem 07.09.2021 um 09:06 +0200 schrieb Frieder Schrempf: > On 06.09.21 20:43, Lucas Stach wrote: > > This adds the defines for the power domains provided by the VPU > > blk-ctrl. > > > > Signed-off-by: Lucas Stach <l.stach@pengutronix.de> > > --- > > include/dt-bindings/power/imx8mm-power.h | 4 ++++ > > 1 file changed, 4 insertions(+) > > > > diff --git a/include/dt-bindings/power/imx8mm-power.h b/include/dt-bindings/power/imx8mm-power.h > > index fc9c2e16aadc..38b0a56fd7d0 100644 > > --- a/include/dt-bindings/power/imx8mm-power.h > > +++ b/include/dt-bindings/power/imx8mm-power.h > > @@ -19,4 +19,8 @@ > > #define IMX8MM_POWER_DOMAIN_DISPMIX 10 > > #define IMX8MM_POWER_DOMAIN_MIPI 11 > > > > +#define IMX8MM_VPUBLK_PD_G1 0 > > +#define IMX8MM_VPUBLK_PD_G2 1 > > +#define IMX8MM_VPUBLK_PD_H1 2 > > I wonder how these defines should be named. Here you have a > IMX8MM_*BLK_PD_*, but for the DISP BLK-CTRL you only have IMX8MM_*BLK_* > (without the PD). > > Also in Peng's last approach for this we already have defines for this > [1] that have been acked by Rob and might be useful as a reference or > you could even pick up Peng's patch and by that carry over the existing > R-b/A-b tags. > > Though, in general I like the shorter versions you provided better. Good point, we should try to be consistent here. I don't want those names to be overly long, but it should be clear that those are power domain specifiers. IMO the best option is the *BLK_PD* naming, as used in the VPUMIX binding. Regards, Lucas
diff --git a/include/dt-bindings/power/imx8mm-power.h b/include/dt-bindings/power/imx8mm-power.h index fc9c2e16aadc..38b0a56fd7d0 100644 --- a/include/dt-bindings/power/imx8mm-power.h +++ b/include/dt-bindings/power/imx8mm-power.h @@ -19,4 +19,8 @@ #define IMX8MM_POWER_DOMAIN_DISPMIX 10 #define IMX8MM_POWER_DOMAIN_MIPI 11 +#define IMX8MM_VPUBLK_PD_G1 0 +#define IMX8MM_VPUBLK_PD_G2 1 +#define IMX8MM_VPUBLK_PD_H1 2 + #endif
This adds the defines for the power domains provided by the VPU blk-ctrl. Signed-off-by: Lucas Stach <l.stach@pengutronix.de> --- include/dt-bindings/power/imx8mm-power.h | 4 ++++ 1 file changed, 4 insertions(+)