Message ID | 20211004141151.132231-3-andr2000@gmail.com (mailing list archive) |
---|---|
State | Superseded |
Headers | show |
Series | PCI devices passthrough on Arm, part 2 | expand |
Hi Oleksandr, > On 4 Oct 2021, at 3:11 pm, Oleksandr Andrushchenko <andr2000@gmail.com> wrote: > > From: Oleksandr Andrushchenko <oleksandr_andrushchenko@epam.com> > > Add new device type (DEV_PCI) to distinguish PCI devices from platform > DT devices, so some drivers, like IOMMU, can handle PCI devices > differently. > > Also add a helper which is when given a struct device returns the > corresponding struct pci_dev which this device is a part of. > > Because of the header cross-dependencies, e.g. we need both > struct pci_dev and struct arch_pci_dev at the same time, this cannot be > done with an inline. > > Signed-off-by: Oleksandr Andrushchenko <oleksandr_andrushchenko@epam.com> > Reviewed-by: Stefano Stabellini <sstabellini@kernel.org> Reviewed-by: Rahul Singh <rahul.singh@arm.com> Tested-by: Rahul Singh <rahul.singh@arm.com> Regards, Rahul > > Since v2: > - !! dropped Stefano's r-b because of the changes > - simplified dev_to_pci to use a single > container_of(dev, struct pci_dev, arch.dev) (Jan) > Since v1: > - Folded new device type (DEV_PCI) into this patch. > --- > xen/arch/arm/pci/pci.c | 7 +++++++ > xen/include/asm-arm/device.h | 4 ++-- > xen/include/asm-arm/pci.h | 7 +++++++ > 3 files changed, 16 insertions(+), 2 deletions(-) > > diff --git a/xen/arch/arm/pci/pci.c b/xen/arch/arm/pci/pci.c > index 73540045d187..138da19284ab 100644 > --- a/xen/arch/arm/pci/pci.c > +++ b/xen/arch/arm/pci/pci.c > @@ -27,6 +27,13 @@ int arch_pci_clean_pirqs(struct domain *d) > return 0; > } > > +struct pci_dev *dev_to_pci(struct device *dev) > +{ > + ASSERT(dev->type == DEV_PCI); > + > + return container_of(dev, struct pci_dev, arch.dev); > +} > + > static int __init dt_pci_init(void) > { > struct dt_device_node *np; > diff --git a/xen/include/asm-arm/device.h b/xen/include/asm-arm/device.h > index ebe84ea853cd..7bf040560363 100644 > --- a/xen/include/asm-arm/device.h > +++ b/xen/include/asm-arm/device.h > @@ -4,6 +4,7 @@ > enum device_type > { > DEV_DT, > + DEV_PCI, > }; > > struct dev_archdata { > @@ -25,8 +26,7 @@ typedef struct device device_t; > > #include <xen/device_tree.h> > > -/* TODO: Correctly implement dev_is_pci when PCI is supported on ARM */ > -#define dev_is_pci(dev) ((void)(dev), 0) > +#define dev_is_pci(dev) ((dev)->type == DEV_PCI) > #define dev_is_dt(dev) ((dev)->type == DEV_DT) > > enum device_class > diff --git a/xen/include/asm-arm/pci.h b/xen/include/asm-arm/pci.h > index 7cb2e2f1edaf..603a1fc072d1 100644 > --- a/xen/include/asm-arm/pci.h > +++ b/xen/include/asm-arm/pci.h > @@ -26,6 +26,13 @@ struct arch_pci_dev { > struct device dev; > }; > > +/* > + * Because of the header cross-dependencies, e.g. we need both > + * struct pci_dev and struct arch_pci_dev at the same time, this cannot be > + * done with an inline here. Macro can be implemented, but looks scary. > + */ > +struct pci_dev *dev_to_pci(struct device *dev); > + > /* Arch-specific MSI data for vPCI. */ > struct vpci_arch_msi { > }; > -- > 2.25.1 >
diff --git a/xen/arch/arm/pci/pci.c b/xen/arch/arm/pci/pci.c index 73540045d187..138da19284ab 100644 --- a/xen/arch/arm/pci/pci.c +++ b/xen/arch/arm/pci/pci.c @@ -27,6 +27,13 @@ int arch_pci_clean_pirqs(struct domain *d) return 0; } +struct pci_dev *dev_to_pci(struct device *dev) +{ + ASSERT(dev->type == DEV_PCI); + + return container_of(dev, struct pci_dev, arch.dev); +} + static int __init dt_pci_init(void) { struct dt_device_node *np; diff --git a/xen/include/asm-arm/device.h b/xen/include/asm-arm/device.h index ebe84ea853cd..7bf040560363 100644 --- a/xen/include/asm-arm/device.h +++ b/xen/include/asm-arm/device.h @@ -4,6 +4,7 @@ enum device_type { DEV_DT, + DEV_PCI, }; struct dev_archdata { @@ -25,8 +26,7 @@ typedef struct device device_t; #include <xen/device_tree.h> -/* TODO: Correctly implement dev_is_pci when PCI is supported on ARM */ -#define dev_is_pci(dev) ((void)(dev), 0) +#define dev_is_pci(dev) ((dev)->type == DEV_PCI) #define dev_is_dt(dev) ((dev)->type == DEV_DT) enum device_class diff --git a/xen/include/asm-arm/pci.h b/xen/include/asm-arm/pci.h index 7cb2e2f1edaf..603a1fc072d1 100644 --- a/xen/include/asm-arm/pci.h +++ b/xen/include/asm-arm/pci.h @@ -26,6 +26,13 @@ struct arch_pci_dev { struct device dev; }; +/* + * Because of the header cross-dependencies, e.g. we need both + * struct pci_dev and struct arch_pci_dev at the same time, this cannot be + * done with an inline here. Macro can be implemented, but looks scary. + */ +struct pci_dev *dev_to_pci(struct device *dev); + /* Arch-specific MSI data for vPCI. */ struct vpci_arch_msi { };