Message ID | 20211123193723.12112-3-madvenka@linux.microsoft.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | arm64: Reorganize the unwinder and implement stack trace reliability checks | expand |
On Tue, Nov 23, 2021 at 01:37:20PM -0600, madvenka@linux.microsoft.com wrote: > From: "Madhavan T. Venkataraman" <madvenka@linux.microsoft.com> > > Rename unwinder functions for consistency and better naming. > > - Rename start_backtrace() to unwind_start(). > - Rename unwind_frame() to unwind_next(). > - Rename walk_stackframe() to unwind(). Reviewed-by: Mark Brown <broonie@kernel.org>
On Tue, Nov 23, 2021 at 01:37:20PM -0600, madvenka@linux.microsoft.com wrote: > From: "Madhavan T. Venkataraman" <madvenka@linux.microsoft.com> > > Rename unwinder functions for consistency and better naming. > > - Rename start_backtrace() to unwind_start(). > - Rename unwind_frame() to unwind_next(). > - Rename walk_stackframe() to unwind(). Super trivial, but could we s/unwind_start/unwind_init/ ? That makes it slightly clearer that it's not performing an unwind step. Otherwise, this looks good to me. For the rename: Acked-by: Mark Rutland <mark.rutland@arm.com> It's be nice if we could also clean up 'struct stackframe' into 'struct unwind_state', but that can be a follow-up, and this is fine as it is, modulo the super trivial comment above. Thanks, Mark. > > Signed-off-by: Madhavan T. Venkataraman <madvenka@linux.microsoft.com> > --- > arch/arm64/kernel/stacktrace.c | 28 ++++++++++++++-------------- > 1 file changed, 14 insertions(+), 14 deletions(-) > > diff --git a/arch/arm64/kernel/stacktrace.c b/arch/arm64/kernel/stacktrace.c > index 7217c4f63ef7..918852cd2681 100644 > --- a/arch/arm64/kernel/stacktrace.c > +++ b/arch/arm64/kernel/stacktrace.c > @@ -33,8 +33,8 @@ > */ > > > -static void start_backtrace(struct stackframe *frame, unsigned long fp, > - unsigned long pc) > +static void unwind_start(struct stackframe *frame, unsigned long fp, > + unsigned long pc) > { > frame->fp = fp; > frame->pc = pc; > @@ -45,7 +45,7 @@ static void start_backtrace(struct stackframe *frame, unsigned long fp, > /* > * Prime the first unwind. > * > - * In unwind_frame() we'll check that the FP points to a valid stack, > + * In unwind_next() we'll check that the FP points to a valid stack, > * which can't be STACK_TYPE_UNKNOWN, and the first unwind will be > * treated as a transition to whichever stack that happens to be. The > * prev_fp value won't be used, but we set it to 0 such that it is > @@ -63,8 +63,8 @@ static void start_backtrace(struct stackframe *frame, unsigned long fp, > * records (e.g. a cycle), determined based on the location and fp value of A > * and the location (but not the fp value) of B. > */ > -static int notrace unwind_frame(struct task_struct *tsk, > - struct stackframe *frame) > +static int notrace unwind_next(struct task_struct *tsk, > + struct stackframe *frame) > { > unsigned long fp = frame->fp; > struct stack_info info; > @@ -104,7 +104,7 @@ static int notrace unwind_frame(struct task_struct *tsk, > > /* > * Record this frame record's values and location. The prev_fp and > - * prev_type are only meaningful to the next unwind_frame() invocation. > + * prev_type are only meaningful to the next unwind_next() invocation. > */ > frame->fp = READ_ONCE_NOCHECK(*(unsigned long *)(fp)); > frame->pc = READ_ONCE_NOCHECK(*(unsigned long *)(fp + 8)); > @@ -137,27 +137,27 @@ static int notrace unwind_frame(struct task_struct *tsk, > > return 0; > } > -NOKPROBE_SYMBOL(unwind_frame); > +NOKPROBE_SYMBOL(unwind_next); > > -static void notrace walk_stackframe(struct task_struct *tsk, > - unsigned long fp, unsigned long pc, > - bool (*fn)(void *, unsigned long), void *data) > +static void notrace unwind(struct task_struct *tsk, > + unsigned long fp, unsigned long pc, > + bool (*fn)(void *, unsigned long), void *data) > { > struct stackframe frame; > > - start_backtrace(&frame, fp, pc); > + unwind_start(&frame, fp, pc); > > while (1) { > int ret; > > if (!fn(data, frame.pc)) > break; > - ret = unwind_frame(tsk, &frame); > + ret = unwind_next(tsk, &frame); > if (ret < 0) > break; > } > } > -NOKPROBE_SYMBOL(walk_stackframe); > +NOKPROBE_SYMBOL(unwind); > > static bool dump_backtrace_entry(void *arg, unsigned long where) > { > @@ -210,5 +210,5 @@ noinline notrace void arch_stack_walk(stack_trace_consume_fn consume_entry, > fp = thread_saved_fp(task); > pc = thread_saved_pc(task); > } > - walk_stackframe(task, fp, pc, consume_entry, cookie); > + unwind(task, fp, pc, consume_entry, cookie); > } > -- > 2.25.1 >
On 11/30/21 9:08 AM, Mark Rutland wrote: > On Tue, Nov 23, 2021 at 01:37:20PM -0600, madvenka@linux.microsoft.com wrote: >> From: "Madhavan T. Venkataraman" <madvenka@linux.microsoft.com> >> >> Rename unwinder functions for consistency and better naming. >> >> - Rename start_backtrace() to unwind_start(). >> - Rename unwind_frame() to unwind_next(). >> - Rename walk_stackframe() to unwind(). > > Super trivial, but could we s/unwind_start/unwind_init/ ? That makes it > slightly clearer that it's not performing an unwind step. > > Otherwise, this looks good to me. > Will do. > For the rename: > > Acked-by: Mark Rutland <mark.rutland@arm.com> > > It's be nice if we could also clean up 'struct stackframe' into 'struct > unwind_state', but that can be a follow-up, and this is fine as it is, modulo > the super trivial comment above. > I could do this rename as well in the next version if you want. Might as well get all the renaming done in one shot. Thanks, Madhavan
diff --git a/arch/arm64/kernel/stacktrace.c b/arch/arm64/kernel/stacktrace.c index 7217c4f63ef7..918852cd2681 100644 --- a/arch/arm64/kernel/stacktrace.c +++ b/arch/arm64/kernel/stacktrace.c @@ -33,8 +33,8 @@ */ -static void start_backtrace(struct stackframe *frame, unsigned long fp, - unsigned long pc) +static void unwind_start(struct stackframe *frame, unsigned long fp, + unsigned long pc) { frame->fp = fp; frame->pc = pc; @@ -45,7 +45,7 @@ static void start_backtrace(struct stackframe *frame, unsigned long fp, /* * Prime the first unwind. * - * In unwind_frame() we'll check that the FP points to a valid stack, + * In unwind_next() we'll check that the FP points to a valid stack, * which can't be STACK_TYPE_UNKNOWN, and the first unwind will be * treated as a transition to whichever stack that happens to be. The * prev_fp value won't be used, but we set it to 0 such that it is @@ -63,8 +63,8 @@ static void start_backtrace(struct stackframe *frame, unsigned long fp, * records (e.g. a cycle), determined based on the location and fp value of A * and the location (but not the fp value) of B. */ -static int notrace unwind_frame(struct task_struct *tsk, - struct stackframe *frame) +static int notrace unwind_next(struct task_struct *tsk, + struct stackframe *frame) { unsigned long fp = frame->fp; struct stack_info info; @@ -104,7 +104,7 @@ static int notrace unwind_frame(struct task_struct *tsk, /* * Record this frame record's values and location. The prev_fp and - * prev_type are only meaningful to the next unwind_frame() invocation. + * prev_type are only meaningful to the next unwind_next() invocation. */ frame->fp = READ_ONCE_NOCHECK(*(unsigned long *)(fp)); frame->pc = READ_ONCE_NOCHECK(*(unsigned long *)(fp + 8)); @@ -137,27 +137,27 @@ static int notrace unwind_frame(struct task_struct *tsk, return 0; } -NOKPROBE_SYMBOL(unwind_frame); +NOKPROBE_SYMBOL(unwind_next); -static void notrace walk_stackframe(struct task_struct *tsk, - unsigned long fp, unsigned long pc, - bool (*fn)(void *, unsigned long), void *data) +static void notrace unwind(struct task_struct *tsk, + unsigned long fp, unsigned long pc, + bool (*fn)(void *, unsigned long), void *data) { struct stackframe frame; - start_backtrace(&frame, fp, pc); + unwind_start(&frame, fp, pc); while (1) { int ret; if (!fn(data, frame.pc)) break; - ret = unwind_frame(tsk, &frame); + ret = unwind_next(tsk, &frame); if (ret < 0) break; } } -NOKPROBE_SYMBOL(walk_stackframe); +NOKPROBE_SYMBOL(unwind); static bool dump_backtrace_entry(void *arg, unsigned long where) { @@ -210,5 +210,5 @@ noinline notrace void arch_stack_walk(stack_trace_consume_fn consume_entry, fp = thread_saved_fp(task); pc = thread_saved_pc(task); } - walk_stackframe(task, fp, pc, consume_entry, cookie); + unwind(task, fp, pc, consume_entry, cookie); }